当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助:arch makepkg liblunar 出错,该如何解决?谢谢!
帖子发表于 : 2009-09-30 20:37 
头像

注册: 2009-01-19 23:03
帖子: 2354
送出感谢: 5
接收感谢: 0 次
引用:
checking for pkg-config... no
configure: error: You need to have gtk-doc >= 1.0 installed to build gtk-doc
==> 错误: 创建失败。
正在放弃...

引用:
gtk-doc (1.11-2)

Documentation tool for public library API

状态 : 已安装
本地版本 : 1.11-2
仓库里的版本 : 1.11-2


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求助:arch makepkg liblunar 出错,该如何解决?谢谢!
帖子发表于 : 2009-09-30 20:40 
头像

注册: 2007-09-29 3:09
帖子: 5773
送出感谢: 0 次
接收感谢: 3
disable掉咯...


_________________
HUNT Unfortunately No Talent...


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求助:arch makepkg liblunar 出错,该如何解决?谢谢!
帖子发表于 : 2009-09-30 21:19 
头像

注册: 2009-01-19 23:03
帖子: 2354
送出感谢: 5
接收感谢: 0 次
#Maintainer Corvolino <corvolino@archlinux.com.br>
#Contributor yetist <yetist@gmail.com>

pkgname=liblunar
pkgver=2.2.1
pkgrel=1
pkgdesc="Chinese lunar library."
arch=("i686" "x86_64")
url="http://code.google.com/p/liblunar/"
license=('GPL2')
depends=('glib2>=2.12')
makedepends=('glib2>=2.12' 'pygobject')
optdepends=('python: python binding')
source=("http://liblunar.googlecode.com/files/$pkgname-$pkgver.tar.gz")
md5sums=('bc9dd113ab4a5fa77d6c5e352d6b44b7')

build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr --enable-python --enable-gtk-doc || return 1
make || return 1
make DESTDIR=$pkgdir install || return 1
}

红色的地方?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求助:arch makepkg liblunar 出错,该如何解决?谢谢!
帖子发表于 : 2009-10-01 0:55 
头像

注册: 2009-03-13 14:26
帖子: 799
送出感谢: 0 次
接收感谢: 0 次
这包是什么东西?

去掉那个enable或者disable


_________________
http://www.imgplace.com/viewimg220/2882/61715315173.png


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求助:arch makepkg liblunar 出错,该如何解决?谢谢!
帖子发表于 : 2009-10-01 9:18 
头像

注册: 2007-06-05 18:27
帖子: 441
送出感谢: 0 次
接收感谢: 0 次
liblunar 小applet看农历用的吧


_________________
推荐目前为止最优秀的网络备份|文件分享工具Dropbox
Ubuntu 12.04


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 求助:arch makepkg liblunar 出错,该如何解决?谢谢!
帖子发表于 : 2009-10-03 21:56 
头像

注册: 2009-01-19 23:03
帖子: 2354
送出感谢: 5
接收感谢: 0 次
去掉
引用:
--enable-
引用:
checking build system type... Invalid configuration `gtk-doc': machine `gtk' not recognized
configure: error: /bin/sh ./config.sub gtk-doc failed
==> 错误: 创建失败。
正在放弃...


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 求助:arch makepkg liblunar 出错,该如何解决?谢谢!
帖子发表于 : 2009-10-03 22:00 
头像

注册: 2009-01-19 23:03
帖子: 2354
送出感谢: 5
接收感谢: 0 次
xsoul 写道:
liblunar 小applet看农历用的吧

小农历的中间包 :em04
在坛子下了个天气脚本,用conky曲线弄了个农历 :em11
不知道咋整个掌万的桌面


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译