当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : archlinux欺负ruby?
帖子发表于 : 2009-10-10 8:11 
头像

注册: 2007-11-23 9:49
帖子: 1021
送出感谢: 0 次
接收感谢: 1
继ruby过早的升级到1.9之后(rails2.4.4都不支持1.9还不过早?)

我发现gvim无法全能补全ruby了

摸索发现gvim的PKG里面

代码:
--enable-perlinterp --enable-pythoninterp --disable-rubyinterp


:em80 ruby接口被关了。

正在自己编译……

archlinux上的rubyer声音很小


页首
 用户资料  
 
2 楼 
 文章标题 : Re: archlinux欺负ruby?
帖子发表于 : 2009-10-10 8:13 
头像

注册: 2007-11-23 9:49
帖子: 1021
送出感谢: 0 次
接收感谢: 1
:em36 果然是ruby接口没打开编译的问题,重编译能补全了


页首
 用户资料  
 
3 楼 
 文章标题 : Re: archlinux欺负ruby?
帖子发表于 : 2009-10-10 8:15 
头像

注册: 2005-10-04 10:59
帖子: 1928
地址: 上海
送出感谢: 0 次
接收感谢: 1
ruby升个级,这个也破了,那个也坏了。

升到1.9,gems不能用,要设置环境变量才行,上次去ruby官方看了下,当时这个bug已经84天了,没改。rdoc很久不能看ruby自带的函数的文档了,不知何解。

一堆自己写的脚本都不能用了,搞的不敢相信ruby了,慢慢又把脚本写回python。


_________________
弄个dropbox空间来备份文件或者做私人代码服务器
配置:git://github.com/roylez/dotfiles.git
主页:http://roylez.heroku.com
各种稀奇玩意儿:http://dooloo.info


页首
 用户资料  
 
4 楼 
 文章标题 : Re: archlinux欺负ruby?
帖子发表于 : 2009-10-10 8:23 
头像

注册: 2007-11-23 9:49
帖子: 1021
送出感谢: 0 次
接收感谢: 1
:em98 打包者肯定有阴谋,收了python钱,又不见把python升到3.0


页首
 用户资料  
 
5 楼 
 文章标题 : Re: archlinux欺负ruby?
帖子发表于 : 2009-10-10 22:34 
头像

注册: 2009-03-13 14:26
帖子: 799
送出感谢: 0 次
接收感谢: 0 次
ChloeRei 写道:
:em98 打包者肯定有阴谋,收了python钱,又不见把python升到3.0


你这想法就很可以拿去好莱坞拍片了 喜剧片


_________________
http://www.imgplace.com/viewimg220/2882/61715315173.png


页首
 用户资料  
 
6 楼 
 文章标题 : Re: archlinux欺负ruby?
帖子发表于 : 2009-10-10 23:20 
头像

注册: 2007-11-23 9:49
帖子: 1021
送出感谢: 0 次
接收感谢: 1
自己编辑掉


页首
 用户资料  
 
7 楼 
 文章标题 : Re: archlinux欺负ruby?
帖子发表于 : 2009-10-11 17:31 
头像

注册: 2007-08-24 20:16
帖子: 164
地址: Hangzhou, China
送出感谢: 0 次
接收感谢: 0 次
roylez 写道:
ruby升个级,这个也破了,那个也坏了。

升到1.9,gems不能用,要设置环境变量才行,上次去ruby官方看了下,当时这个bug已经84天了,没改。rdoc很久不能看ruby自带的函数的文档了,不知何解。

一堆自己写的脚本都不能用了,搞的不敢相信ruby了,慢慢又把脚本写回python。


这是Arch自行把还没有足够支持的Ruby 1.9作为默认的Ruby的问题,不要把问题扯到Ruby语言上。

rdoc的问题是Ruby的源码中Makefile里把文档生成选项给关了,改下PKGBUILD就可以了。

建议用AUR的Ruby enpterprise 1.8.7。


_________________
http://www.google.com/profiles/chenk85


页首
 用户资料  
 
8 楼 
 文章标题 : Re: archlinux欺负ruby?
帖子发表于 : 2009-10-11 17:54 
头像

注册: 2007-11-23 9:49
帖子: 1021
送出感谢: 0 次
接收感谢: 1
http://aur.archlinux.org/packages.php?ID=25926
我倒,qt4-qtruby被报告1.9不能通过编译

:em20 其实我现在都不用这个包了,用kdebindings-ruby了。

但是不能放弃不装kde又用ruby和qt的人,我要到vbox装个arch才能调试打包了。(主系统一堆gem依赖1.8不想动)

:em06 谁对qt-ruby编译有心得的麻烦帮下忙


页首
 用户资料  
 
9 楼 
 文章标题 : Re: archlinux欺负ruby?
帖子发表于 : 2009-10-11 17:55 
头像

注册: 2009-02-23 17:55
帖子: 342
送出感谢: 0 次
接收感谢: 0 次
:em04 完全看不懂 顶以下把`


_________________
我的linux网站:http://www.kudouzi.com 欢迎访问!!!
我的QQ:53273291 敬请骚扰


页首
 用户资料  
 
10 楼 
 文章标题 : Re: archlinux欺负ruby?
帖子发表于 : 2009-10-11 18:03 
头像

注册: 2007-11-23 9:49
帖子: 1021
送出感谢: 0 次
接收感谢: 1
看了下ruby-enterprise的PKG
http://aur.archlinux.org/packages/ruby- ... e/PKGBUILD

makedepends=('ruby')
:em06 ?编译过程需要装一个ruby的?

update:
哦,官方文档有
Note that this installer is written in Ruby, and thus requires a Ruby interpreter to run. Because not all systems come with a Ruby interpreter by default, the source tarball also contains a number of precompiled Ruby interpreters for various platforms, with the purpose of running the installer. The installer script will automatically use a precompiled Ruby binary for the current platform, if available. Precompiled Ruby interpreters for the following platforms are included

算了,自己机子上开发先不搞复杂。部署环境我也配置不了。


最后由 ChloeRei 编辑于 2009-10-11 18:08,总共编辑了 1 次

页首
 用户资料  
 
11 楼 
 文章标题 : Re: archlinux欺负ruby?
帖子发表于 : 2009-10-11 18:06 
头像

注册: 2005-12-28 1:16
帖子: 3916
地址: 火星
系统: Ubuntu 12.10 X64
送出感谢: 1
接收感谢: 0 次
倒向python吧


_________________
目前负债150多万


页首
 用户资料  
 
12 楼 
 文章标题 : Re: archlinux欺负ruby?
帖子发表于 : 2009-10-11 18:12 
头像

注册: 2007-11-23 9:49
帖子: 1021
送出感谢: 0 次
接收感谢: 1
xhy 写道:
倒向python吧

用惯ruby on rails了阿。在写些小东西,包括在用的blog。
其实我先学的python,不过看错书,用了DIVE INTO PYTHON。一开始就被很多嵌套语法吓住了。看了半本书还无好感。


页首
 用户资料  
 
13 楼 
 文章标题 : Re: archlinux欺负ruby?
帖子发表于 : 2009-10-15 23:32 
头像

注册: 2007-08-24 20:16
帖子: 164
地址: Hangzhou, China
送出感谢: 0 次
接收感谢: 0 次
xhy 写道:
倒向python吧


太搞笑了吧,只是因为某个系统升级了一门熟悉的语言就倒向另一门语言。如果Arch升级py到py3k,那岂不是要倒向Lua?


_________________
http://www.google.com/profiles/chenk85


页首
 用户资料  
 
14 楼 
 文章标题 : Re: archlinux欺负ruby?
帖子发表于 : 2009-10-21 13:52 
头像

注册: 2007-11-23 9:49
帖子: 1021
送出感谢: 0 次
接收感谢: 1
终于修复AUR上的qt4-qtruby,可以在ruby1.9上编译了。

但我自己用的还是1.8.7-svn


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译