当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : [解决]Archlinux rc.conf中..DHCP注释掉就可以进X,不注释就只看见三个终端及小时钟,WHY?
帖子发表于 : 2009-10-27 0:23 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
Archlinux在rc.conf中..DHCP注释掉就可以进X,不注释就只看见三个终端及小时钟,WHY?

我们学校用的是锐捷,我看到在windows下面shi "认证后获取DHCP",不知道是否和这个有关?

当我把ducp注释掉,开启无线的时候,就提示无线:command not found ,是不是我的网卡驱动没做好?(这时候可以进入Gnome桌面)





补充:安装了dhclient后,在注释掉dhcp的情况下也可以上网。10月28日

————————————————————————————————————————————————————————————————————————————————————————————————————————————————--
——————————————————————————————————————————————————————————————————————————————————————————————————————————————————--
解决方式如下--来自wiki ---安装时没认真——
——————————————————————————————————————————————————————————————-----————-
xorg 1.5.x版本里已经开启热插拔Input设备。
Note: 当热插拔开启后, X将清空xorg.conf里所有使用the kbd and mouse 驱动建立的设备。这将导致X被冻结,使得鼠标和键盘失去响应。下面是解决办法。方法只能二选一有两个办法可以修复这一问题:
# pacman -S xf86-input-evdev
# /etc/rc.d/hal start
把hal加入/etc/rc.conf里的DAEMONS列表里,这样每次电脑启动,都会自动开启hal。
说明: 开启hal必须首先有一个dbus用户和用户组,以root身份输入下面命令创建用户和用户组
usr/sbin/groupadd -g 81 dbus
usr/sbin/useradd -c 'System message bus' -u 81 -g dbus -d '/' -s /bin/false dbus
——————————————————————————————————————————————
2) 关闭input设备热插拔:在/etc/X11/xorg.conf的ServerFlags段,加入参数Option "AutoAddDevices" "False" 这将忽略hal的硬件检测,并使用你xorg.conf的keyboard/mouse配置。步骤如下
# nano /etc/X11/xorg.conf
加入下面三行:
Section "ServerFlags"
Option "AutoAddDevices" "False"
EndSection


我选择2.
———————————————————————————————————————————————————————————————————————————————————————————————————————————
———————————————————————————————————————————————————————————————————————————————————————————————————————————


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


最后由 wowoto 编辑于 2009-11-04 0:16,总共编辑了 8 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: Archlinux诡异..DHCP注释掉就可以进X,不注释就只看见三个终端盒小时钟,WHY?
帖子发表于 : 2009-10-27 0:59 
头像

注册: 2005-08-14 19:53
帖子: 3998
送出感谢: 1
接收感谢: 2
你是怎么启动X的?


页首
 用户资料  
 
3 楼 
 文章标题 : ~
帖子发表于 : 2009-10-27 9:40 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
jarryson 写道:
你是怎么启动X的?


当我把rc.conf中的dhcp#了,就可以直接进入gnome桌面~
当我没注释时,只能startx,这时候看到三个终端及小时钟~
有人告诉我网络和启动没关系~~wiki上没说


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Archlinux诡异..DHCP注释掉就可以进X,不注释就只看见三个终端盒小时钟,WHY?
帖子发表于 : 2009-10-27 10:19 
头像

注册: 2007-10-06 18:40
帖子: 4313
送出感谢: 0 次
接收感谢: 5

/etc/inittab


_________________
E=m c^2


页首
 用户资料  
 
5 楼 
 文章标题 : Re: Archlinux诡异..DHCP注释掉就可以进X,不注释就只看见三个终端盒小时钟,WHY?
帖子发表于 : 2009-10-27 12:49 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
syrano 写道:

/etc/inittab


改过了,3和5都试过...我们学校用的是锐捷,我看到在windows下面试认证后获取DHCP,不知道是否和这个有关?当我把ducp注释掉,开启无线的时候,就提示无线:command not found ,是不是我的网卡驱动没做好?


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


页首
 用户资料  
 
6 楼 
 文章标题 : Re: Archlinux诡异..DHCP注释掉就可以进X,不注释就只看见三个终端盒小时钟,WHY?
帖子发表于 : 2009-10-27 12:53 
头像

注册: 2005-08-14 19:53
帖子: 3998
送出感谢: 1
接收感谢: 2
既然是认证后获取,那当然不能启用dhcp服务了。

不过这应该和你启动X没有任何关系


页首
 用户资料  
 
7 楼 
 文章标题 : Re: Archlinux诡异..DHCP注释掉就可以进X,不注释就只看见三个终端盒小时钟,WHY?
帖子发表于 : 2009-10-27 13:03 
头像

注册: 2007-09-29 3:09
帖子: 5773
送出感谢: 0 次
接收感谢: 3
startx那是自己没改x启动的配置,用twm那个默认配置了,大惊小怪...
用/etc/rc.d/gdm start


_________________
HUNT Unfortunately No Talent...


页首
 用户资料  
 
8 楼 
 文章标题 : Re: Archlinux诡异..DHCP注释掉就可以进X,不注释就只看见三个终端盒小时钟,WHY?
帖子发表于 : 2009-10-27 13:09 
头像

注册: 2007-10-06 18:40
帖子: 4313
送出感谢: 0 次
接收感谢: 5
在/etc/rc.conf里
在DAEMONS里的network前面加@


_________________
E=m c^2


页首
 用户资料  
 
9 楼 
 文章标题 : Re: Archlinux诡异..DHCP注释掉就可以进X,不注释就只看见三个终端盒小时钟,WHY?
帖子发表于 : 2009-10-27 13:19 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
syrano 写道:
在/etc/rc.conf里
在DAEMONS里的network前面加@



嗯,是这样的,我安装了networkmanager——现在我要选哪一个比较好?


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


页首
 用户资料  
 
10 楼 
 文章标题 : Re: Archlinux诡异..DHCP注释掉就可以进X,不注释就只看见三个终端盒小时钟,WHY?
帖子发表于 : 2009-10-27 13:20 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
HuntXu 写道:
startx那是自己没改x启动的配置,用twm那个默认配置了,大惊小怪...
用/etc/rc.d/gdm start



ok 我试试看~~谢谢


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


页首
 用户资料  
 
11 楼 
 文章标题 : Re: Archlinux诡异..DHCP注释掉就可以进X,不注释就只看见三个终端盒小时钟,WHY?
帖子发表于 : 2009-10-27 14:30 

注册: 2008-04-20 12:13
帖子: 813
地址: Shanghai, PRC
系统: OS X, Gentoo, Win8.1
送出感谢: 0 次
接收感谢: 1
.xinitrc下你怎么设置的?


页首
 用户资料  
 
12 楼 
 文章标题 : Re: Archlinux诡异..DHCP注释掉就可以进X,不注释就只看见三个终端盒小时钟,WHY?
帖子发表于 : 2009-10-27 16:29 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
Havanna 写道:
.xinitrc下你怎么设置的?




引用:
#
# /etc/inittab
#

# Runlevels:
# 0 Halt
# 1(S) Single-user
# 2 Not used
# 3 Multi-user
# 4 Not used
# 5 X11
# 6 Reboot

## Only one of the following two lines can be uncommented!
# Boot to console
id:3:initdefault:
# Boot to X11
#id:5:initdefault:

rc::sysinit:/etc/rc.sysinit
rs:S1:wait:/etc/rc.single
rm:2345:wait:/etc/rc.multi
rh:06:wait:/etc/rc.shutdown

# -8 options fixes umlauts problem on login
c1:2345:respawn:/sbin/agetty -8 38400 tty1 linux
c2:2345:respawn:/sbin/agetty -8 38400 tty2 linux
c3:2345:respawn:/sbin/agetty -8 38400 tty3 linux
c4:2345:respawn:/sbin/agetty -8 38400 tty4 linux
c5:2345:respawn:/sbin/agetty -8 38400 tty5 linux
c6:2345:respawn:/sbin/agetty -8 38400 tty6 linux

ca::ctrlaltdel:/sbin/shutdown -t3 -r now

# Example lines for starting a login manager
x:5:respawn:/usr/bin/xdm -nodaemon
#x:5:respawn:/usr/sbin/gdm -nodaemon
#x:5:respawn:/usr/bin/kdm -nodaemon
#x:5:respawn:/usr/bin/slim >& /dev/null

# End of file


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


页首
 用户资料  
 
13 楼 
 文章标题 : Re: Archlinux诡异..DHCP注释掉就可以进X,不注释就只看见三个终端盒小时钟,WHY?
帖子发表于 : 2009-10-27 22:28 
头像

注册: 2009-01-19 23:03
帖子: 2354
送出感谢: 5
接收感谢: 0 次
DAEMONS加gdm没,不用改inittab,gdm启动3和5都进入桌面


页首
 用户资料  
 
14 楼 
 文章标题 : Re: Archlinux诡异..DHCP注释掉就可以进X,不注释就只看见三个终端盒小时钟,WHY?
帖子发表于 : 2009-10-27 22:29 
头像

注册: 2009-01-19 23:03
帖子: 2354
送出感谢: 5
接收感谢: 0 次
不能上网折腾这么久,不容易。我的rc.conf参照折腾吧,不过我是用路由上网
代码:
DAEMONS=(syslog-ng hal !network !dbus clamav ufw !iptables networkmanager netfs !crond alsa gdm !fam ntpd cpufreq mpd)

代码:
#
# /etc/rc.conf - Main Configuration for Arch Linux
#

# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# USEDIRECTISA: use direct I/O requests instead of /dev/rtc for hwclock
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="zh_CN.utf8"
HARDWARECLOCK="localtime"
USEDIRECTISA="no"
TIMEZONE="Asia/Shanghai"
KEYMAP="us"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# MOD_AUTOLOAD: Allow autoloading of modules at boot and when needed
# MOD_BLACKLIST: Prevent udev from loading these modules
# MODULES: Modules to load at boot-up. Prefix with a ! to blacklist.
#
# NOTE: Use of 'MOD_BLACKLIST' is deprecated. Please use ! in the MODULES array.
#
MOD_AUTOLOAD="yes"
#MOD_BLACKLIST=() #deprecated
MODULES=(vboxdrv vboxnetflt bridge powernow-k8 cpufreq_powersave)

# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
# HOSTNAME: Hostname of machine. Should also be put in /etc/hosts
#
HOSTNAME="myhost"

# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
#
# DHCP:     Set your interface to "dhcp" (eth0="dhcp")
# Wireless: See network profiles below
#
#eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
lo="lo 127.0.0.1"
eth0="dhcp"
br0="dhcp"
#INTERFACES=(eth0)
INTERFACES=(lo !eth0 br0)

# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
#gateway="default gw 192.168.0.1"
#ROUTES=(!gateway)
 
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network.d
#
# This now requires the netcfg package
#
#NETWORKS=(main)

# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng hal !network !dbus clamav ufw !iptables networkmanager netfs !crond alsa gdm !fam ntpd cpufreq mpd)


页首
 用户资料  
 
15 楼 
 文章标题 : Re: Archlinux诡异..DHCP注释掉就可以进X,不注释就只看见三个终端盒小时钟,WHY?
帖子发表于 : 2009-10-28 2:06 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
白鳍豚 写道:
#
# DHCP: Set your interface to "dhcp" (eth0="dhcp")
# Wireless: See network profiles below
#
#eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
lo="lo 127.0.0.1"
eth0="dhcp"
br0="dhcp"
#INTERFACES=(eth0)
INTERFACES=(lo !eth0 br0)

# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
# - prefix an entry in ROUTES with a ! to disable it
#
#gateway="default gw 192.168.0.1"
#ROUTES=(!gateway)




就是顶上那两行出问题,

①都不注释掉,进不了;

②我禁用DHCP,不禁用wireless就报错说command not found (但还是可以进入桌面);

③两个一起禁用就正常进入——学校的锐捷我在windows下看到设置是“DHCP在认证后获取”。

禁用后虽然也可以上网,但是网络很不稳定;网速也受影响;

是不是因为我本身设置冲突了;(最后那gateway和route我都没注释掉)

是不是因为DBUS没装?

中间那看不懂。我继续看下书。

谢谢您的回答。


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译