当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 突然发现 yaourt 用不了
帖子发表于 : 2010-06-23 14:56 

注册: 2010-05-01 21:23
帖子: 1949
送出感谢: 4
接收感谢: 21
[wlk@myhost ~]$ yaourt vbox
package-query: error while loading shared libraries: libalpm.so.5: cannot open shared object file: No such file or directory


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 突然发现 yaourt 用不了
帖子发表于 : 2010-06-23 16:20 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
引用:
package-query: error while loading shared libraries: libalpm.so.5: cannot open shared object file: No such file or directory


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 突然发现 yaourt 用不了
帖子发表于 : 2010-06-23 17:25 
头像

注册: 2007-10-06 18:40
帖子: 4313
送出感谢: 0 次
接收感谢: 5
用pacman


_________________
E=m c^2


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 突然发现 yaourt 用不了
帖子发表于 : 2010-06-23 18:21 
头像

注册: 2007-07-11 12:31
帖子: 1794
地址: neverland
送出感谢: 0 次
接收感谢: 0 次
我也是这个问题,怀疑是打包的问题

我的解决方法:

删除掉package-query这个包

删完后到AUR里下载package-query的PKGBUILD自己编译打包再安装就好了


_________________
To be is to do--Nietzsche
To do is to be--Kant
Do be do be do---Frank Sinatra
http://ggarlic.org


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 突然发现 yaourt 用不了
帖子发表于 : 2010-06-23 20:42 

注册: 2009-02-08 17:19
帖子: 96
送出感谢: 0 次
接收感谢: 0 次
pacman -S yaourt 重装遍


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 突然发现 yaourt 用不了
帖子发表于 : 2010-06-23 21:10 
头像

注册: 2006-09-10 22:36
帖子: 10669
地址: 北京
送出感谢: 1
接收感谢: 16
代码:
wget http://repo.archlinux.fr/i686/package-query-0.3-2-i686.pkg.tar.xz
sudo pacman -U package-query-0.3-2-i686.pkg.tar.xz


_________________
看破、放下、自在、随缘、念佛
真诚、清净、平等、正觉、慈悲


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 突然发现 yaourt 用不了
帖子发表于 : 2010-06-23 21:19 

注册: 2009-05-29 15:21
帖子: 406
送出感谢: 2
接收感谢: 1
qiang_liu8183 写道:
代码:
wget http://repo.archlinux.fr/i686/package-query-0.3-2-i686.pkg.tar.xz
sudo pacman -U package-query-0.3-2-i686.pkg.tar.xz

:em11


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 突然发现 yaourt 用不了
帖子发表于 : 2010-06-23 23:36 
头像

注册: 2009-01-19 23:03
帖子: 2354
送出感谢: 5
接收感谢: 0 次
qiang_liu8183 写道:
代码:
wget http://repo.archlinux.fr/i686/package-query-0.3-2-i686.pkg.tar.xz
sudo pacman -U package-query-0.3-2-i686.pkg.tar.xz

谢谢 :em11


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 突然发现 yaourt 用不了
帖子发表于 : 2010-06-24 8:47 

注册: 2010-05-01 21:23
帖子: 1949
送出感谢: 4
接收感谢: 21
今天更新了400m后,可以了。我用是64位arch。谢谢大家的回答。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 突然发现 yaourt 用不了
帖子发表于 : 2010-06-24 10:22 

注册: 2008-04-20 12:13
帖子: 813
地址: Shanghai, PRC
系统: OS X, Gentoo, Win8.1
送出感谢: 0 次
接收感谢: 1
重编译package-query即可


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 突然发现 yaourt 用不了
帖子发表于 : 2010-06-24 11:40 
头像

注册: 2009-01-11 21:38
帖子: 198
送出感谢: 0 次
接收感谢: 0 次
近几天更新后就出现这个问题,重新安装一次package-query


_________________
以缺德服人......


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译