vbox无法安装

回复
谢宝良
帖子: 1979
注册时间: 2010-05-01 21:23
送出感谢: 4 次
接收感谢: 21 次

vbox无法安装

#1

帖子 谢宝良 » 2010-11-25 10:51

提示如下:
wlk@myhost ~ $ sudo sh VirtualBox-3.2.10-66896-Linux_x86.run
Verifying archive integrity... All good.
Uncompressing VirtualBox for Linux installation..........
VirtualBox Version 3.2.10 r66896 (2010-10-21T16:55:50Z) installer
Installing VirtualBox to /opt/VirtualBox
Python found: python, installing bindings...
File "/usr/lib/python3.1/site-packages/vboxapi/__init__.py", line 174
except AttributeError,e:
^
SyntaxError: invalid syntax

Building the VirtualBox kernel modules
VirtualBox has been installed successfully.

You will find useful information about using VirtualBox in the user manual
/opt/VirtualBox/UserManual.pdf
and in the user FAQ
http://www.virtualbox.org/wiki/User_FAQ

We hope that you enjoy using VirtualBox.
头像
hasee.wu
帖子: 2089
注册时间: 2009-10-20 21:13
来自: Pacific Western University
送出感谢: 0
接收感谢: 7 次

Re: vbox无法安装

#2

帖子 hasee.wu » 2010-11-25 10:59

代码: 全选

 yaourt -S virtualbox_bin
谢宝良
帖子: 1979
注册时间: 2010-05-01 21:23
送出感谢: 4 次
接收感谢: 21 次

Re: vbox无法安装

#3

帖子 谢宝良 » 2010-11-25 11:10

用yaourt命令安装程序,我还从没成功过,你看。
$ yaourt -S virtualbox_bin

==> Downloading virtualbox_bin PKGBUILD from AUR...
x vboxdrv
x virtualbox.install
x 10-vboxdrv.rules
x PKGBUILD

Comment by: cryptocrack on Mon, 01 Nov 2010 14:34:31 +0000
sergi34: Does it work if you use another Qt theme such as qtcurve, QGtkStyle or Clearlooks or another video driver? Could you please test that?

Comment by: cyberpatrol on Mon, 01 Nov 2010 15:56:25 +0000
Haven't tested the global settings, yet. But I can confirm that virtualbox crashes when opening this dialog with system's Qt. So I would say it's an upstream bug.

Comment by: cryptocrack on Mon, 01 Nov 2010 16:44:34 +0000
cyberpatrol: No, it's not. I had a discussing with the VirtualBox devs about that issue and from their point of view, using anything but built-in Qt is not supported. It seems to be some kind of indisputable fact.

Comment by: cyberpatrol on Mon, 01 Nov 2010 17:11:04 +0000
Just because Oracle thinks they only need to support their own built-in Qt instead of the official one doesn't mean that this is not a bug. ;-)
I mean in case of doubt the bug is their attitude against OpenSource.

Comment by: setokaiba1308 on Tue, 02 Nov 2010 15:52:41 +0000
https://bbs.archlinux.org/viewtopic.php?id=107206 --- anoyone has had this problem?

Comment by: skodabenz on Thu, 18 Nov 2010 19:16:27 +0000
Hi all, I use virtualbox-ose (didn't find any specific need to use the PUEL edition). But I have a request, is it possible to create a package similar to catalyst-generator http://aur.archlinux.org/packages.php?ID=41040 for vboxdrv (not like catalyst-daemon or catalyst-hook). I came across mkinitcpio-vbox http://aur.archlinux.org/packages.php?ID=41021 but that does not seem to work with systemd init system (http://aur.archlinux.org/packages.php?ID=36902 and http://aur.archlinux.org/packages.php?ID=40419).

Also whats the difference between virtualbox_bin and virtualbox-sun http://aur.archlinux.org/packages.php?ID=31996 package. Although virtualbox-sun package has many votes, it is very less compared to what virtualbox_bin has. If both provide the exact same binary then I think virtualbox-sun should be removed. Thanks in advance.

First Submitted: Sun, 11 Mar 2007 00:52:22 +0000
virtualbox_bin 3.2.10-2 : Powerful x86 virtualization (Personal Use Binaries Edition).
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
头像
hasee.wu
帖子: 2089
注册时间: 2009-10-20 21:13
来自: Pacific Western University
送出感谢: 0
接收感谢: 7 次

Re: vbox无法安装

#4

帖子 hasee.wu » 2010-11-25 11:15

提示要不要edit 时,输 n 回车
提示要不要intall 时,输y回车

看提示, 这英语不难的
谢宝良
帖子: 1979
注册时间: 2010-05-01 21:23
送出感谢: 4 次
接收感谢: 21 次

Re: vbox无法安装

#5

帖子 谢宝良 » 2010-11-25 11:42

安装成功了,但还是无法启动。
头像
hasee.wu
帖子: 2089
注册时间: 2009-10-20 21:13
来自: Pacific Western University
送出感谢: 0
接收感谢: 7 次

Re: vbox无法安装

#6

帖子 hasee.wu » 2010-11-25 11:52

谢宝良 写了:安装成功了,但还是无法启动。
记得好像要重启的,因为相当于装了驱动
头像
vicwjb
帖子: 404
注册时间: 2007-10-05 15:49
送出感谢: 0
接收感谢: 0
联系:

Re: vbox无法安装

#7

帖子 vicwjb » 2010-11-25 12:25

把python ln到python2.7上就可以了,现在arch的python是链接到3.1的,而vbox的python绑定的是python2.。。。。。。。。。。
msoffice,autocad,我恨你们。。。。。。
我的blog
头像
tenzu
论坛版主
帖子: 36913
注册时间: 2008-11-21 20:26
送出感谢: 0
接收感谢: 21 次

Re: vbox无法安装

#8

帖子 tenzu » 2010-11-25 12:51

猜到是python的杯具,没想到真是
husttc
帖子: 2
注册时间: 2010-12-07 10:58
送出感谢: 0
接收感谢: 0

Re: vbox无法安装

#9

帖子 husttc » 2010-12-07 11:09

其实可以装virtualbox-ose版本,这个版本是开源的,在源里有,直接pacman -S virtualbox-ose装完了会有提示信息,照着提示把几个模块加载了就行了
回复

回到 “Arch发行版”