当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : yaourt 循环错误,求解(solved)
帖子发表于 : 2010-12-18 0:37 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
_______________________________

已解决,烦请查看第 19 楼,谢谢诸位。
_______________________________

代码:
[xmu@Archlinux ~]$ sudo pacman -S iptux
Password:
error: directive 'Server' with a value not recognized
error: config file /etc/pacman.d/mirrorlist, line 6: problem in options section
error: 'iptux': could not find or read package
[xmu@Archlinux ~]$ yaourt -S iptux

==> Downloading iptux PKGBUILD from AUR...
x iptux.install
x PKGBUILD


Comment by: solstice on Mon, 21 Jun 2010 18:36:31 +0000
pkgver=0.5.1_2
echo ${pkgver/_/-}
0.5.1-2   

Comment by: tocer on Tue, 22 Jun 2010 00:54:49 +0000
fixed. thanks for solstice   

First Submitted: Sat, 20 Dec 2008 07:08:22 +0000   
iptux 0.5.1_2-2 : Lan communication software, compatiable with IP Messenger.
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> iptux dependencies:
 - gtk2 (already installed)
 - gconf (already installed)
 - make (already installed)
 - error: (building from AUR)
 - directive (building from AUR)
 - 'Server' (building from AUR)
 - with (building from AUR)
 - a (building from AUR)
 - value (building from AUR)
 - not (building from AUR)
 - recognized (building from AUR)
 - error: (building from AUR)
 - config (building from AUR)
 - file (package found)
 - /etc/pacman.d/mirrorlist, (building from AUR)
 - line (building from AUR)
 - 6: (building from AUR)
 - problem (building from AUR)
 - in (building from AUR)
 - options (building from AUR)
 - section (building from AUR)


==> Edit iptux.install ? [Y/n] ("A" to abort)
==> -----------------------------------------
==> n

==> Continue building iptux ? [Y/n]
==> -------------------------------
==>
==> Building and installing package
==> Install or build missing dependencies for iptux:
error: directive 'Server' with a value not recognized
error: config file /etc/pacman.d/mirrorlist, line 6: problem in options section
error: 'value': could not find or read package

==> Downloading config PKGBUILD from AUR...
x PKGBUILD


First Submitted: Thu, 17 Aug 2006 09:51:20 +0000   
config 0.3.7-4 : a python module for the configuration file management
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> ^C                                                            #此处自己X了,因为看到循环错误了
[xmu@Archlinux ~]$


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


最后由 wowoto 编辑于 2010-12-24 23:46,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: yaourt 循环错误,求解
帖子发表于 : 2010-12-18 11:27 
头像

注册: 2008-07-24 11:33
帖子: 4793
地址: 郑州
送出感谢: 4
接收感谢: 92
iptux 0.5.1_2-2 : Lan communication software, compatiable with IP Messenger.
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> Edit iptux.install ? [Y/n] ("A" to abort)
==> -----------------------------------------
==> n

config 0.3.7-4 : a python module for the configuration file management
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> ^C

前两次询问的是iptux的包配置(PKGBUILD、iptux.install),后面询问的是config的包配置。没有问题吧。
如果嫌询问太麻烦,可以加上--noconfirm参数,就不会询问是否修改文件了。

另:你的mirrorlist是不是有格式问题?


_________________
求人不如求它仨: 天蓝的Wiki 屎黄的Wiki 绿
Site: CUIHAO.TK    Twitter: @cuihaoleo
Machine: Athlon64 X2 5200+ / 2x2GB DDR2-800 / GeForce GTS 450
AD: ~まだ見ぬ誰かの笑顔のために~


页首
 用户资料  
 
3 楼 
 文章标题 : Re: yaourt 循环错误,求解
帖子发表于 : 2010-12-18 12:40 
头像

注册: 2009-11-19 19:35
帖子: 2061
送出感谢: 0 次
接收感谢: 0 次
引用:
error: config file /etc/pacman.d/mirrorlist, line 6: problem in options section
第六行好像有问题,打开看看呗


_________________
——nerver is not never


页首
 用户资料  
 
4 楼 
 文章标题 : Re: yaourt 循环错误,求解
帖子发表于 : 2010-12-18 15:10 

注册: 2010-01-25 9:27
帖子: 211
送出感谢: 0 次
接收感谢: 1
很显然是配置文件有问题


页首
 用户资料  
 
5 楼 
 文章标题 : Re: yaourt 循环错误,求解
帖子发表于 : 2010-12-20 23:18 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
nerver , flay : 和你们说的第六行配置 无关。


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


页首
 用户资料  
 
6 楼 
 文章标题 : Re: yaourt 循环错误,求解
帖子发表于 : 2010-12-20 23:19 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
cuihao 写道:
iptux 0.5.1_2-2 : Lan communication software, compatiable with IP Messenger.
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> Edit iptux.install ? [Y/n] ("A" to abort)
==> -----------------------------------------
==> n

config 0.3.7-4 : a python module for the configuration file management
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> ^C

前两次询问的是iptux的包配置(PKGBUILD、iptux.install),后面询问的是config的包配置。没有问题吧。
如果嫌询问太麻烦,可以加上--noconfirm参数,就不会询问是否修改文件了。

另:你的mirrorlist是不是有格式问题?


mirrorlist格式一直提示有问题,但是pacman 可以正常更新yaourt 最近当了~~不知为何 循环提问


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


页首
 用户资料  
 
7 楼 
 文章标题 : Re: yaourt 循环错误,求解
帖子发表于 : 2010-12-20 23:51 
头像

注册: 2005-08-14 19:53
帖子: 4002
送出感谢: 1
接收感谢: 2
mirrorlist问题就改的没有问题再说。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: yaourt 循环错误,求解
帖子发表于 : 2010-12-21 0:06 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
jarryson 写道:
mirrorlist问题就改的没有问题再说。

下面给出的是我的mirrorlist的一部分,你看下有没问题,按照我的看法是没问题的,给出来的未做任何更改:

引用:


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


页首
 用户资料  
 
9 楼 
 文章标题 : Re: yaourt 循环错误,求解
帖子发表于 : 2010-12-21 3:00 
头像

注册: 2005-08-14 19:53
帖子: 4002
送出感谢: 1
接收感谢: 2
如果需要帮忙找错误,你得用code框起来,或者上传整个mirrorlist,这样看不出来,初看确实没有问题。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: yaourt 循环错误,求解
帖子发表于 : 2010-12-21 23:23 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
jarryson 写道:
如果需要帮忙找错误,你得用code框起来,或者上传整个mirrorlist,这样看不出来,初看确实没有问题。

你所看到的就是mirrorlist的原文。只字未变。


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


页首
 用户资料  
 
11 楼 
 文章标题 : Re: yaourt 循环错误,求解
帖子发表于 : 2010-12-22 0:38 
头像

注册: 2005-08-14 19:53
帖子: 4002
送出感谢: 1
接收感谢: 2
/etc/pacman.d/mirrorlist
...
这是神马东西?没在mirrorlist里面把?


页首
 用户资料  
 
12 楼 
 文章标题 : Re: yaourt 循环错误,求解
帖子发表于 : 2010-12-22 21:22 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
jarryson 写道:
/etc/pacman.d/mirrorlist
...
这是神马东西?没在mirrorlist里面把?


没,那是less 出现在终端的~~


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


页首
 用户资料  
 
13 楼 
 文章标题 : Re: yaourt 循环错误,求解
帖子发表于 : 2010-12-22 21:34 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
关键词,python
要把python2.7做个符号链接


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
14 楼 
 文章标题 : Re: yaourt 循环错误,求解
帖子发表于 : 2010-12-22 21:53 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
tenzu 写道:
关键词,python
要把python2.7做个符号链接



拜见tenzu,您不知道我是菜鸟吗 ~ 这样说我是完全不理解的~~~


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


页首
 用户资料  
 
15 楼 
 文章标题 : Re: yaourt 循环错误,求解
帖子发表于 : 2010-12-22 22:07 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
简单解释一下就是arch现在里面有两个python, python2.7是用python2启动的,python启动的是python3
所以要做个软链接
具体方法google一下
回家睡觉了,白白


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译