关于openbox中的qt程序和openbox的右键菜单

回复
Mazenvoy
帖子: 306
注册时间: 2010-04-02 21:17
送出感谢: 0
接收感谢: 2 次

关于openbox中的qt程序和openbox的右键菜单

#1

帖子 Mazenvoy » 2011-05-16 17:45

1.右键菜单真丑,不过这到不是问题,但它的字太小了,哪里配置其字体
2.qt程序太丑,怎么配置
3.勿喷,今天刚装openbox。
4.我是kde(电脑不行)->gnome 3(用不惯)->openbox,所以电脑里还有一个gnome 3,于是发现桌布还是gnome管的,而非feh,不过我倒不追求轻量什么的,只是本着求是的精神要搞明白。
5.之所以发贴而不google是因为实在是搜不动了,我要急着写程序了,老师的最后期限要到了
头像
phyware
帖子: 157
注册时间: 2009-08-22 8:47
送出感谢: 0
接收感谢: 0

Re: 关于openbox中的qt程序和openbox的右键菜单

#2

帖子 phyware » 2011-05-16 18:13

1. 这个貌似是跟openbox的主题挂钩的。

2, 可以用 qtconfig [link]

3. 我不喷

4.
You can disable the wallpaper loading in gnome-settings-daemon like this:

$ gconftool-2 --set /apps/gnome_settings_daemon/plugins/background/active --type bool False
Futurama
Mazenvoy
帖子: 306
注册时间: 2010-04-02 21:17
送出感谢: 0
接收感谢: 2 次

Re: 关于openbox中的qt程序和openbox的右键菜单

#3

帖子 Mazenvoy » 2011-05-16 18:30

phyware 写了:1. 这个貌似是跟openbox的主题挂钩的。

2, 可以用 qtconfig [link]

3. 我不喷

4.
You can disable the wallpaper loading in gnome-settings-daemon like this:

$ gconftool-2 --set /apps/gnome_settings_daemon/plugins/background/active --type bool False
关于4,我其实也在wiki上看到了,但是我在bash中输入后它出现
GLib-GIO:ERROR:gdbusconnection.c:2279:initable_init: assertion failed: (connection->initialization_error == NULL)
Aborted
头像
phyware
帖子: 157
注册时间: 2009-08-22 8:47
送出感谢: 0
接收感谢: 0

Re: 关于openbox中的qt程序和openbox的右键菜单

#4

帖子 phyware » 2011-05-16 18:52

曾经似乎见过 说可以把gnome_settings_daemon换成gnome-panel-control
具体已经记不起

也许这可用 [via]
If you really want to continue using gnome-settings-daemon, open gconf-editor and set the following to no/false/uncheck :

/desktop/gnome/background/draw_background
/apps/gnome_settings_daemon/plugins/background/active

You can also disable these :

/apps/nautilus/preferences/background_set
/apps/nautilus/preferences/show_desktop
Futurama
Mazenvoy
帖子: 306
注册时间: 2010-04-02 21:17
送出感谢: 0
接收感谢: 2 次

Re: 关于openbox中的qt程序和openbox的右键菜单

#5

帖子 Mazenvoy » 2011-05-16 19:09

phyware 写了:曾经似乎见过 说可以把gnome_settings_daemon换成gnome-panel-control
具体已经记不起

也许这可用 [via]
If you really want to continue using gnome-settings-daemon, open gconf-editor and set the following to no/false/uncheck :

/desktop/gnome/background/draw_background
/apps/gnome_settings_daemon/plugins/background/active

You can also disable these :

/apps/nautilus/preferences/background_set
/apps/nautilus/preferences/show_desktop
thx,我发现问题所在了,原来是gnome 3 大部分gconf的功能已经转到dconf,所以上述命令失效,我在dconf-editor中该好了。

看了那个blog,发现qtconfig貌似arch是没有的,而且那个博主说Qt themes are more complex blabla。。。。
我想他的意思就是他也挂了吧 :em06
不过他的log好详细
头像
phyware
帖子: 157
注册时间: 2009-08-22 8:47
送出感谢: 0
接收感谢: 0

Re: 关于openbox中的qt程序和openbox的右键菜单

#6

帖子 phyware » 2011-05-16 19:28

那个博客文章是针对ubuntu的,他是说用qt3-config,或qt4-config。
qtconfig在我这是有的。

代码: 全选

pacman -Qo $(which qtconfig)
/usr/bin/qtconfig is owned by qt 4.7.3-1
Qt themes are more complex than Gtk themes, and are therefore harder to change through text files than Gtk themes are.
他是说手动改配置文件比较麻烦吧,所以建议用工具。
Futurama
Mazenvoy
帖子: 306
注册时间: 2010-04-02 21:17
送出感谢: 0
接收感谢: 2 次

Re: 关于openbox中的qt程序和openbox的右键菜单

#7

帖子 Mazenvoy » 2011-05-16 22:35

phyware 写了:那个博客文章是针对ubuntu的,他是说用qt3-config,或qt4-config。
qtconfig在我这是有的。

代码: 全选

pacman -Qo $(which qtconfig)
/usr/bin/qtconfig is owned by qt 4.7.3-1
Qt themes are more complex than Gtk themes, and are therefore harder to change through text files than Gtk themes are.
他是说手动改配置文件比较麻烦吧,所以建议用工具。
啊,多谢啊,我还以为qtconfig是个包呢?
pacman -Ss qtconfig 弄不出来

不过我最后字体的抗锯齿什么还是用了gnome的工具 :em06
网上说改~/.fonts.conf
我把我以前的 .fonts.conf拷贝来,发现在qt程序中还是有锯齿
头像
phyware
帖子: 157
注册时间: 2009-08-22 8:47
送出感谢: 0
接收感谢: 0

Re: 关于openbox中的qt程序和openbox的右键菜单

#8

帖子 phyware » 2011-05-16 23:12

我可能也没表达清楚,毕竟给的link里说是一个包

偶这~/.fonts.conf 对gtk和qt程序都有效果
Futurama
owwbu
帖子: 614
注册时间: 2006-11-15 14:14
送出感谢: 0
接收感谢: 1 次

Re: 关于openbox中的qt程序和openbox的右键菜单

#9

帖子 owwbu » 2011-05-17 7:56

Mazenvoy 写了:
phyware 写了:曾经似乎见过 说可以把gnome_settings_daemon换成gnome-panel-control
具体已经记不起

也许这可用 [via]
If you really want to continue using gnome-settings-daemon, open gconf-editor and set the following to no/false/uncheck :

/desktop/gnome/background/draw_background
/apps/gnome_settings_daemon/plugins/background/active

You can also disable these :

/apps/nautilus/preferences/background_set
/apps/nautilus/preferences/show_desktop
thx,我发现问题所在了,原来是gnome 3 大部分gconf的功能已经转到dconf,所以上述命令失效,我在dconf-editor中该好了。

看了那个blog,发现qtconfig貌似arch是没有的,而且那个博主说Qt themes are more complex blabla。。。。
我想他的意思就是他也挂了吧 :em06
不过他的log好详细
qtconfig是包含在qt这个包里头的。
我觉得既然openbox了,就不要其用gnome-settings-deamon了。要设置openbox的gtk主题什么的,可以用lxappearance设定,gtk3程序的外观,可以这样来:
1. Installed gnome-themes-standard. Created a new folder ~/.config/gtk-3.0/; Created the file in the folder "settings.ini" with the following code;

[Settings]

gtk-application-prefer-dark-theme = true

gtk-theme-name = Adwaita

gtk-fallback-icon-theme = gnome

以上设置都可以参照.gtkrc-2.0 (lxappearance会给你生成这个文件的)里头的项目进行添加、设置。
openbox的字体、主题什么的,可以用obconf来设置。
回复

回到 “Arch发行版”