求助:麻烦给个xorg.conf(arch+intel+ati6400/7400M显卡),谢谢!

头像
白鳍豚
帖子: 2354
注册时间: 2009-01-19 23:03
送出感谢: 5 次
接收感谢: 0

求助:麻烦给个xorg.conf(arch+intel+ati6400/7400M显卡),谢谢!

#1

帖子 白鳍豚 » 2013-03-19 9:33

(arch+intel+ati6400/7400M显卡,systemd)
麻烦哪位安装catalyst-dkms,并已成功开启的给个xorg.conf。谢谢!
安装完之后系统没有xorg.conf,用aticonfig生成的,启动不了X,删除之后才能启动。
xgdgsc
帖子: 277
注册时间: 2010-02-25 11:02
系统: Arch x64
送出感谢: 1 次
接收感谢: 13 次

Re: 求助:麻烦给个xorg.conf(arch+intel+ati6400/7400M显卡),谢谢!

#2

帖子 xgdgsc » 2013-03-19 18:32

xorg.conf本来就可以没有。
jtshs256
论坛版主
帖子: 22322
注册时间: 2010-07-19 21:41
系统: OS X
送出感谢: 2 次
接收感谢: 27 次

Re: 求助:麻烦给个xorg.conf(arch+intel+ati6400/7400M显卡),谢谢!

#3

帖子 jtshs256 » 2013-03-19 18:35

xgdgsc 写了:xorg.conf本来就可以没有。
NO DO NO DIE
http://a/%%30%30
头像
白鳍豚
帖子: 2354
注册时间: 2009-01-19 23:03
送出感谢: 5 次
接收感谢: 0

Re: 求助:麻烦给个xorg.conf(arch+intel+ati6400/7400M显卡),谢谢!

#4

帖子 白鳍豚 » 2013-03-19 22:34

jtshs256 写了:
xgdgsc 写了:xorg.conf本来就可以没有。
这样A 卡启动不了啊
TA: Escalation
帖子: 23
注册时间: 2010-04-17 11:42
送出感谢: 0
接收感谢: 1 次

Re: 求助:麻烦给个xorg.conf(arch+intel+ati6400/7400M显卡),谢谢!

#5

帖子 TA: Escalation » 2013-03-21 16:48

注意:catalyst 驱动目前支持linux 3.5 xorg-server =<1.13
双显卡要用 https://aur.archlinux.org/packages/catalyst-total-pxp/
安装xf86-video-intel 2.20.19
装好catalyst-total-pxp后记得:

代码: 全选

sudo pxp_switch_catalyst amd

代码: 全选

      Section "ServerLayout"
   Identifier     "aticonfig Layout"
   Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]-0"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   BusID       "PCI:1:0:0"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "intel"
   Option "AccelMethod" "uxa"
   Option "SwapbuffersWait" "false"
   Option "TearFree" "true"
   BusID       "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-0"
   Device     "aticonfig-Device[0]-0"
   Monitor    "aticonfig-Monitor[0]-0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection
这些用户感谢了作者 TA: Escalation 于这个帖子:
白鳍豚 (2013-03-24 0:44)
评价: 3.7%
头像
白鳍豚
帖子: 2354
注册时间: 2009-01-19 23:03
送出感谢: 5 次
接收感谢: 0

Re: 求助:麻烦给个xorg.conf(arch+intel+ati6400/7400M显卡),谢谢!

#6

帖子 白鳍豚 » 2013-03-21 22:50

extra/xorg-server 1.14.0-2 (xorg) [已安装]
:em20
core/linux-headers 3.8.3-2 [已安装]
:em06
头像
b33e
论坛版主
帖子: 3862
注册时间: 2011-06-07 14:20
系统: Mint18
送出感谢: 16 次
接收感谢: 62 次

Re: 求助:麻烦给个xorg.conf(arch+intel+ati6400/7400M显卡),谢谢!

#7

帖子 b33e » 2013-03-21 22:53

你确定你的驱动装好了?
头像
白鳍豚
帖子: 2354
注册时间: 2009-01-19 23:03
送出感谢: 5 次
接收感谢: 0

Re: 求助:麻烦给个xorg.conf(arch+intel+ati6400/7400M显卡),谢谢!

#8

帖子 白鳍豚 » 2013-03-21 22:54

试试
core/linux-lts 3.0.69-1
1.13缓存还有 :em01
头像
白鳍豚
帖子: 2354
注册时间: 2009-01-19 23:03
送出感谢: 5 次
接收感谢: 0

Re: 求助:麻烦给个xorg.conf(arch+intel+ati6400/7400M显卡),谢谢!

#9

帖子 白鳍豚 » 2013-03-21 22:54

b33e 写了:你确定你的驱动装好了?
模块有装载
头像
白鳍豚
帖子: 2354
注册时间: 2009-01-19 23:03
送出感谢: 5 次
接收感谢: 0

Re: 求助:麻烦给个xorg.conf(arch+intel+ati6400/7400M显卡),谢谢!

#10

帖子 白鳍豚 » 2013-03-21 23:08

:: xorg-server: 要求 xf86-input-evdev
降级不了 :em20
头像
白鳍豚
帖子: 2354
注册时间: 2009-01-19 23:03
送出感谢: 5 次
接收感谢: 0

Re: 求助:麻烦给个xorg.conf(arch+intel+ati6400/7400M显卡),谢谢!

#11

帖子 白鳍豚 » 2013-03-21 23:14

等aur升级再弄。谢谢!
xorg-server怪不得升级冲突,觉得用不上给卸载了 :em04
头像
白鳍豚
帖子: 2354
注册时间: 2009-01-19 23:03
送出感谢: 5 次
接收感谢: 0

Re: 求助:麻烦给个xorg.conf(arch+intel+ati6400/7400M显卡),谢谢!

#12

帖子 白鳍豚 » 2013-03-21 23:15

TA: Escalation 写了:注意:catalyst 驱动目前支持linux 3.5 xorg-server =<1.13
双显卡要用 https://aur.archlinux.org/packages/catalyst-total-pxp/
安装xf86-video-intel 2.20.19
装好catalyst-total-pxp后记得:

代码: 全选

sudo pxp_switch_catalyst amd

代码: 全选

      Section "ServerLayout"
   Identifier     "aticonfig Layout"
   Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]-0"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   BusID       "PCI:1:0:0"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "intel"
   Option "AccelMethod" "uxa"
   Option "SwapbuffersWait" "false"
   Option "TearFree" "true"
   BusID       "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-0"
   Device     "aticonfig-Device[0]-0"
   Monitor    "aticonfig-Monitor[0]-0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection
已经支持3.8了
linux<3.9
头像
白鳍豚
帖子: 2354
注册时间: 2009-01-19 23:03
送出感谢: 5 次
接收感谢: 0

Re: 求助:麻烦给个xorg.conf(arch+intel+ati6400/7400M显卡),谢谢!

#13

帖子 白鳍豚 » 2013-03-21 23:31

extra/xf86-video-intel 2.21.4-1
A卡驱动更新太慢了,不知道什么时候才能用得上
呵呵 不能Syu了
坐等升级 :em01
头像
白鳍豚
帖子: 2354
注册时间: 2009-01-19 23:03
送出感谢: 5 次
接收感谢: 0

Re: 求助:麻烦给个xorg.conf(arch+intel+ati6400/7400M显卡),谢谢!

#14

帖子 白鳍豚 » 2013-03-23 0:09

头像
白鳍豚
帖子: 2354
注册时间: 2009-01-19 23:03
送出感谢: 5 次
接收感谢: 0

Re: 求助:麻烦给个xorg.conf(arch+intel+ati6400/7400M显卡),谢谢!

#15

帖子 白鳍豚 » 2013-03-23 1:02

TA: Escalation 写了:注意:catalyst 驱动目前支持linux 3.5 xorg-server =<1.13
双显卡要用 https://aur.archlinux.org/packages/catalyst-total-pxp/
安装xf86-video-intel 2.20.19
装好catalyst-total-pxp后记得:

代码: 全选

sudo pxp_switch_catalyst amd

代码: 全选

      Section "ServerLayout"
   Identifier     "aticonfig Layout"
   Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]-0"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   BusID       "PCI:1:0:0"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "intel"
   Option "AccelMethod" "uxa"
   Option "SwapbuffersWait" "false"
   Option "TearFree" "true"
   BusID       "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-0"
   Device     "aticonfig-Device[0]-0"
   Monitor    "aticonfig-Monitor[0]-0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection
Parse error on line 39 of section Screen in file /etc/X11/xorg.conf
Unexpected EOF. Missing EndSection keyword?
回复

回到 “Arch发行版”