当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助:这个xorg错在哪?谢谢!
帖子发表于 : 2013-05-01 0:54 
头像

注册: 2009-01-19 23:03
帖子: 2354
送出感谢: 5
接收感谢: 0 次
代码:
Section "ServerLayout"
   Identifier     "aticonfig Layout"
   Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
   Identifier   "aticonfig-Monitor[0]-0"
   Option       "VendorName" "ATI Proprietary Driver"
   Option       "ModelName" "Generic Autodetecting Monitor"
   Option       "DPMS" "true"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "fglrx"
   BusID       "PCI:1:0:0"
EndSection

Section "Device"
   Identifier  "aticonfig-Device[0]-0"
   Driver      "intel"
   Option "AccelMethod" "uxa"
   Option "SwapbuffersWait" "false"
   Option "TearFree" "true"
   BusID       "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "aticonfig-Screen[0]-0"
   Device     "aticonfig-Device[0]-0"
   Monitor    "aticonfig-Monitor[0]-0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "Extensions"
        Option      "Composite" "Disable"
EndSection
Section "ServerFlags"
        Option      "AIGLX" "off"
EndSection


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求助:这个xorg错在哪?谢谢!
帖子发表于 : 2013-05-01 0:55 
头像

注册: 2009-01-19 23:03
帖子: 2354
送出感谢: 5
接收感谢: 0 次
引用:
[ 19.593]
X.Org X Server 1.13.4
Release Date: 2013-04-17
[ 19.593] X Protocol Version 11, Revision 0
[ 19.593] Build Operating System: Linux 3.8.10-1-ARCH x86_64
[ 19.593] Current Operating System: Linux ******* 3.8.10-1-ARCH #1 SMP PREEMPT Sat Apr 27 12:36:59 CEST 2013 x86_64
[ 19.593] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=1c9a0b76-d1de-4022-a21d-6fb8a6a3b726 ro nomodeset quiet
[ 19.593] Build Date: 28 April 2013 01:19:17PM
[ 19.593]
[ 19.593] Current version of pixman: 0.28.2
[ 19.593] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 19.593] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 19.593] (==) Log file: "/var/log/Xorg.0.log", Time: Wed May 1 00:48:11 2013
[ 19.675] (==) Using config file: "/etc/X11/xorg.conf"
[ 19.675] (==) Using config directory: "/etc/X11/xorg.conf.d"
[ 19.675] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 19.797] (==) ServerLayout "aticonfig Layout"
[ 19.797] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[ 19.797] (**) | |-->Monitor "aticonfig-Monitor[0]-0"
[ 19.797] (**) | |-->Device "aticonfig-Device[0]-0"
[ 19.797] (**) Option "AIGLX" "off"
[ 19.797] (==) Automatically adding devices
[ 19.797] (==) Automatically enabling devices
[ 19.797] (==) Automatically adding GPU devices
[ 19.901] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[ 19.901] Entry deleted from font path.
[ 19.902] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[ 19.902] Entry deleted from font path.
[ 19.902] (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[ 19.902] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[ 19.902] Entry deleted from font path.
[ 19.902] (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[ 19.902] (==) FontPath set to:
/usr/share/fonts/misc/,
/usr/share/fonts/TTF/,
/usr/share/fonts/Type1/
[ 19.902] (**) ModulePath set to "/usr/lib/xorg/modules/updates,/usr/lib/xorg/modules"
[ 19.902] (**) Extension "Composite" is disabled
[ 19.902] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 19.918] (II) Loader magic: 0x7fbc20
[ 19.918] (II) Module ABI versions:
[ 19.918] X.Org ANSI C Emulation: 0.4
[ 19.918] X.Org Video Driver: 13.1
[ 19.918] X.Org XInput driver : 18.0
[ 19.918] X.Org Server Extension : 7.0
[ 19.920] (--) PCI:*(0:0:2:0) 8086:0116:103c:1855 rev 9, Mem @ 0x63000000/4194304, 0x50000000/268435456, I/O @ 0x00005000/64
[ 19.920] (--) PCI: (0:1:0:0) 1002:6760:103c:1855 rev 0, Mem @ 0x40000000/268435456, 0x62000000/131072, I/O @ 0x00004000/256, BIOS @ 0x????????/131072
[ 19.920] Initializing built-in extension Generic Event Extension
[ 19.920] Initializing built-in extension SHAPE
[ 19.920] Initializing built-in extension MIT-SHM
[ 19.920] Initializing built-in extension XInputExtension
[ 19.920] Initializing built-in extension XTEST
[ 19.920] Initializing built-in extension BIG-REQUESTS
[ 19.920] Initializing built-in extension SYNC
[ 19.920] Initializing built-in extension XKEYBOARD
[ 19.920] Initializing built-in extension XC-MISC
[ 19.920] Initializing built-in extension SECURITY
[ 19.920] Initializing built-in extension XINERAMA
[ 19.920] Initializing built-in extension XFIXES
[ 19.920] Initializing built-in extension RENDER
[ 19.920] Initializing built-in extension RANDR
[ 19.920] Initializing built-in extension COMPOSITE
[ 19.920] Initializing built-in extension DAMAGE
[ 19.920] Initializing built-in extension MIT-SCREEN-SAVER
[ 19.920] Initializing built-in extension DOUBLE-BUFFER
[ 19.920] Initializing built-in extension RECORD
[ 19.920] Initializing built-in extension DPMS
[ 19.920] Initializing built-in extension X-Resource
[ 19.920] Initializing built-in extension XVideo
[ 19.920] Initializing built-in extension XVideo-MotionCompensation
[ 19.920] Initializing built-in extension XFree86-VidModeExtension
[ 19.920] Initializing built-in extension XFree86-DGA
[ 19.920] Initializing built-in extension XFree86-DRI
[ 19.920] Initializing built-in extension DRI2
[ 19.920] (II) "glx" will be loaded by default.
[ 19.920] (II) LoadModule: "glx"
[ 19.980] (II) Loading /usr/lib/xorg/modules/updates/extensions/libglx.so
[ 20.005] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[ 20.005] compiled for 6.9.0, module version = 1.0.0
[ 20.005] Loading extension GLX
[ 20.005] (II) LoadModule: "fglrx"
[ 20.025] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
[ 20.689] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[ 20.689] compiled for 1.4.99.906, module version = 12.10.5
[ 20.689] Module class: X.Org Video Driver
[ 20.690] (II) Loading sub module "fglrxdrm"
[ 20.690] (II) LoadModule: "fglrxdrm"
[ 20.690] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[ 20.714] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[ 20.714] compiled for 1.4.99.906, module version = 12.10.5
[ 20.714] (II) AMD Proprietary Linux Driver Version Identifier:12.10.05
[ 20.714] (II) AMD Proprietary Linux Driver Release Identifier: 12.104
[ 20.714] (II) AMD Proprietary Linux Driver Build Date: Mar 28 2013 21:07:25
[ 20.714] (++) using VT number 1

[ 20.789] (WW) Falling back to old probe method for fglrx
[ 20.837] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[ 20.857] ukiDynamicMajor: found major device number 251
[ 20.857] ukiDynamicMajor: found major device number 251
[ 20.857] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[ 20.857] ukiOpenDevice: node name is /dev/ati/card0
[ 20.857] ukiOpenDevice: open result is 9, (OK)
[ 21.886] ukiOpenByBusid: ukiOpenMinor returns 9
[ 21.886] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[ 21.898] (--) Chipset Supported AMD Graphics Processor (0x6760) found
[ 21.915] (II) fglrx: intel VGA device detected, load intel driver.
[ 21.915] (II) LoadModule: "intel"
[ 21.915] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[ 21.941] (II) Module intel: vendor="X.Org Foundation"
[ 21.941] compiled for 1.13.2.901, module version = 2.21.3
[ 21.941] Module class: X.Org Video Driver
[ 21.941] ABI class: X.Org Video Driver, version 13.1
[ 21.942] (II) AMD Video driver is running on a device belonging to a group targeted for this release
[ 21.942] (II) AMD Video driver is signed
[ 21.943] (II) fglrx(0): pEnt->device->identifier=0xc94820
[ 21.957]
Fatal server error:
[ 21.957] atiddxProbe: fail to probe intel VGA device
[ 21.957] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 21.957] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 21.957] (EE)


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求助:这个xorg错在哪?谢谢!
帖子发表于 : 2013-05-02 20:06 

注册: 2010-02-25 11:02
帖子: 277
系统: Arch x64
送出感谢: 2
接收感谢: 14
据说ATI驱动还不支持最新的X,所以要降级X,你没看见catalyst已经被扔到aur了。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求助:这个xorg错在哪?谢谢!
帖子发表于 : 2013-05-07 21:54 
头像

注册: 2009-01-19 23:03
帖子: 2354
送出感谢: 5
接收感谢: 0 次
xorg已经降级了。是aur里面的。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求助:这个xorg错在哪?谢谢!
帖子发表于 : 2013-05-07 21:58 
头像

注册: 2009-01-19 23:03
帖子: 2354
送出感谢: 5
接收感谢: 0 次
据说ATI有给ubuntu开小灶,不知道效果怎么样


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译