当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决][问题]神州数码DCWL-390拨号连线问题
帖子发表于 : 2008-05-17 4:28 

注册: 2008-05-17 4:14
帖子: 153
送出感谢: 0 次
接收感谢: 0 次
总算装好ubuntu 8.04
就是神州数码DCWL-390不能拨号,查了一些资料,还是搞不定,特此向高手求助!
动行sudo gedit /etc/wvdial.cong,内容如下:

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
ISDN = 0
New PPPD = yes
Phone = #777
Modem = /dev/ttyS0
Username = CARD
Password = CARD
Baud = 115200

这里说明一下,原来显示的有些不同,这里列出:

; Phone = #777
; Username = CARD
; Password = CARD

两种不同的配置文件拨号都不能成功,以下是以第一种配置运行sudo wvdial显示的内容:

os@ubuntu:~$ sudo wvdialconf
Editing `/etc/wvdial.conf'.
Scanning your serial ports for a modem.
ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 -- OK
ttyS0<*1>: ATQ0 V1 E1 Z -- OK
ttyS0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyS0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyS0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyS0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyS0<*1>: Modem Identifier: ATI -- TechFaith Flying TP
ttyS0<*1>: Max speed is 115200; that should be safe.
ttyS0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
Modem Port Scan<*1>: S2 S3
Found a modem on /dev/ttyS0.
Modem configuration written to /etc/wvdial.conf.
ttyS0<Info>: Speed 115200; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
os@ubuntu:~$ sudo wvdial
--> WvDial: Internet dialer version 1.60
--> Initializing modem.
--> Sending: ATZ ATZ OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier. ATDT#777 CONNECT
--> Carrier detected. Waiting for prompt.
--> Connected, but carrier signal lost! Retrying...
--> Sending: ATDT#777
--> Waiting for carrier. ATDT#777 CONNECT
--> Carrier detected. Waiting for prompt.
1]+ Stopped sudo wvdial
os@ubuntu:~$

请高手指点,这里先谢过!


最后由 go2 编辑于 2008-05-18 12:33,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-18 0:31 

注册: 2008-05-17 4:14
帖子: 153
送出感谢: 0 次
接收感谢: 0 次
摸索了很久,好象wvdial.cong文件内显示找到的moden并不是DWCL-390的,而是Conexant D480的!
所以sudo wvdial拨号不成功!

但疑惑中DWCL-390硬件驱动并没找到,而且也不算是无线网卡。因为我试过,如下所做:

用新利得加载CD ROM的ubuntu 8.04光盘,安装了ndiswrapper-common,ndiswrapper-utils-1.9,ndisgtk
然后再系统-管理-Wireless Net-添加(windows驱动的INF文件),但显示驱动不对,显然DWCL-390应该不是无线网卡。

但是在硬件中要如何添加驱动?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-18 10:14 

注册: 2008-05-17 4:14
帖子: 153
送出感谢: 0 次
接收感谢: 0 次
很晕@@

可以上网,只要在wvdial.conf把Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0这行删除即可!完整表达如下:

Dialer Defaults]
Init1 = ATZ
Modem Type = Analog Modem
ISDN = 0
New PPPD = yes
Phone = #777
Modem = /dev/ttyS0
Username = CARD
Password = CARD
Baud = 115200

然后在终端拨号,sudo wvdial,运行后出现IP,现在就是用ubuntu上的网!感谢天神!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译