当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 【已解决】更新后的问题,mentohust无法上网(感谢wowoto)
帖子发表于 : 2010-05-01 19:35 
头像

注册: 2010-04-12 12:10
帖子: 230
送出感谢: 1
接收感谢: 0 次
以前在9.10的时候用mentohust设置完之后上网一切正常
10.04正式版发布后完马上重装系统
装完后发现mentohust无法使用
设置完成之后会有提示:计时提示(9.10中看到这个就可以上网)
但却上不了网,崩溃

然后就换了ruijieclient
但是这个十分不稳定
几分钟断一次线,每次都要重新打开,好麻烦
在sudo gedit /etc/crontab 下加了
1 0 0 0 0 root ruijieclient
也解决不了

求解
尽量解决mentohust先- -


_________________
ubuntusoft | Linux 问答 | 我的博客


最后由 阿依帝 编辑于 2010-05-02 0:32,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 更新后的问题,mentohust无法上网
帖子发表于 : 2010-05-01 21:46 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
引用:
几分钟断一次线,每次都要重新打开,好麻烦


<EchoInterval>33</EchoInterval> 这个地方数值设置不要小于10,我的机器从开机到关机的>10hours之内,不需要重新连接。我的ruijieclient配置可以参考置顶贴。
<IntelligentReconnect>1</IntelligentReconnect>
PS:
crontab居然用gedit编辑... :em06


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


最后由 wowoto 编辑于 2010-05-08 0:20,总共编辑了 1 次

页首
 用户资料  
 
3 楼 
 文章标题 : Re: 更新后的问题,mentohust无法上网
帖子发表于 : 2010-05-01 23:05 
头像

注册: 2010-04-12 12:10
帖子: 230
送出感谢: 1
接收感谢: 0 次
我试试

谢谢回答
那么那个要用什么打开编辑啊crontab


_________________
ubuntusoft | Linux 问答 | 我的博客


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 更新后的问题,mentohust无法上网
帖子发表于 : 2010-05-01 23:14 
头像

注册: 2009-11-03 16:24
帖子: 908
送出感谢: 0 次
接收感谢: 0 次
他的意思就是,你可以尝试用vi...之类的


_________________
OMG, this is a signature!—_—|
FollowMe......


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 更新后的问题,mentohust无法上网
帖子发表于 : 2010-05-01 23:23 
头像

注册: 2010-04-12 12:10
帖子: 230
送出感谢: 1
接收感谢: 0 次
VI是什么
我是纯新手阿 :em06


_________________
ubuntusoft | Linux 问答 | 我的博客


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 更新后的问题,mentohust无法上网
帖子发表于 : 2010-05-01 23:39 
头像

注册: 2010-04-12 12:10
帖子: 230
送出感谢: 1
接收感谢: 0 次
<EchoInterval>33</EchoInterval>我也是弄33,但还是会掉。。
是不是很悲剧


_________________
ubuntusoft | Linux 问答 | 我的博客


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 更新后的问题,mentohust无法上网
帖子发表于 : 2010-05-01 23:47 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
阿依帝, win.milan, 我的意思是
代码:
crontab -e

阿依帝, 我把我自己的贴给你——不过,学校不同,您自己看下rujieclient的wiki参考下:
代码:
<?xml version="1.0" encoding="UTF-8"?>
<ruijie.conf version="0.8.2">
  <!--This is a sample configuration file of RuijieClient, change it appropriately according to your settings.-->
  <account>
    <Name>COUNT</Name> #账户
    <Password>PASSWORD</Password>#密码
  </account>
  <settings>
    <!--Network Adapter Name-->
    <NIC>eth0</NIC> #网卡
    <!--0: Standard, 1: Private-->
    <AuthenticationMode>1</AuthenticationMode> #认证模式
    <EchoInterval>33</EchoInterval> #保活延时
    <!--IntelligentReconnect: 0: Disable IntelligentReconnect, 1: Enable IntelligentReconnect -->
    <IntelligentReconnect>1</IntelligentReconnect>       # #自从重连!1是启用,0是禁用!Very important!!注意!
    <!--AutoConnect: 0: Disable AutoConnect, 1: Enable AutoConnect (only available in gruijieclient) -->
    <AutoConnect>0</AutoConnect>  #仅用于gruijieclient,可以不管。
    <!--Fake Version for cheating server-->
    <FakeVersion>3.63</FakeVersion> #版本欺骗
    <!--Fake IP for cheating server-->
    <FakeAddress></FakeAddress>
    <!--DHCP mode 0: Disable, 1: Enable DHCP before authentication, 2: Enable DHCP after authentication 3: DHCP after DHCP authentication andre-authentication(You should use this if your net env is DHCP)-->
    <DHCPmode>2</DHCPmode>  #DHCP认证模式选择
    <!--Add if you don't want ruijieclient to ping the default gateway-->
    <PingHost></PingHost>
  </settings>
</ruijie.conf>
~
~


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


最后由 wowoto 编辑于 2010-05-01 23:53,总共编辑了 1 次

页首
 用户资料  
 
8 楼 
 文章标题 : Re: 更新后的问题,mentohust无法上网
帖子发表于 : 2010-05-01 23:53 
头像

注册: 2010-04-12 12:10
帖子: 230
送出感谢: 1
接收感谢: 0 次
不过确实好了很多 :em09


_________________
ubuntusoft | Linux 问答 | 我的博客


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 更新后的问题,mentohust无法上网
帖子发表于 : 2010-05-01 23:57 
头像

注册: 2010-04-12 12:10
帖子: 230
送出感谢: 1
接收感谢: 0 次
谢谢你阿
我的
<?xml version="1.0" encoding="UTF-8"?>
<ruijie.conf version="0.8.1svn129">
<!--This is a sample configuration file of RuijieClient, change it appropriately according to your settings.-->
<account>
<Name></Name>
<Password></Password>
</account>
<settings>
<!--Network Adapter Name-->
<NIC>eth0</NIC>
<!--0: Standard, 1: Private-->
<AuthenticationMode>1</AuthenticationMode>
<EchoInterval>50</EchoInterval>
<!--IntelligentReconnect: 0: Disable IntelligentReconnect, 1: Enable IntelligentReconnect -->
<IntelligentReconnect>1</IntelligentReconnect>
<!--AutoConnect: 0: Disable AutoConnect, 1: Enable AutoConnect (only available in gruijieclient) -->
<AutoConnect>1</AutoConnect>
<!--Fake Version for cheating server-->
<FakeVersion>3.95</FakeVersion>
<!--Fake IP for cheating server-->
<FakeAddress></FakeAddress>
<!--DHCP mode 0: Disable, 1: Enable DHCP before authentication, 2: Enable DHCP after authentication 3: DHCP after DHCP authentication andre-authentication(You should use this if your net env is DHCP)-->
<DHCPmode>0</DHCPmode> //这里如果我用2的话会认证不了,一直卡在搜索服务那,最后说重复次数过多
<!--Add if you don't want ruijieclient to ping the default gateway-->
<PingHost></PingHost>
</settings>
</ruijie.conf>


_________________
ubuntusoft | Linux 问答 | 我的博客


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 更新后的问题,mentohust无法上网
帖子发表于 : 2010-05-02 0:00 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
引用:
<!--AutoConnect: 0: Disable AutoConnect, 1: Enable AutoConnect (only available in gruijieclient) -->
<AutoConnect>1</AutoConnect>
——>0
只用于gruijieclient

引用:
<!--DHCP mode 0: Disable, 1: Enable DHCP before authentication, 2: Enable DHCP after authentication 3: DHCP after DHCP authentication andre-authentication(You should use this if your net env is DHCP)-->
<DHCPmode>0</DHCPmode> //这里如果我用2的话会认证不了,一直卡在搜索服务那,最后说重复次数过多


这个确实,不同学校会有不同的,您选自己可用的就好,从windows的ruijie客户端可以看到设置。

引用:
<FakeVersion>3.63</FakeVersion> #版本欺骗
这个,您学校用的客户端版本很高吗@:)我们的是3.94


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


最后由 wowoto 编辑于 2010-05-02 0:02,总共编辑了 1 次

页首
 用户资料  
 
11 楼 
 文章标题 : Re: 更新后的问题,mentohust无法上网
帖子发表于 : 2010-05-02 0:01 
头像

注册: 2010-04-12 12:10
帖子: 230
送出感谢: 1
接收感谢: 0 次
看了你的教程后好很多了
以前用ruijieclient基本上两分钟就掉,现在可以撑比较久了


_________________
ubuntusoft | Linux 问答 | 我的博客


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 更新后的问题,mentohust无法上网
帖子发表于 : 2010-05-02 0:03 
头像

注册: 2010-04-12 12:10
帖子: 230
送出感谢: 1
接收感谢: 0 次
我把<AutoConnect>1</AutoConnect>
改回来了
现在测试看看

已经有5分多钟没掉了 :em11
太感谢你了


_________________
ubuntusoft | Linux 问答 | 我的博客


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 更新后的问题,mentohust无法上网
帖子发表于 : 2010-05-02 0:06 
头像

注册: 2010-04-12 12:10
帖子: 230
送出感谢: 1
接收感谢: 0 次
我们学校用的是3.95的
..
3.6X的也可以用


_________________
ubuntusoft | Linux 问答 | 我的博客


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 更新后的问题,mentohust无法上网
帖子发表于 : 2010-05-02 0:06 
头像

注册: 2009-04-11 12:17
帖子: 3049
送出感谢: 0 次
接收感谢: 0 次
阿依帝 写道:
看了你的教程后好很多了,以前用ruijieclient基本上两分钟就掉,现在可以撑比较久了

呵呵,好用了就好,只是配置问题,你原来说的问题我在arch用的时候也遇到,后来才发现自己粗心忘了修改自动重连||
我在UBUNTU,Archlinux下用的都是ruijieclient连接校园网。FreeBSD下用的是mentohust,主要是因为ruijieclient在freebsd下没编译通过。

PS:我相信,只要你能撑下去,5小时也不会断线的。:) :em04


_________________
wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 更新后的问题,mentohust无法上网
帖子发表于 : 2010-05-02 0:18 
头像

注册: 2010-04-12 12:10
帖子: 230
送出感谢: 1
接收感谢: 0 次
还没断

很好很强大

谢谢了


_________________
ubuntusoft | Linux 问答 | 我的博客


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 20 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译