[分享]锐捷开机自动认证

回复
头像
lmyessential
帖子: 27
注册时间: 2007-07-22 23:07
来自: 福州
送出感谢: 0
接收感谢: 0
联系:

[分享]锐捷开机自动认证

#1

帖子 lmyessential » 2007-11-26 20:00

先到官网载xrgsu ,然后sudo cp xrgsu /usr/local/bin,以下以7.10 为例
点右上角的网络配置,输入你的ip,gateway和dns等,然后
xrgsu需要libpcap的支持,ubuntu默认有libpcap.so.0.9.7,而xrgsu编写的时候要找libpcap.so.0.6.2
所以我们就
sudo ln -s /usr/lib/libpcap.so.0.9.7 /usr/lib/libpcap.so.0.6.2
然后
xrgsu编写的时候要libstdc++.so.5,而7.10中的为libdstc++.so.6.0.9,软连接后发现不行,所以附上libdstc++.so.5.07,下载后重命名为libdstc++.so.5拷到/usr/lib/下就可以了
然后
sudo xrgsu -a,输入帐号和密码,然后选项默认,你直接回车就行了,不行的话就多试几次!
还不行的话就看看你是不是双系统了,万恶的micorsoft的集成网卡驱动设置了每次windows关机后在主板的某个地方留下一个信息,禁止网卡启动,等下次windows启动后在重新配置,开启网卡,
网卡都没启动,怎么连网呢?
所以去看下网卡,如果网卡灯不亮,就有可能是这个问题了,有两种方法解决:
1.进入windwos,进入网卡的配置,
设置网卡属性里的wake on lan为开启,
2.断电去掉主板上的信息就行了.
然后进入ubuntu下在试下上面的方法把!
自动认证方法如下:
首先由于要用到expect,所以

sudo apt-get install expect expect-dev

然后写脚本

cd /usr/local/bin

sudo touch autoruijie.sh

sudo vi autoruijie.sh

在其中写入如下脚本:(以下脚本引用linuxjerry在linuxsir中发的贴)

#! /usr/bin/expect
spawn su -c xrgsu
expect “Password:*”
send “这里输入你的root密码\r”
#supplicant
expect “Please input your user name:”
send “在这里输入你的用户名\r”
expect “Please input your password:”
send “这里输入你的密码\r”
expect “Use DHCP,1-Use,0-UnUse(Default: 0):”
send “\r”
expect “Use default auth parameter,0-Use 1-UnUse(Default: 0):”
send “\r”
expect “LogOff:”
sleep 3600000
#end
保存,
如果你还没设置root的密码,请 sudo passwd root
最后加入执行权限
sudo chmod 715 /usr/local/bin/autoruijie.sh
在System/Preference/Sessions里打开会话,然后单击add,在command里写入

/usr/local/bin/autoruijie.sh

就可以了,
注,在文件中明文写入您的root密码,是很不安全的,请自行取决用否
附件
libstdc++.so.5.0.7.tar.gz
(225.72 KiB) 下载 221 次
上次由 lmyessential 在 2009-01-15 23:21,总共编辑 8 次。
世上总是有这么一些天才,他们将0和1组织成了 LINUX,将那枯燥的频率组织成了令人感动的声音!
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#2

帖子 stlxv » 2007-11-26 21:05

PHP是最好的语言!不服来战!
头像
lmyessential
帖子: 27
注册时间: 2007-07-22 23:07
来自: 福州
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 lmyessential » 2007-11-29 10:03

按照你的方法是可以连上,可惜,那个没当一连网,那个xsupplicant总是占用95%的cpu,呵呵,还是用原来那个把
世上总是有这么一些天才,他们将0和1组织成了 LINUX,将那枯燥的频率组织成了令人感动的声音!
头像
liuke19851220
帖子: 92
注册时间: 2007-01-15 19:20
送出感谢: 0
接收感谢: 0

#4

帖子 liuke19851220 » 2007-12-26 11:05

试了下 ,还是不行
浪客达人
帖子: 8
注册时间: 2007-12-14 12:14
送出感谢: 0
接收感谢: 0

#5

帖子 浪客达人 » 2007-12-30 14:19

为什么我在输入 sudo xrgsu -a 后, 它说 command not found.
搞不定,高手请教一下。
头像
gcell
帖子: 429
注册时间: 2007-04-30 2:25
来自: 湖南湘潭
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 gcell » 2008-04-02 20:12

楼主这个方法还是有点问题, 用上之后发现xrgsu占用了50%左右的CPU
guanglian
帖子: 5
注册时间: 2008-04-26 13:09
送出感谢: 0
接收感谢: 0

cpu太耗了

#7

帖子 guanglian » 2008-05-04 15:55

太耗cpu了,一下就有一块cpu是100%,算了,还是不用了好
回复

回到 “校园网拨号”