当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : (已解决)光盘安装8.04无法显示分区,wubi安装提示找不到根分区目录
帖子发表于 : 2008-12-01 14:02 

注册: 2008-10-28 19:32
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
这个问题纠结了我两周了,一直无法解决!我新买的320G的SATA2笔记本硬盘,换到笔记本上之后。用livecd安装8.04,到了硬盘分区那一步,只能看到整块硬盘显示为320G,可是我已经在xp下,把分区都做好了,并且还为Ubuntu单独划分了50G的空白分区。无奈换成wubi安装,XP下的安装时一切正常,但是重启之后进入安装界面,检测分区的时候提示我无法找到根分区目录。

这个问题不知道该如何解决!希望有朋友能帮帮我,已经被这个问题搞的几近崩溃!

在没有更换硬盘之前,原本带的100GSATA的硬盘,安装Ubuntu和macos一切正常,三系统完美运行,而且都是一次性全部安装成功,没有做任何调试。为啥换了大硬盘就只能装XP了呢! :em20


最后由 psdc123 编辑于 2009-05-06 16:22,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 光盘安装8.04无法显示分区,wubi安装提示找不到根分区目录
帖子发表于 : 2008-12-01 14:45 

注册: 2008-10-28 19:32
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
顶起来,希望有朋友帮帮我!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 光盘安装8.04无法显示分区,wubi安装提示找不到根分区目录
帖子发表于 : 2008-12-01 19:52 
头像

注册: 2008-11-29 12:45
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
我也是如此,为何Uubuntu要让想接近你的人觉得你如此遥不可及。。。 :em18


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 光盘安装8.04无法显示分区,wubi安装提示找不到根分区目录
帖子发表于 : 2008-12-02 14:28 

注册: 2008-10-28 19:32
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
咳!google搜了不少帖子看了,意思都是说与我们的SATA2的硬盘有关系,说是模拟成IDE的就可以。可是我的笔记本BIOS非常简单,压根就没设置这方面的选项。

还有人说开启AHCI就行了,但是我驱动装了,也开启了,还是问题依旧!

网上找的那些安装时候可以解决无法挂载分区的命令,我全都在终端里试了,还是无法解决!

不过在CD版试用的情况下,可以正常识别各个分区,但是安装或用Ubuntu自己的磁盘工具,就无法看到分区。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 光盘安装8.04无法显示分区,wubi安装提示找不到根分区目录
帖子发表于 : 2008-12-02 15:56 

注册: 2008-10-28 19:32
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
顶起来!~


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 光盘安装8.04无法显示分区,wubi安装提示找不到根分区目录
帖子发表于 : 2008-12-02 16:09 
头像

注册: 2008-10-15 8:05
帖子: 19
地址: 有马有山的地方
送出感谢: 0 次
接收感谢: 0 次
我也不会,帮顶 :em06


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 光盘安装8.04无法显示分区,wubi安装提示找不到根分区目录
帖子发表于 : 2008-12-03 17:17 

注册: 2008-06-24 20:08
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
我也是出现了这种情况.没有人解决,那一位高手帮忙,解决


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 光盘安装8.04无法显示分区,wubi安装提示找不到根分区目录
帖子发表于 : 2008-12-19 12:16 

注册: 2008-07-14 6:29
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
完全一样的问题,顶
高手们,怎么办啊


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 光盘安装8.04无法显示分区,wubi安装提示找不到根分区目录
帖子发表于 : 2008-12-20 8:40 

注册: 2008-07-14 6:29
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
eeyy 写道:
完全一样的问题,顶
高手们,怎么办啊


试了一下用diskgen重建分区表,问题解决了
看来vista下的分区调整功能还是有bug,导致分区表出错


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 光盘安装8.04无法显示分区,wubi安装提示找不到根分区目录
帖子发表于 : 2009-04-09 13:04 

注册: 2008-10-28 19:32
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
今天在一个群里有位朋友说,需要重新编译sata2驱动,只是这个驱动如何编译呢??


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 光盘安装8.04无法显示分区,wubi安装提示找不到根分区目录
帖子发表于 : 2009-04-09 13:11 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
到底搞定没有? :em01
不知道是否Bios问题。 :em02
现在的320G问题搞定了,等到明年,打算买个单碟500G的硬盘来用了。 :em09


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 光盘安装8.04无法显示分区,wubi安装提示找不到根分区目录
帖子发表于 : 2009-04-09 22:08 

注册: 2008-05-03 23:42
帖子: 3681
送出感谢: 4
接收感谢: 6
这么久了还没解决啊 :em06
你的问题明显是分区表错误,原因就是
引用:
我已经在xp下,把分区都做好了
很明显你把分区做坏了。
跟什么 bios, sata, AHCI, 驱动这些乱七八糟的完全没有关系。


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 光盘安装8.04无法显示分区,wubi安装提示找不到根分区目录
帖子发表于 : 2009-04-21 13:17 

注册: 2008-10-28 19:32
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
billbear 写道:
这么久了还没解决啊 :em06
你的问题明显是分区表错误,原因就是
引用:
我已经在xp下,把分区都做好了
很明显你把分区做坏了。
跟什么 bios, sata, AHCI, 驱动这些乱七八糟的完全没有关系。


是吗?当时我全盘格式化后,重新建了分区表,问题依旧。用分区魔术师修复分区表也是问题依旧。


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 光盘安装8.04无法显示分区,wubi安装提示找不到根分区目录
帖子发表于 : 2009-05-06 16:20 

注册: 2008-10-28 19:32
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
问题总算解决了,看了billbear的帖子,让我受益匪浅,把这个病根彻底给铲除了!具体的做法是在http://forum.ubuntu.org.cn/viewtopic.php?f=77&t=190435

这个帖子里找到的!因为残留的 gpt 分区表标志,在曾经使用过 gpt 分区表的磁盘上用 xp 安装程序重新分区并不会抹去 gpt 标志。

注意:以下操作有潜在的风险,如有意外发生,可能会丢失数据。如果硬盘上有重要的资料,建议先备份。

代码:
sudo dd if=/dev/zero of=/dev/sda bs=1 count=8 seek=512

这会抹去 Primary GPT header 里的 GPT signature。请不要输错任何一个字,包括空格。
马上重启看看 windows 的各个盘符是否正常。不出意外的话,应该就没有问题了,备份的资料可以丢弃了。
ubuntu 安装程序应该可以进行了。

说明: GPT 分区表有两份同样的拷贝,分别在磁盘的开头 mbr LBA0 之后和磁盘的末端。
上面的操作抹去的是磁盘开头的 GPT signature,在磁盘末端尚有一个备份的 Secondary GPT header,本来也应该抹去的,但是已经不影响了。安装程序不会再把它看作 GPT 磁盘。
由于这第二份 GPT 分区表的存在,在 sudo fdisk -l 的时候依然会跳出警告

代码:
WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

你可以直接忽略这个信息。假如你是完美主义者,我再告诉你怎么抹去这第二份 GPT 分区表。
有关 GPT 的介绍,参考 http://en.wikipedia.org/wiki/GUID_Partition_Table

输入这两段代码问题彻底解决!完美安装运行!


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 光盘安装8.04无法显示分区,wubi安装提示找不到根分区目录
帖子发表于 : 2009-05-06 16:22 

注册: 2008-10-28 19:32
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
以上解决方法全部引用他人的帖子内容,希望能帮助遇到同样问题的朋友。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 18 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译