当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : wubi安装ubuntu 9.1更新后无法正常启动进入grub的解决方法
帖子发表于 : 2010-01-25 23:09 

注册: 2009-12-07 1:50
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
不知道有人发过没,我是遇到这样的问题在网上搜了后解决的,以下内容大部分来源于网络

本文适用于更新后无法启动进入gurb的情况

sh:grub> insmod ntfs #加载ntfs文件
sh:grub> set root=(hdX,Y) #设置root,注意:每个系统的X,Y不同,可用ls命令查看
sh:grub> loopback loop0 /ubuntu/disks/root.disk #设置loop0
sh:grub> set root=(loop0) #重置root
sh:grub> linux /boot/vmlinuz-2.6.31-16-generic root=/dev/sdaX loop=/ubuntu/disks/root.disk ro
#输入vmlinuz后用TAB键查看目前存在的内核,并不一定是2.6.31-16,后面的X跟前文一样
sh:grub> initrd /boot/initrd.img-2.6.31-16-generic #挂载系统镜像文件
sh:grub> boot #引导加载

关于硬盘分区(hdX,Y),很多前辈都发贴说明过,我也不想班门弄斧,只指出两个问题:
1、跟Windows中的系统信息显示的X,Y不一定相同
2、grub不区分是否SCSI,用hd即可,而linux里的sda1相当于grub中的(hd0,1),即第一个硬盘的第一个分区

若下次重启还是grub界面,把/boot/grub/grub.cfg 复制到 /host/ubuntu/install/boot/grub/grub.cfg即可


页首
 用户资料  
 
2 楼 
 文章标题 : Re: wubi安装ubuntu 9.1更新后无法正常启动进入grub的解决方法
帖子发表于 : 2010-01-26 0:59 

注册: 2009-12-15 1:11
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
总是提示 /dev/sda0/ 不存在
另外为什么会出现进不了ubuntu的情况啊


页首
 用户资料  
 
3 楼 
 文章标题 : Re: wubi安装ubuntu 9.1更新后无法正常启动进入grub的解决方法
帖子发表于 : 2010-01-26 19:59 

注册: 2009-12-07 1:50
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
sc-cloud 写道:
总是提示 /dev/sda0/ 不存在
另外为什么会出现进不了ubuntu的情况啊


grub中第一个逻辑分区是(hd0,4),假设你有一个硬盘,分C、D、E、F四个区,C是主分区,其他是逻辑分区,
那么,
C盘是(hd0,0);
D盘是(hd0,4);
E盘是(hd0,5);
F盘是(hd0,6);

而在linux中,sd-X-Y
X表示硬盘,a表示第一块硬盘,第二块是b,以此类推
Y表示分区,1表示第一个分区,第二个是2,以此类推

sda1表示第一块硬盘的第一个分区,是没有sda0的,所以提示不存在

进不了的原因很多,我是由于更新后系统自动修改了配置里的读取路径导致的


页首
 用户资料  
 
4 楼 
 文章标题 : Re: wubi安装ubuntu 9.1更新后无法正常启动进入grub的解决方法
帖子发表于 : 2010-01-26 20:06 
头像

注册: 2008-04-26 12:41
帖子: 11000
送出感谢: 11
接收感谢: 38
:em09


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


页首
 用户资料  
 
5 楼 
 文章标题 : Re: wubi安装ubuntu 9.1更新后无法正常启动进入grub的解决方法
帖子发表于 : 2010-02-01 11:02 
头像

注册: 2008-03-10 23:09
帖子: 38
地址: UESTC_Qingshuihe
送出感谢: 0 次
接收感谢: 0 次
通过LZ的方法,可以进入系统了,但是重启之后,选择最新的内核(我是18),无法进入系统,貌似说要我载入什么信息,按任意键退出,然后我按了任意键,选择老的内核就进入系统了,难道只能把新内核删了不成~
哎~


页首
 用户资料  
 
6 楼 
 文章标题 : Re: wubi安装ubuntu 9.1更新后无法正常启动进入grub的解决方法
帖子发表于 : 2010-03-03 22:22 
头像

注册: 2009-11-20 21:31
帖子: 228
送出感谢: 3
接收感谢: 0 次
我也曾按http://forum.ubuntu.org.cn/viewtopic.php?f=139&t=239982
的方法修复过,但结果只是那时可进去,
重启后就不行了,总不能要我每次都输一大堆后才可进入系统吧,要有个根本的解决方法才行啊。

也曾在进入ubuntu后,把/boot/grub/grub.cfg 复制出来,在回windows下把它放到时所在盘/ubuntu/install/boot/grub/grub.cfg,但还是不行,郁闷!


页首
 用户资料  
 
7 楼 
 文章标题 : Re: wubi安装ubuntu 9.1更新后无法正常启动进入grub的解决方法
帖子发表于 : 2010-04-23 15:36 

注册: 2010-04-22 11:21
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
UThinXer 写道:
sc-cloud 写道:
总是提示 /dev/sda0/ 不存在
另外为什么会出现进不了ubuntu的情况啊


grub中第一个逻辑分区是(hd0,4),假设你有一个硬盘,分C、D、E、F四个区,C是主分区,其他是逻辑分区,
那么,
C盘是(hd0,0);
D盘是(hd0,4);
E盘是(hd0,5);
F盘是(hd0,6);

而在linux中,sd-X-Y
X表示硬盘,a表示第一块硬盘,第二块是b,以此类推
Y表示分区,1表示第一个分区,第二个是2,以此类推

sda1表示第一块硬盘的第一个分区,是没有sda0的,所以提示不存在

进不了的原因很多,我是由于更新后系统自动修改了配置里的读取路径导致的



你这个我还是没看明白,如果我UBUNTU安装在C盘,那么在输入那一大串命令的时候是不是就要输入 HD0,1 ?


页首
 用户资料  
 
8 楼 
 文章标题 : Re: wubi安装ubuntu 9.1更新后无法正常启动进入grub的解决方法
帖子发表于 : 2010-05-01 14:10 

注册: 2009-05-12 15:02
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
UThinXer 写道:
不知道有人发过没,我是遇到这样的问题在网上搜了后解决的,以下内容大部分来源于网络

本文适用于更新后无法启动进入gurb的情况

sh:grub> insmod ntfs #加载ntfs文件
sh:grub> set root=(hdX,Y) #设置root,注意:每个系统的X,Y不同,可用ls命令查看
sh:grub> loopback loop0 /ubuntu/disks/root.disk #设置loop0
sh:grub> set root=(loop0) #重置root
sh:grub> linux /boot/vmlinuz-2.6.31-16-generic root=/dev/sdaX loop=/ubuntu/disks/root.disk ro
#输入vmlinuz后用TAB键查看目前存在的内核,并不一定是2.6.31-16,后面的X跟前文一样
sh:grub> initrd /boot/initrd.img-2.6.31-16-generic #挂载系统镜像文件
sh:grub> boot #引导加载


操作完直接进入图形界面么?
我操作后直接出现 (initramfs),全是命令行操作。
输入 update-grub2 结果发现命令没法识别。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译