关于用wubi安装Ubuntu10.10,总是提示“没有定义根文件系统”的问题

Windows based Ubuntu Installer 讨论
回复
zaojon
帖子: 22
注册时间: 2007-10-17 15:06
送出感谢: 0
接收感谢: 0

关于用wubi安装Ubuntu10.10,总是提示“没有定义根文件系统”的问题

#1

帖子 zaojon » 2010-11-01 15:09

10.10出来时,就尝鲜在台式机上用WUBI安装了,不过回家在笔记本上安装时,发现重启后就出现这个问题,总是提示“没有定义根文件系统”,网上搜索了一下,发现这个现象还不少见,不过解答没有针对性,WUBI下又不存在分区操作,也和安装至WINDOWS的哪个分区没有关系,甚至和分区的格式也没有关系。
发现问题的根源是一个巧合,因为发现WUBI不能安装,所以就刻盘安装了,发现竟然到分区时,只识别整个硬盘,不能识别硬盘内分区,而刚好在论坛看到这个帖子:千奇百怪的分区表错误 - 光盘安装只能看到整个硬盘而无法看到分区的同学请过来瞧瞧。viewtopic.php?f=77&t=194802,和我的问题一样,所以就怀疑是硬盘分区可能有问题,果不其然,用diskgenius测试一下分区问题,就发现一些错误,所以怀疑可能就是因为这个分区参数错误导致WUBI安装不成功,费了大力气转移数据后,重新对硬盘分区,这里称赞一下diskgenius,的确不错,当初换新硬盘时就是怕出问题,还是用的WIDOWS的分区功能分区的,哪里知道会出现问题,当然可能是我操作或者是什么问题,(不过WINDOWS的容错能力不错呵),新分区就是使用了diskgenius,速度不错,直观,方便,推荐一下。
果然,新分区后,diskgenius检测没有错误,WUBI安装,成功!

所以,遇到总是提示“没有定义根文件系统”,这个问题时,很可能就是你硬盘分区表有错误,而UBUNTU对分区表的错误是零容忍的,找diskgenius检测一下分区表错误看,解决分区表错误就应该能解决问题了。推论,其它版本UBUNTU这个问题估计也是由于分区表错误。
xcyhome
帖子: 5
注册时间: 2010-10-31 15:38
送出感谢: 0
接收感谢: 0

Re: 关于用wubi安装Ubuntu10.10,总是提示“没有定义根文件系统”的问题

#2

帖子 xcyhome » 2010-11-01 21:26

我不试了,我的windows 7 64 旗舰版还是在办公室下载的,据说是微软的原版。烤回来后,是在从硬盘安装的,只是安装过程中没有提示要格式化C盘,所以至今C盘里还有winxp遗留下来的一些零碎东西(如ms-dos)。只是winxp的目录文件夹和程序文件夹都被我手动删除了。系统是刷bios,网上找的证书激活的,没有安装盘。现在要重新分区,一旦失败岂不是连我的win7也不保了。
wubatu
帖子: 3
注册时间: 2013-04-05 22:50
系统: Winxp
送出感谢: 0
接收感谢: 0

Re: 关于用wubi安装Ubuntu10.10,总是提示“没有定义根文件系统”的问题

#3

帖子 wubatu » 2013-04-11 19:47

楼主的描述很细致,和我现在的遇到的问题一样。我用光盘安装时,到了分区界面显示整个硬盘容量。我用wubi安装时,提示根文件系统问题,我可以按照楼主的经验试试看,谢谢哈!!
不知道光盘安装和wubi安装是否有区别呢
wubatu
帖子: 3
注册时间: 2013-04-05 22:50
系统: Winxp
送出感谢: 0
接收感谢: 0

Re: 关于用wubi安装Ubuntu10.10,总是提示“没有定义根文件系统”的问题

#4

帖子 wubatu » 2013-04-11 20:03

我检查了分区,没有报错啊。但C盘是最后一个盘符,不知道这个有没有问题?
头像
photor
论坛版主
帖子: 11003
注册时间: 2008-04-26 12:41
送出感谢: 8 次
接收感谢: 36 次

Re: 关于用wubi安装Ubuntu10.10,总是提示“没有定义根文件系统”的问题

#5

帖子 photor » 2013-04-11 23:29

wubatu 写了:我检查了分区,没有报错啊。但C盘是最后一个盘符,不知道这个有没有问题?
你用什么检查的?windows下的软件对分区表错误的定义与linux下的软件不同 :em09
wubatu
帖子: 3
注册时间: 2013-04-05 22:50
系统: Winxp
送出感谢: 0
接收感谢: 0

Re: 关于用wubi安装Ubuntu10.10,总是提示“没有定义根文件系统”的问题

#6

帖子 wubatu » 2013-04-13 17:27

photor 写了:
wubatu 写了:我检查了分区,没有报错啊。但C盘是最后一个盘符,不知道这个有没有问题?
你用什么检查的?windows下的软件对分区表错误的定义与linux下的软件不同 :em09
用diskgenius。还有一个问题,安装ubuntu没成功,但引导已经修改了,每次启动都出现windown7 和ubuntu两个选项。是否可以把ubuntu去掉呢?
头像
photor
论坛版主
帖子: 11003
注册时间: 2008-04-26 12:41
送出感谢: 8 次
接收感谢: 36 次

Re: 关于用wubi安装Ubuntu10.10,总是提示“没有定义根文件系统”的问题

#7

帖子 photor » 2013-04-13 20:08

wubatu 写了:
photor 写了:
wubatu 写了:我检查了分区,没有报错啊。但C盘是最后一个盘符,不知道这个有没有问题?
你用什么检查的?windows下的软件对分区表错误的定义与linux下的软件不同 :em09
用diskgenius。还有一个问题,安装ubuntu没成功,但引导已经修改了,每次启动都出现windown7 和ubuntu两个选项。是否可以把ubuntu去掉呢?
diskgenius不行,最好用跨平台的testdisk来检查
windows是什么版本?vista及以上版本用bcd工具,xp及以下版本直接改boot.ini :em09
酷酷的小黑人
帖子: 1
注册时间: 2013-04-09 10:08
系统: ubuntu.xp
送出感谢: 0
接收感谢: 0

Re: 关于用wubi安装Ubuntu10.10,总是提示“没有定义根文件系统”的问题

#8

帖子 酷酷的小黑人 » 2013-05-28 11:09

很多都不懂.如果是分区问题要重新对硬盘分区,怎么操作我不会,重新对硬盘分区对C盘系统的文件什么的有影响吗?能不能教教我重新对硬盘分区具体的操作


.. :em19 :em19 :em19 :em19
回复

回到 “Wubi安装讨论”