win7+wubi 启动时提示 No wubildr 和 unknown command 'loadfont'

Windows based Ubuntu Installer 讨论
回复
leon0
帖子: 2
注册时间: 2010-12-08 12:17
送出感谢: 0
接收感谢: 0

win7+wubi 启动时提示 No wubildr 和 unknown command 'loadfont'

#1

帖子 leon0 » 2010-12-08 15:58

win7 + wubi ubuntu 10.04
今天启动后提示:

Try (hd0,0): NTFS5: No wubildr

error: unknown command 'loadfont'
error:

目前只能进入win7, 怎么进入 ubuntu啊?
singyu20
帖子: 32
注册时间: 2010-11-15 18:35
送出感谢: 0
接收感谢: 0

Re: win7+wubi 启动时提示 No wubildr 和 unknown command 'loadfont'

#2

帖子 singyu20 » 2010-12-09 0:13

leon0 写了:win7 + wubi ubuntu 10.04
今天启动后提示:

Try (hd0,0): NTFS5: No wubildr

error: unknown command 'loadfont'
error:

目前只能进入win7, 怎么进入 ubuntu啊?
vista也是这样,同跪求答案
不过我的还是可以进ubuntu的,^_^,就是开机不美观
camel2320
帖子: 2
注册时间: 2010-12-08 19:46
送出感谢: 0
接收感谢: 0

Re: win7+wubi 启动时提示 No wubildr 和 unknown command 'loadfont'

#3

帖子 camel2320 » 2010-12-09 13:07

我也一样啊 目前还没解决
leon0
帖子: 2
注册时间: 2010-12-08 12:17
送出感谢: 0
接收感谢: 0

Re: win7+wubi 启动时提示 No wubildr 和 unknown command 'loadfont'

#4

帖子 leon0 » 2010-12-09 18:58

搞定了,可以进 ubuntu了。
参见:
http://ubuntu-ky.ubuntuforums.org/showt ... p=10165304
以下是解决方案:
Boot a live CD, then edit grub.cfg as follows:
Code:

sudo mkdir /media/win
sudo mount /dev/sda1 /media/win
sudo mount -o loop /media/win/ubuntu/disks/root.disk /mnt
sudo cp /mnt/boot/grub/grub.cfg /mnt/boot/grub/grub.cfg.copy
sudo chmod +w /mnt/boot/grub/grub.cfg
gksu gedit /mnt/boot/grub/grub.cfg

Delete all lines up to (not including) the first line that starts with "menuentry"
Save, reboot.

只不过 开头的 no wubildr 还有。
Eric.He
帖子: 5
注册时间: 2011-03-17 21:45
送出感谢: 0
接收感谢: 0

Re: win7+wubi 启动时提示 No wubildr 和 unknown command 'loadfont'

#5

帖子 Eric.He » 2011-09-27 7:18

Try (hd0,0): NTFS5: No wubildr这个问题可以这样解决
解决方法:windows 7有一个100M的系统保留区,用来保留引导启动系统的相关程序。
1、右键点击我的电脑->管理->磁盘管理->右键点击100M的 分区->更改驱动器号和路径->为该分区选择一个临时的驱动器号(比如H盘)
2、在Ubuntu所在的磁盘分区(比如G盘)将"wubildr" 和"wubildr.mbr"两个文件拷贝到步骤1说道德H盘
3、右键点击我的电脑->管理->磁盘管理->右键点击100M的分区->更改驱动器号和路径->删除临时的驱动器号
4、重启机器,问题解决

但是我的这个问题解决后只显示Try (hd0,1):NTFS5:
然后光标就一直闪硬盘灯熄灭,知道为什么吗?
回复

回到 “Wubi安装讨论”