[问题]为什么最近Firefox一直都不能在论坛上发贴?

论坛日常站务以及建议或咨询
回复
Vstar
帖子: 273
注册时间: 2005-10-03 14:13
来自: Tokushima, Japan
送出感谢: 0
接收感谢: 1 次
联系:

[问题]为什么最近Firefox一直都不能在论坛上发贴?

#1

帖子 Vstar » 2006-06-09 12:45

如题
Vstar
帖子: 273
注册时间: 2005-10-03 14:13
来自: Tokushima, Japan
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 Vstar » 2006-06-09 13:16

回贴时提示posing.php保存位置,现在用的是Dapper,Firefox 1.5.0.3。回贴和编辑时都出现这个现象
头像
oneleaf
论坛管理员
帖子: 10238
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 107 次

#3

帖子 oneleaf » 2006-06-09 14:25

不会啊,我这边都正常。我用的系统、浏览器和楼主一样。
头像
Tenyears
帖子: 2245
注册时间: 2005-06-30 15:46
来自: 成都
送出感谢: 0
接收感谢: 0

#4

帖子 Tenyears » 2006-06-09 15:06

一样的 ,没问题
Humanity to others // 己所不欲,勿施与人
Laptop: ThinkPad X220 --- Win7 Home / Ubuntu 12.04
Desktop: Win7/Ubuntu 12.04
Server: Ubuntu12.04
头像
nobrain
帖子: 808
注册时间: 2005-08-25 13:58
来自: ustc
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 nobrain » 2006-06-09 20:07

我的也是,有时候可以发,有时候又不能发,现在在用konqueror发。如果用mozilla发,会出现Bad Request,说server不能理解浏览器发送的信息。
爱喝真猪奶茶的夜鸣猪
xep007
帖子: 870
注册时间: 2006-01-03 20:44
送出感谢: 0
接收感谢: 6 次

#6

帖子 xep007 » 2006-06-09 20:32

有这样的事?
xep007
帖子: 870
注册时间: 2006-01-03 20:44
送出感谢: 0
接收感谢: 6 次

#7

帖子 xep007 » 2006-06-09 20:32

刚验证了,一切正常啊。
头像
oneleaf
论坛管理员
帖子: 10238
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 107 次

#8

帖子 oneleaf » 2006-06-09 20:35

初步查明是内核和网卡有些不兼容,出现如下的现像:

RX packets:12262249 errors:0 dropped:0 overruns:0 frame:42881

出现大量的损坏帧。解决办法不了解,等待官方新的server内核包。

网卡为: Ethernet controller: Marvell Technology Group Ltd. 88E8053 Gigabit Ethernet Controller (rev 19)
头像
oneleaf
论坛管理员
帖子: 10238
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 107 次

#9

帖子 oneleaf » 2006-06-09 20:38

代码: 全选

# ethtool -i eth0
driver: sky2
version: 0.15
firmware-version: N/A
bus-info: 0000:02:00.0

# ethtool -S eth0
NIC statistics:
     tx_bytes: 21743026439
     rx_bytes: 1630303592
     tx_broadcast: 20
     rx_broadcast: 101581
     tx_multicast: 6
     rx_multicast: 54838
     tx_unicast: 16985260
     rx_unicast: 12131739
     tx_mac_pause: 0
     rx_mac_pause: 0
     collisions: 0
     late_collision: 0
     aborted: 0
     multi_collisions: 0
     fifo_underrun: 0
     fifo_overflow: 0
     rx_toolong: 0
     rx_jabber: 0
     rx_runt: 0
     rx_too_long: 0
     rx_fcs_error: 0

# ethtool eth0
Settings for eth0:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: Twisted Pair
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: g
        Wake-on: d
        Current message level: 0x000000ff (255)
        Link detected: yes
如果有人了解这个请支招。
头像
oneleaf
论坛管理员
帖子: 10238
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 107 次

#10

帖子 oneleaf » 2006-06-09 21:36

我用了一个很笨的方法,将防火墙设置为仅仅从服务器对外访问smtp dns http irc 端口,稍微好转。
头像
哇msn
帖子: 50
注册时间: 2006-06-02 9:29
送出感谢: 0
接收感谢: 0

#11

帖子 哇msn » 2006-06-10 11:24

posting.php
经常回贴失败,xp下一样,估计不是网卡驱动的问题
头像
oneleaf
论坛管理员
帖子: 10238
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 107 次

#12

帖子 oneleaf » 2006-06-10 13:21

哇msn 写了:posting.php
经常回贴失败,xp下一样,估计不是网卡驱动的问题
我是说是这台服务器的网卡驱动的问题,呵呵,不是你的电脑的网卡问题。
头像
oneleaf
论坛管理员
帖子: 10238
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 107 次

#13

帖子 oneleaf » 2006-06-10 23:07

换了最新的内核
~$ uname -a
Linux ubuntuserver 2.6.17-1-386 #1 Mon Jun 5 17:06:27 UTC 2006 i686 GNU/Linux

查看了驱动的版本一个巨大的提升:由0.15 到 1.4 呵呵,先试试看有没有问题。

$ sudo ethtool -i eth0
Password:
driver: sky2
version: 1.4
firmware-version: N/A
bus-info: 0000:02:00.0
头像
DarkEyes
帖子: 548
注册时间: 2005-07-01 13:09
来自: 广西南宁
送出感谢: 0
接收感谢: 1 次

#14

帖子 DarkEyes » 2006-06-10 23:27

怪不得今天下午老弄不上去
今天把802认证弄好了:)开心
最新座驾:华晨中华酷宝 1.8T手动
头像
oneleaf
论坛管理员
帖子: 10238
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 107 次

#15

帖子 oneleaf » 2006-06-13 10:33

[17384811.552000] sky2 hardware hung? flushingJun
[17385591.552000] NETDEV WATCHDOG: eth0: transmit timed out
[17385591.552000] sky2 status report lost?
[17385626.552000] NETDEV WATCHDOG: eth0: transmit timed out

这个内核不稳定,网卡容易挂掉。郁闷中...
回复

回到 “论坛管理”