当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 单CD版的Ubuntu8.04开发GTK应用程序的环境怎样搭建?
帖子发表于 : 2008-07-02 12:37 

注册: 2008-06-30 11:02
帖子: 54
送出感谢: 0 次
接收感谢: 0 次
刚装了Ubuntu8.04版,单CD,好像好多东东都没有,一些头文件了,等等。
我该怎样去找那些头文件呢,如GTK的头文件和库之类的,学了两个多月了,现在还没理出一个头绪,
好烦啊


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-07-02 12:40 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
1. 连网
2. 用新立得安装需要的包


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-07-02 12:58 

注册: 2008-06-30 11:02
帖子: 54
送出感谢: 0 次
接收感谢: 0 次
楼上的,我没有联网,也不知要下载哪个包,麻烦啊


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 单CD版的Ubuntu8.04开发GTK应用程序的环境怎样搭建?
帖子发表于 : 2008-07-02 13:01 

注册: 2006-09-11 22:47
帖子: 2841
送出感谢: 0 次
接收感谢: 4
Killdog1982 写道:
刚装了Ubuntu8.04版,单CD,好像好多东东都没有,一些头文件了,等等。
我该怎样去找那些头文件呢,如GTK的头文件和库之类的,学了两个多月了,现在还没理出一个头绪,
好烦啊


没有联网,你必须要自己解决。

至于不知道该下载哪个包,简单:
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install build-essential
sudo apt-get build-dep vim
sudo apt-get build-dep kate
应该就把常用的包都装上了,其它还需要什么可以自己再慢慢装。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-07-03 10:12 
头像

注册: 2006-04-12 18:54
帖子: 4669
送出感谢: 0 次
接收感谢: 7
libgtk2.0-dev


_________________
blog:杰林修·呓


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-07-06 7:29 

注册: 2008-06-30 11:02
帖子: 54
送出感谢: 0 次
接收感谢: 0 次
再问一下,开发基本的linux程序需要什么包呢?就是不带X-Window的,控制台程序,需要什么包?
还有,如果我要开发Gnome桌面上应用的程序需要什么包啊?
多谢回答


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-07-09 18:25 
头像

注册: 2007-10-24 15:32
帖子: 108
地址: 四川省南充市
送出感谢: 1
接收感谢: 0 次
论坛里面专门有个帖子就是介绍gtk编程的。自己搜搜看嘛~


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-07-09 18:58 

注册: 2006-09-11 22:47
帖子: 2841
送出感谢: 0 次
接收感谢: 4
Killdog1982 写道:
再问一下,开发基本的linux程序需要什么包呢?就是不带X-Window的,控制台程序,需要什么包?
还有,如果我要开发Gnome桌面上应用的程序需要什么包啊?
多谢回答


不是已经告诉你了嘛!

sudo apt-get build-dep vim

就可以把gnome开发需要的和控制台程序所需要的基本的包都装上了。如果你的程序需要其他的包,编译的时候会给出提示差什么包的。

至于具体需要什么包,你自己运行了这个命令就可以看到了,

为什么我上面帖子给的命令你试都不试就问呢?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-07-15 17:43 

注册: 2008-06-30 11:02
帖子: 54
送出感谢: 0 次
接收感谢: 0 次
poet 写道:
Killdog1982 写道:
再问一下,开发基本的linux程序需要什么包呢?就是不带X-Window的,控制台程序,需要什么包?
还有,如果我要开发Gnome桌面上应用的程序需要什么包啊?
多谢回答


不是已经告诉你了嘛!

sudo apt-get build-dep vim

就可以把gnome开发需要的和控制台程序所需要的基本的包都装上了。如果你的程序需要其他的包,编译的时候会给出提示差什么包的。

至于具体需要什么包,你自己运行了这个命令就可以看到了,

为什么我上面帖子给的命令你试都不试就问呢?



sudo apt-get update
sudo apt-get upgrade
sudo apt-get install build-essential
sudo apt-get build-dep vim
sudo apt-get build-dep kate
这几个命令我都试了,我是用dvd做源的,前三个命令能成功,glibc确实装上去了,但是没有gtk,搜遍/usr目录也没有gtk.h这个文件,后两个命令执行时说无法打开文件/var/lib/apt/lists/cn.archive.ubuntu.com_ubuntu_dists_hardy_main_source_Sources - open(2 没有该文件或目录),就停下来了,不知道该怎么办了,我也试了源码安装gtk,也失败了,说libx11 not found,怎么也安装不下去了,谁能告诉我该怎么装啊


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译