[问题]请问在Ubuntu下编写gtk(2.0以上)/gnome程序都要安装哪些软件包,在新立得软件包管理

开发基于GTK+或QT的应用程序
回复
yangchaosail
帖子: 6
注册时间: 2006-06-19 14:56
送出感谢: 0
接收感谢: 0

[问题]请问在Ubuntu下编写gtk(2.0以上)/gnome程序都要安装哪些软件包,在新立得软件包管理

#1

帖子 yangchaosail » 2006-06-19 15:19

以前用redhat,完全安装,注意到/urs/include下有gtk1.2、gtk2.0和gnome文件夹。现在用Ubuntu一直不知道怎么把这些头文件加进来,请哪位指点一下,谢谢了!
头像
madoldman
帖子: 599
注册时间: 2006-02-27 20:19
来自: works system
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 madoldman » 2006-06-19 16:28

编译时在后面加`pkg-config --cflags --libs gtk+-2.0`就可以了
东西路,南北走
十字路口人咬狗
拿起狗来打砖头
砖头咬了狗一口
图片
yangchaosail
帖子: 6
注册时间: 2006-06-19 14:56
送出感谢: 0
接收感谢: 0

#3

帖子 yangchaosail » 2006-06-21 12:01

呵呵,问题解决了,原来需要安装的是libgnome-dev(gtk1.2)或libgnome2-dev.在新立得软件包管理器中找上面大软件包,其它被依赖的软件包也就自动安装,不用一个一个的安装了
回复

回到 “GTK+和QT”