在ubuntu的gnome的环境下面如何安装QT?

开发基于GTK+或QT的应用程序
回复
lenneyggyy
帖子: 5
注册时间: 2006-07-23 17:20
送出感谢: 0
接收感谢: 0

在ubuntu的gnome的环境下面如何安装QT?

#1

帖子 lenneyggyy » 2006-07-23 17:36

我安装ubuntu的使用默认的桌面环境是gnome,想安装QT,因为我对JAVA非常熟悉,非常喜欢面向对象编程。
安装QT前我已经安装了gcc和相应的g++,使用apt-get install gcc gcc-c++安装的,编译器应该是gcc4的版本。下安装QT时,先使用su切换到超级管理员身份,运行./configure通过,configure没有加任何参数,但是执行make时就报告编译的错误,我下载QT3.0和QT4.1编译都是提示编译不通过,急死我了,谁能帮帮我!
头像
madoldman
帖子: 599
注册时间: 2006-02-27 20:19
来自: works system
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 madoldman » 2006-07-23 18:32

直接apt-get install libqt4-core qt4-designer qt4-dev-tools qt4-qtconfig libqt4-dev libqt4-gui libqt4-debug libqt4-debug-dev做数据库开发再加上libqt4-sql,在Ubuntu下,能用源里的东西尽量用源里的吧,自己编译好麻烦
东西路,南北走
十字路口人咬狗
拿起狗来打砖头
砖头咬了狗一口
图片
lenneyggyy
帖子: 5
注册时间: 2006-07-23 17:20
送出感谢: 0
接收感谢: 0

#3

帖子 lenneyggyy » 2006-07-25 22:16

谢谢这个大哥,ubuntu下C++我是刚学的。
以前我学JAVA,用了4年的JAVA了,JAVA该学的都学了,不该学的不想学。
现在想学Linux,理所当然学习C++,因为熟悉JAVA面向对象,C不是很喜欢。
lyuq1984
帖子: 3
注册时间: 2006-08-25 19:48
送出感谢: 0
接收感谢: 0

#4

帖子 lyuq1984 » 2006-08-28 12:26

感谢你们给我提供的解决办法,我在网上找了好几天,今天总算是解决了
回复

回到 “GTK+和QT”