有没有谁在ubuntu6.0.6下安装过qt4.1.4的?

开发基于GTK+或QT的应用程序
回复
higgs
帖子: 2
注册时间: 2006-07-25 9:59
送出感谢: 0
接收感谢: 0

有没有谁在ubuntu6.0.6下安装过qt4.1.4的?

#1

帖子 higgs » 2006-08-09 15:59

有没有安装指南,试装了一次,失败了.有没有可以成功安装的安装指南,发我一份,不胜感激
头像
ectotherm
帖子: 225
注册时间: 2006-05-23 13:35
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 ectotherm » 2006-08-10 10:27

。。。什么安装指南啊,难道你用 Enterprise Qt?

我用 Open Qt 只要 make && sudo make install 就好了,但是现在要开发 Linux 上的商业软件,不能使用 Qt 了。
higgs
帖子: 2
注册时间: 2006-07-25 9:59
送出感谢: 0
接收感谢: 0

#3

帖子 higgs » 2006-08-10 15:42

ectotherm 写了:。。。什么安装指南啊,难道你用 Enterprise Qt?

我用 Open Qt 只要 make && sudo make install 就好了,但是现在要开发 Linux 上的商业软件,不能使用 Qt 了。


我也是这么装的,先sudo ./configure.再sudo make ,最后sudo make install。但是出错了,gcc装过的,是不是还要装什么库的?
头像
ectotherm
帖子: 225
注册时间: 2006-05-23 13:35
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 ectotherm » 2006-08-10 19:50

不清楚生成 Makefile 的话,就说明没有缺少东西啊
头像
nap
帖子: 14
注册时间: 2006-08-20 19:08
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 nap » 2006-08-22 17:28

我用的是./configure -platform linux-icc(好像是,把平台换下)
gcc的不知道为什么没编译过,好像是关于汇编的问题,只好用icc了。
我的出现类似:
{standard input}:1392: Error: bad register name `%e'
{standard input}:1400: Error: suffix or operands invalid for `call'
{standard input}:1434: Error: junk at end of line, first unrecognized character is `-'
的问题。各位如果可以也把出错信息贴上来吧。
XServer最近刚坏,不知道是不是用icc的原因。
如果有libimf.so的问题记住要把LD_LIBRARY_PATH设上
回复

回到 “GTK+和QT”