当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 求救!!两天啦。都没有装上QT。
帖子发表于 : 2009-08-15 16:39 
头像

注册: 2009-06-06 8:57
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
我的步骤是这样的!!
1.在目录/usr/include/qt 里面把qt-x11-opensource-src-4.5.2.tar解压
tar xvf qt-x11-opensource-src-4.5.2.tar
这一步是成功的。生成了一个qt-x11-opensource-src-4.5.2目录。
然后cd qt-x11-opensource-src-4.5.2 进去。

2.
登录到root用户,本应该依次运行以下命令:
#./configure
#gmake
#gmake install

但是:#./configure 在这不一步就出事了。

Do you accept the terms of either license?yes
Creating qmake. Please wait...
g++ -c -o project.o -pipe -DQMAKE_OPENSOURCE_EDITION -I.
。。。。。一大串字符后。
最后显示。
Basic XLib functionality test failed!
You might need to modify the include and library search paths by editing
QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in /usr/include/qt/qt-x11-opensource-src-4.5.2/mkspecs/linux-g++.
到了这里就不行了。。
下面的两条命令也没有成功。。。

如果有同学也遇到这样的问题。。可以告诉小弟如何弄吗。。
小菜。。现拜谢!!


_________________
本人花580元从国嵌淘宝店上购买的正版,现在尝试创业,低价转让。qq:1531267696


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求救!!两天啦。都没有装上QT。
帖子发表于 : 2009-08-15 17:27 
头像

注册: 2008-11-09 18:07
帖子: 580
地址: SCU
送出感谢: 0 次
接收感谢: 0 次
不能apt吗?


_________________
。。。。。。。。感觉好山寨。。。。。。。。。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求救!!两天啦。都没有装上QT。
帖子发表于 : 2009-08-15 17:30 
头像

注册: 2007-06-13 15:57
帖子: 12566
地址: 在他乡
送出感谢: 50
接收感谢: 87
该求助的时候就求助,都2天了 :em04


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求救!!两天啦。都没有装上QT。
帖子发表于 : 2009-08-15 17:33 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
基本X库测试失败。兄弟先看下wiki,把整套工具链和各种库先装全了,省得以后缺这缺那。 :em04
此外,你可以下另外一个版本,不要编译的,Qt编译好花时间。我曾经编译过一次,花了一个白天(机器比较老)。 :em20


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求救!!两天啦。都没有装上QT。
帖子发表于 : 2009-08-15 19:11 
头像

注册: 2009-07-07 19:52
帖子: 240
送出感谢: 0 次
接收感谢: 0 次
还是用 apt 吧,方便简单。


_________________
阿呆 : 天下第一呆!


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 求救!!两天啦。都没有装上QT。
帖子发表于 : 2009-08-16 15:45 

注册: 2009-08-16 15:43
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
Qt经典出错信息之”Basic XLib functionality test failed!”
此完整出错信息是在./configure阶段 Basic XLib functionality test failed! You might need to modify the include and library search paths by editing QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in /home/zhu/Qt/qt-x11-opensource-src-4.5.2/mkspecs/linux-g++ 在Qt-4.4以前的版本没怎么碰到过,想当然的认为是安装libX11-dev/libXext-dev就完事了。其实并非那么回事~还是老办法,以不变应万变。进config.test/x11/xlib 执行make命令,看出错信息 g++ -Wl,-O1 -o xlib xlib.o -L/usr/X11R6/lib -lXext -lX11 -lm /usr/bin/ld: cannot find -lXext 看到了吧,g++在/usr/X11R6/lib下,找不到libXext.so呢。 但是我的libxext和libX11-dev分明安装了呀…. 那安装到哪里去了呢 /usr/X11R6/lib# dpkg -L libxext6 libx11-dev|grep libX /usr/lib/libXext.so.6.4.0 /usr/lib/libXext.so.6 /usr/lib/libX11.a /usr/lib/libX11.so 瞧瞧,指定的库路径不是常见的/usr/X11R6/lib吧,所以根据刚开始的提示改动/home/zhu/Qt/qt-x11- opensource-src-4.5.2/mkspecs/linux-g++/qmake.conf 里的 QMAKE_LIBDIR_X11路径吧 (不要告诉我说上面的qmake.conf里没有这个环境变量哦,里面有个include,在别的文件里~) 本人使用的是Debian5,各位看官自己的LibX11装到哪里,务必自行研究。罗唆一句,碰到configure的问题,最靠谱的还是看config.test里的东西。比如,本文问题曾在qtcn上有一帖子 http://www.qtcn.org/bbs/simple/index.php?t18095.html ,各路回答,无法解释本文现象。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 求救!!两天啦。都没有装上QT。
帖子发表于 : 2009-08-16 17:20 

注册: 2009-08-16 15:43
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
我现在的麻烦就是,我知道自己的LibX11安装在了/usr/lib/中,可是我不知道在/linux-g++/qmake.conf中怎么加语句!
我对linucx太菜了,我好心人知道给发上来吧!已经搞了好第时间了!


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 求救!!两天啦。都没有装上QT。
帖子发表于 : 2009-08-16 19:43 
头像

注册: 2009-06-06 8:57
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
tongxk0812 写道:
我现在的麻烦就是,我知道自己的LibX11安装在了/usr/lib/中,可是我不知道在/linux-g++/qmake.conf中怎么加语句!
我对linucx太菜了,我好心人知道给发上来吧!已经搞了好第时间了!


我今天早上装好咯。呵呵。。
libX11是放在/usr/lib上的。没错哦。。我的也是。。

你先装好libx-dev跟libXext-dev这两个包。还有他们的一些依赖的包。。。
给你几个命令:
sudo dpkg -L xxx 查找xxx的安装内容
sudo apt-cache search xxx 查找xxx软件包
sudo apt-cache depend xxx 查找xxx依赖了那些包。。。

你装好那些包后,应该就没有问题的拉。。不过。在这之前,你好要安装g++的。

下面的步骤跟书上或者。解包qt-x11-opensource-src-4.5.2.tar后有个INSTALL文件,有安装步骤的。。

而且网上很多地方也有介绍。。。。。。

祝你好运咯。。要坚持装下去。。哦。。 :em06


_________________
本人花580元从国嵌淘宝店上购买的正版,现在尝试创业,低价转让。qq:1531267696


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 求救!!两天啦。都没有装上QT。
帖子发表于 : 2009-08-16 19:45 
头像

注册: 2009-06-06 8:57
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
wangdu2002 写道:
基本X库测试失败。兄弟先看下wiki,把整套工具链和各种库先装全了,省得以后缺这缺那。 :em04
此外,你可以下另外一个版本,不要编译的,Qt编译好花时间。我曾经编译过一次,花了一个白天(机器比较老)。 :em20


我编译了两个小时。呵呵。 :em06


_________________
本人花580元从国嵌淘宝店上购买的正版,现在尝试创业,低价转让。qq:1531267696


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 求救!!两天啦。都没有装上QT。
帖子发表于 : 2009-08-16 23:06 

注册: 2009-08-16 15:43
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
dengroj 你好:

我用的是红旗7.0, g++和gcc已经装好了:

# g++ --version 键入后系统反馈回:
g++ (GCC) 4.3.2 20081105 (Red Hat 4.3.2-7)
Copyright © 2008 Free Software Foundation, Inc.

# gcc --version 键入后系统反馈回:
gcc (GCC) 4.3.2 20081105 (Red Hat 4.3.2-7)
Copyright © 2008 Free Software Foundation, Inc. 这说明g++和gcc应该没有问题。

不过找不到libx-dev跟libXext-dev这两个包,在rpm管理器中也找不到,应该没有安装!

可是我不知道去那里找这两个包,怎么的安装?请楼主详解,为什么红旗7不能运行apt-get命令!?


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 求救!!两天啦。都没有装上QT。
帖子发表于 : 2009-08-17 18:08 
头像

注册: 2009-06-06 8:57
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
tongxk0812 写道:
dengroj 你好:

我用的是红旗7.0, g++和gcc已经装好了:

# g++ --version 键入后系统反馈回:
g++ (GCC) 4.3.2 20081105 (Red Hat 4.3.2-7)
Copyright © 2008 Free Software Foundation, Inc.

# gcc --version 键入后系统反馈回:
gcc (GCC) 4.3.2 20081105 (Red Hat 4.3.2-7)
Copyright © 2008 Free Software Foundation, Inc. 这说明g++和gcc应该没有问题。

不过找不到libx-dev跟libXext-dev这两个包,在rpm管理器中也找不到,应该没有安装!

可是我不知道去那里找这两个包,怎么的安装?请楼主详解,为什么红旗7不能运行apt-get命令!?


:em06 。。那我帮不上啦。。你在论坛发帖问问大伙吧。。我没有试过红旗。

不过。好像fedora跟debian都自带qt的。。呵呵。。好像fedora出fedora 11了。。你可以试试啊。。。

加油哦。!!


_________________
本人花580元从国嵌淘宝店上购买的正版,现在尝试创业,低价转让。qq:1531267696


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 求救!!两天啦。都没有装上QT。
帖子发表于 : 2009-08-18 13:15 

注册: 2009-08-16 15:43
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
:em05 我也安装成功了,用的是qt-sdk-linux-x86-opensource-2009.03.1.bin,解决了出错信息“Installer payload initialization failed. This is likely due to an incomplete or corrupt downloaded file.“的问题后顺利安装!


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 求救!!两天啦。都没有装上QT。
帖子发表于 : 2009-10-04 8:24 

注册: 2008-10-31 22:12
帖子: 6546
系统: 践兔
送出感谢: 18
接收感谢: 25
红旗系统最以包少、编译难通过而著称... :em06


_________________
代码:
] ls -ld //


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 求救!!两天啦。都没有装上QT。
帖子发表于 : 2009-10-11 11:00 

注册: 2007-07-11 21:12
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
apt-get install libxext-dev


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 求救!!两天啦。都没有装上QT。
帖子发表于 : 2009-11-24 0:06 
头像

注册: 2009-05-05 23:42
帖子: 360
送出感谢: 5
接收感谢: 10
呵呵,我装了红旗7试验一下,就又红旗6了,红旗6的QT不错啊,是集成的开发环境。红旗7的速度太慢,不是一般的慢。


_________________
-----------------------
在迷茫中追逐,在追逐中迷茫……
-----------------------


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 16 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译