当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 关于QT4.6的环境搭建的问题
帖子发表于 : 2010-01-18 20:49 

注册: 2008-08-27 22:21
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
我在QT官网上下了一个
Download Qt SDK for Linux/X11 32-bit** (353 MB)
好像是说包含了
Qt libraries
Qt Creator IDE
Qt development tools
还需要安装别的什么吗??
我是不是只需要安装这个SDK就可以了啊

我的系统是9.10


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 关于QT4.6的环境搭建的问题
帖子发表于 : 2010-01-18 21:03 

注册: 2006-03-10 15:10
帖子: 3182
地址: xi'an China
送出感谢: 0 次
接收感谢: 2
9.10 的话,不妨直接通过ppa的源安装吧


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 关于QT4.6的环境搭建的问题
帖子发表于 : 2010-01-19 13:15 

注册: 2008-08-27 22:21
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
ppa的源??
我都已经下好了


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 关于QT4.6的环境搭建的问题
帖子发表于 : 2010-01-19 13:42 

注册: 2006-03-10 15:10
帖子: 3182
地址: xi'an China
送出感谢: 0 次
接收感谢: 2
既然下好了,直接装就行了。

https://launchpad.net/~mapopa/+archive/qt4.6
引用:


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 关于QT4.6的环境搭建的问题
帖子发表于 : 2010-01-21 16:01 

注册: 2008-08-27 22:21
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
只安装这个SDK是不行的
还要
ii qt4-demos 4.5.0-0ubuntu4 Qt 4 examples and demos
ii qt4-designer 4.5.0-0ubuntu4 graphical designer for Qt 4 applications
ii qt4-dev-tools 4.5.0-0ubuntu4 Qt 4 development tools
ii qt4-doc 4.5.0-0ubuntu4 Qt 4 API documentation
ii qt4-qmake 4.5.0-0ubuntu4 Qt 4 qmake Makefile generator tool
ii qt4-qtconfig 4.5.0-0ubuntu4 Qt 4 configuration tool

g++


最后由 ighack 编辑于 2010-01-22 21:15,总共编辑了 1 次

页首
 用户资料  
 
6 楼 
 文章标题 : Re: 关于QT4.6的环境搭建的问题
帖子发表于 : 2010-01-21 17:26 

注册: 2006-03-10 15:10
帖子: 3182
地址: xi'an China
送出感谢: 0 次
接收感谢: 2
ighack 写道:
只安装这个SDK是不行的
还要
ii qt4-demos 4.5.0-0ubuntu4 Qt 4 examples and demos
ii qt4-designer 4.5.0-0ubuntu4 graphical designer for Qt 4 applications
ii qt4-dev-tools 4.5.0-0ubuntu4 Qt 4 development tools
ii qt4-doc 4.5.0-0ubuntu4 Qt 4 API documentation
ii qt4-qmake 4.5.0-0ubuntu4 Qt 4 qmake Makefile generator tool
ii qt4-qtconfig 4.5.0-0ubuntu4 Qt 4 configuration tool


这个? 搞不懂你要做什么了
1. 你列出的这些包 + qtcreator = qtsdk !!
2. 9.10 官方仓库中应该都是 4.5.3了吧?你这的4.5.0从哪儿来的
3. 如果你要安装Qt4.6,又不想要麻烦,最好直接用ppa的源


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 关于QT4.6的环境搭建的问题
帖子发表于 : 2010-01-22 21:20 

注册: 2008-08-27 22:21
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
我先是安装qtsdk但还是不行,后来我又重新安装了上面的一些软件包才可以

qt-sdk-linux-x86-opensource-2009-0.5.bin

在我编译的时候提示错误


最后由 ighack 编辑于 2010-01-22 22:00,总共编辑了 1 次

页首
 用户资料  
 
8 楼 
 文章标题 : Re: 关于QT4.6的环境搭建的问题
帖子发表于 : 2010-01-22 21:56 

注册: 2008-08-27 22:21
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
正在读取软件包列表... 完成
W: GPG签名验证错误: http://ppa.launchpad.net karmic Release: 由于没有公钥,下列签名无法进行验证: NO_PUBKEY 0BE6D09EEF648708


ighack@ighack:/etc/apt$ gpg --keyserver subkeys.pgp.net --recv EF648708
gpg: 下载密钥‘EF648708’,从 hkp 服务器 subkeys.pgp.net
gpg: 密钥 EF648708:公钥“Launchpad PPA for Mariuz”已导入
gpg: 合计被处理的数量:1
gpg: 已导入:1 (RSA: 1)
ighack@ighack:/etc/apt$ gpg --export --armor EF648708 | sudo apt-key add -
OK
ighack@ighack:/etc/apt$ sudo apt-get update
获取:1 http://ppa.launchpad.net karmic Release.gpg [307B]
忽略 http://ppa.launchpad.net karmic/main Translation-zh_CN
获取:2 http://ppa.launchpad.net karmic Release [66.0kB]
命中 http://ppa.launchpad.net karmic/main Packages
命中 http://ppa.launchpad.net karmic/main Sources
下载 308B,耗时 2 秒 (130B/s)
正在读取软件包列表... 完成


那么安装qt软件包的名字是什么啊
sudo apt-get install qt4.6
sudo apt-get install qt
sudo apt-get isntall qt4.6-x11
都说无法找到软件的包


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 关于QT4.6的环境搭建的问题
帖子发表于 : 2010-01-22 22:12 

注册: 2008-08-27 22:21
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
No valid Qt version set. Set one in Tools/Options
Error while building project myqt
When executing build step 'QMake'
Canceled build.


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译