新手求教安装gtk时提示依赖关系不满足破损的软件包的解决办法。

开发基于GTK+或QT的应用程序
回复
头像
zsneoks
帖子: 43
注册时间: 2010-04-21 19:08
送出感谢: 0
接收感谢: 0

新手求教安装gtk时提示依赖关系不满足破损的软件包的解决办法。

#1

帖子 zsneoks » 2011-01-03 22:26

如题。提示如下:

$ sudo apt-get install libgtk2.0-dev
[sudo] password for z0:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
libgtk2.0-dev: 依赖: libgtk2.0-0 (= 2.20.1-0ubuntu2) 但是 2.20.1-0ubuntu2+menuproxy11 正要被安装
依赖: libglib2.0-dev (>= 2.21.3) 但是它将不会被安装
依赖: libpango1.0-dev (>= 1.20) 但是它将不会被安装
依赖: libatk1.0-dev (>= 1.13.0) 但是它将不会被安装
E: 破损的软件包



看到前边有帖子说是源选的不对,求教应该选什么源才可以正常安装呢。
这深深沉沉的夜...
不正应做点什么。。。
头像
icyomik
帖子: 76
注册时间: 2010-10-30 17:52
送出感谢: 0
接收感谢: 0

Re: 新手求教安装gtk时提示依赖关系不满足破损的软件包的解决办法。

#2

帖子 icyomik » 2011-01-04 14:18

sudo rm -rf /var/cache/apt/archives/partial/*
个人博客:http://blog.jtwo.me/
女友淘宝:http://icykiss.taobao.com/
你有什么不开心的事情,说出来让大家开心一下。
头像
zsneoks
帖子: 43
注册时间: 2010-04-21 19:08
送出感谢: 0
接收感谢: 0

Re: 新手求教安装gtk时提示依赖关系不满足破损的软件包的解决办法。

#3

帖子 zsneoks » 2011-01-04 23:35

icyomik 写了:sudo rm -rf /var/cache/apt/archives/partial/*
我是用的aptitude安装的,倒是安装上了,他说有一堆东西是降级处理了。不知会有什么坏处。
这深深沉沉的夜...
不正应做点什么。。。
回复

回到 “GTK+和QT”