LMDE 安装 gtk失败,"it is not going to be installed"

开发基于GTK+或QT的应用程序
回复
Vegertar
帖子: 18
注册时间: 2009-03-10 19:55
送出感谢: 0
接收感谢: 0

LMDE 安装 gtk失败,"it is not going to be installed"

#1

帖子 Vegertar » 2011-01-11 13:12

悲剧啊, :em19
装gnome-core-devel时
gnome-core-devel : Depends: libgail-dev (>= 2.20) but it is not going to be installed
Depends: libgtk2.0-dev (>= 2.20) but it is not going to be installed
Depends: libbonoboui2-dev (>= 2.24) but it is not going to be installed
Depends: libglade2-dev (>= 1:2.6.4) but it is not going to be installed
Depends: libgnomecanvas2-dev (>= 2.30) but it is not going to be installed
Depends: libgnomeui-dev (>= 2.24) but it is not going to be installed
Depends: libpango1.0-dev (>= 1.28) but it is not going to be installed
Depends: libgnome-desktop-dev (>= 2.30) but it is not going to be installed
Depends: libpanel-applet2-dev (>= 2.30) but it is not going to be installed
Depends: python-gnome2-desktop-dev (>= 2.30) but it is not going to be installed
Depends: libgtkhtml3.14-dev (>= 3.30) but it is not going to be installed
Depends: libgtksourceview2.0-dev (>= 2.10) but it is not going to be installed
Depends: libgail-gnome-dev (>= 1.20.2) but it is not going to be installed
Depends: libgnomekbd-dev (>= 2.30) but it is not going to be installed
Depends: libgweather-dev (>= 2.30) but it is not going to be installed
Depends: librsvg2-dev (>= 2.26) but it is not going to be installed
Depends: libwnck-dev (>= 2.30) but it is not going to be installed
Depends: libnautilus-extension-dev (>= 2.30) but it is not going to be installed
Depends: libvte-dev (>= 0.24) but it is not going to be installed
Depends: python-gnome2-dev (>= 2.28) but it is not going to be installed
Depends: python-gtk2-dev (>= 2.17) but it is not going to be installed
E: Broken packages

然后换小一点,用libgtk2.0-dev:
libgtk2.0-dev : Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed
E: Broken packages

谁能告诉我怎么解决?据说要换源,我的sources.list:
deb http://packages.linuxmint.com/ debian main upstream import
deb http://mirrors.163.com/debian testing main contrib non-free
deb http://ftp.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free

有木问题?
Vegertar
帖子: 18
注册时间: 2009-03-10 19:55
送出感谢: 0
接收感谢: 0

Re: LMDE 安装 gtk失败,"it is not going to be installed"

#2

帖子 Vegertar » 2011-01-11 13:40

唔,用aptitude解决了! :em11
回复

回到 “GTK+和QT”