Ubuntu下使用gtkmm-2.4的问题

开发基于GTK+或QT的应用程序
回复
robben225
帖子: 1
注册时间: 2011-03-15 14:50
送出感谢: 0
接收感谢: 0

Ubuntu下使用gtkmm-2.4的问题

#1

帖子 robben225 » 2011-03-15 15:01

我安装了gtkmm-2.4,用命令 pkg-config --list-all | grep gtkmm时也是能找到的,但是用命令“g++ -o main main.cpp 'pkg-config --cflags --libs gtkmm-2.4'”编译程序时,始终报下面的错:

//******************************************************
g++: pkg-config --cflags --libs gtkmm-2.4: 没有那个文件或目录
main.cpp:1:18: error: gtkmm.h: 没有那个文件或目录
//******************************************************

但是单独执行'pkg-config --cflags --libs gtkmm-2.4'也是能找到的,实在是不知道怎么回事?是不是装完gtkmm-2.4后,还需要做什么设置?


我的代码:

代码: 全选

#include<gtkmm.h>

using namespace std;

int main(int argc, char *argv[])
{
	Gtk::Main kit(argc, argv);
	Gtk::Window window;
	Gtk::Main::run(window);
	return 0;
}
头像
zheng1733
帖子: 111
注册时间: 2012-07-07 10:12
来自: 广州天河
送出感谢: 0
接收感谢: 0

Re: Ubuntu下使用gtkmm-2.4的问题

#2

帖子 zheng1733 » 2012-07-26 20:18

命令“g++ -o main main.cpp 'pkg-config --cflags --libs gtkmm-2.4' ”中包着“ `pkg-config --cflags --libs gtkmm-2.4`” 的 单引号Tab 键上面的那个
回复

回到 “GTK+和QT”