装过gtk的哥们,过来看看

开发基于GTK+或QT的应用程序
回复
_open_
帖子: 19
注册时间: 2006-11-23 16:49
送出感谢: 0
接收感谢: 0

装过gtk的哥们,过来看看

#1

帖子 _open_ » 2006-12-18 19:40

用新立得安装发现太多的库,大多的依赖文件,发现有点麻烦,而且不知道最先装那些库。。
有那位哥们介绍下主要安装些那些库文件就OK 了?
头像
spider5
帖子: 351
注册时间: 2005-12-15 21:52
送出感谢: 0
接收感谢: 0

#2

帖子 spider5 » 2006-12-18 20:20

有新立得为你操心,不好么?手动安装这么多包,危险性很大的。
_open_
帖子: 19
注册时间: 2006-11-23 16:49
送出感谢: 0
接收感谢: 0

#3

帖子 _open_ » 2006-12-18 20:41

:lol: :lol: 我也知道,但是在新立得里面的要安装的库太多,因穷得要命的时候,硬盘的空间还得省着用啊!!!
头像
juanzhewudi
帖子: 1114
注册时间: 2006-01-19 11:55
来自: HUST
送出感谢: 0
接收感谢: 0
联系:

你上gtk的主页上看,或者在你的源代码包里看看有没有编译说明

#4

帖子 juanzhewudi » 2006-12-18 21:28

你上gtk的主页上看,或者在你的源代码包里看看有没有编译说明。。。。。对了,好像新立得里也有说明依赖性的。。。
编译这种软件很麻烦的,依赖性很难解决的。。。建议还是用新立得装,虽然版本可能不是最新的。
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#5

帖子 BigSnake.NET » 2006-12-18 21:31

sudo apt-get build-dep ***
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
_open_
帖子: 19
注册时间: 2006-11-23 16:49
送出感谢: 0
接收感谢: 0

#6

帖子 _open_ » 2006-12-18 22:11

BigSnake.NET 写了:sudo apt-get build-dep ***
root@ubuntu:~# apt-get build-dep gtkmm
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: You must put some 'source' URIs in your sources.list

还有点小问题,不知道哥们是怎么安装的,。都是用新立得安装的吗?
头像
imlazy
帖子: 136
注册时间: 2006-10-29 10:49
来自: Shanghai, China
送出感谢: 0
接收感谢: 0

#7

帖子 imlazy » 2007-04-24 18:30

_open_ 写了:Reading package lists... Done
Building dependency tree
Reading state information... Done
E: You must put some 'source' URIs in your sources.list
这应该是源的问题,我用cn99的源也是这样,换回亚洲官方源就好了。
回复

回到 “GTK+和QT”