当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决]装过Qt-X11 4.2.2的帮忙解决 一下这个问题
帖子发表于 : 2006-12-19 16:09 

注册: 2006-12-17 22:16
帖子: 12
地址: xi an
送出感谢: 0 次
接收感谢: 0 次
./configure -static
后 出现这些问题

Package glib-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `glib-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'glib-2.0' found
Package glib-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `glib-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'glib-2.0' found

This target is using the GNU C++ compiler (linux-g++).

Recent versions of this compiler automatically include code for
exceptions, which increase both the size of the Qt libraries and
the amount of memory taken by your applications.

You may choose to re-run configure with the -no-exceptions
option to compile Qt without exceptions. This is completely binary
compatible, and existing applications will continue to work.


Build type: linux-g++
Architecture: i386
Platform notes:

- Also available for Linux: linux-kcc linux-icc linux-cxx

Build ............... libs tools examples
Configuration ....... release static largefile stl sse qt3support accessibility minimal-config small-config medium-config large-config full-config reduce_exports ipv6 getaddrinfo ipv6ifname getifaddrs jpeg mng png no-gif freetype zlib nis iconv release
Debug................ no
Qt 3 compatibility... yes
QtDBus module........ no
STL support ......... yes
PCH support ......... no
MMX/SSE support ..... yes
IPv6 support ........ yes
IPv6 ifname support . yes
getaddrinfo support . yes
getifaddrs support... yes
Accessibility ....... yes
NIS support ......... yes
CUPS support ........ no
Iconv support ....... yes
Glib support ........ no
Large File support .. yes
GIF support ......... no
JPEG support ........ yes (qt)
PNG support ......... yes (qt)
MNG support ......... yes (qt)
zlib support ........ yes
OpenGL support ...... no
NAS sound support ... no
Session management .. no
XShape support ...... no
Xinerama support .... no
Xcursor support ..... no
Xfixes support ...... no
Xrandr support ...... no
Xrender support ..... no
FontConfig support .. no
XKB Support ......... no

immodule support .... yes
SQLite support ...... plugin (qt)

WARNING: Using static linking will disable the use of dynamically
loaded plugins. Make sure to import all needed static plugins,
or compile needed modules into the library.




NOTICE: Qt will not be built with XShape support.

As a result, drag-and-drop in the Qt Designer will NOT
work. We recommend that you enable XShape support by passing
the -xshape switch to ./configure.

Qt is now configured for building. Just run 'make'.
Once everything is built, you must run 'make install'.
Qt will be installed into /usr/local/Trolltech/Qt-4.2.2

To reconfigure, run 'make confclean' and 'configure'.



我 是在 ubuntu6.06环境下编译的,SHELL脚本也不会写,照着官方的教程将环境变量设好的,
PKG_CONFIG_PATH 这个怎么设?
还有就是glib2.0我在新立得软件管理器中也没有看到是不是得下?

着色部分该加什么库阿?

望高手指点!!急!


_________________
@@@@@@@@@@@@@@@@@@@
@@@@@我一直在努力.........@@@@@
@@@@@@@@@@@@@@@@@@
@@@@@@@@@@@@@@
@@@@@@@@@@@
@@@@@@@@@
@@@@@@@
Qt研究群(-):20622831 欢迎加入!


最后由 china-wei 编辑于 2006-12-27 10:15,总共编辑了 3 次

页首
 用户资料  
 
2 楼 
 文章标题 : 笨办法试试
帖子发表于 : 2006-12-19 19:55 

注册: 2006-11-29 14:04
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我也装了,没有达到WINDOWS平台的效果,但主要的程序都出来了.

我装的时候,提示是不能编译XSHARP之类的,我就直接在新立得里面加上所有的与QT有关的资源,呵呵,一切OK.

你试试呢.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-12-20 13:45 

注册: 2006-12-17 22:16
帖子: 12
地址: xi an
送出感谢: 0 次
接收感谢: 0 次
还是弄不了,晚上看到的话麻烦你联系我一下
具体说说
我的QQ:9352271
gTalk:chinawei0710@126.com


_________________
@@@@@@@@@@@@@@@@@@@
@@@@@我一直在努力.........@@@@@
@@@@@@@@@@@@@@@@@@
@@@@@@@@@@@@@@
@@@@@@@@@@@
@@@@@@@@@
@@@@@@@
Qt研究群(-):20622831 欢迎加入!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-12-20 13:51 

注册: 2006-03-10 15:10
帖子: 3182
地址: xi'an China
送出感谢: 0 次
接收感谢: 2
为啥不装源里面的4.2.0??


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-12-27 9:40 

注册: 2006-12-17 22:16
帖子: 12
地址: xi an
送出感谢: 0 次
接收感谢: 0 次
Qt-4.2.2-X11-openscore终于在ubuntu6.06下完全编译通过,在这论坛学习拉不少东西。望大家再接在励!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-01-11 17:08 

注册: 2006-11-25 0:13
帖子: 24
送出感谢: 1
接收感谢: 0 次
这个怎么装啊,谁能把详细过程贴出来共享啊


页首
 用户资料  
 
7 楼 
 文章标题 : Re: [已解决]装过Qt-X11 4.2.2的帮忙解决 一下这个问题
帖子发表于 : 2011-05-11 11:09 

注册: 2010-10-19 18:42
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get install xorg-dev


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译