[讨论]关于在Gnome下安装QT4

开发基于GTK+或QT的应用程序
头像
wth123456
帖子: 234
注册时间: 2006-12-07 17:32
送出感谢: 0
接收感谢: 0

[讨论]关于在Gnome下安装QT4

#1

帖子 wth123456 » 2007-02-10 18:19

我想在Gnome下面安装QT4。
请问一下我想学习QT编程,在Win下面建立了环境,现在想在Linux下面也建立起来,想问一下能不能再Ubunut的Gnome下面安装QT4,我APT了大部分qt4开头的东西,现在qtdesign等都能运行了,qmake也能运行,但是make的时候还是有问题,我不想安装KDE(硬盘空间小)。有没有人能成功安装的。
glocklee
帖子: 53
注册时间: 2006-10-21 8:05
送出感谢: 0
接收感谢: 0

#2

帖子 glocklee » 2007-02-11 14:42

呵呵

我一直这么干的

先确定自己能编译不需要QT的东西,再弄QT相关的文件,否则make的时候自己都不知道什么地方出错了

直接新立得里面把QT那个包装上了,依赖的包会自动安装

另:QDESIGNER和ASSISTANT要另外安装

KDEVELOP好像不怎么支持QT4(内置DESIGNER都是3的...)

现在用VIM写Q程序...
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 karron » 2007-02-11 16:05

kdevelop3.4据说对qt4支持蛮好.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
glocklee
帖子: 53
注册时间: 2006-10-21 8:05
送出感谢: 0
接收感谢: 0

#4

帖子 glocklee » 2007-02-12 14:57

karron 写了:kdevelop3.4据说对qt4支持蛮好.
的确,能够建造一个工程并且能编译也能调试

但是代码完成的功能就比较糟糕了,没有对Qt3的支持那么好
gothicane
帖子: 157
注册时间: 2006-08-29 10:31
送出感谢: 0
接收感谢: 0

#5

帖子 gothicane » 2007-02-13 22:46

lz把出错信息贴出来啊
头像
wth123456
帖子: 234
注册时间: 2006-12-07 17:32
送出感谢: 0
接收感谢: 0

#6

帖子 wth123456 » 2007-02-18 14:45

gothicane 写了:lz把出错信息贴出来啊
我另外还有一个帖子,里面是出错的问题,帮我看看啊.
viewtopic.php?t=40977&start=0&postdays= ... highlight=
reinhardcao
帖子: 116
注册时间: 2007-02-22 1:15
送出感谢: 0
接收感谢: 0

#7

帖子 reinhardcao » 2007-02-24 22:09

初学QT,教材是QT3的,所以没装QT4,做个标记看看结果先。
头像
wth123456
帖子: 234
注册时间: 2006-12-07 17:32
送出感谢: 0
接收感谢: 0

#8

帖子 wth123456 » 2007-02-25 17:36

reinhardcao 写了:初学QT,教材是QT3的,所以没装QT4,做个标记看看结果先。
我知道你是哪本书,我借到的也是QT3的,但是QT3和QT4相差不少,我既然开始学,还是从QT4开始比较好。
头像
forrid
帖子: 659
注册时间: 2007-04-23 17:40
送出感谢: 0
接收感谢: 0

#9

帖子 forrid » 2007-06-23 22:13

新立得安QT4好使么?

吾生也有涯,而知也无涯,以有涯随无涯,SB啊~~~~~~~~~~
gaozw
帖子: 68
注册时间: 2007-01-02 1:47
来自: 杭州
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 gaozw » 2007-06-27 11:33

我在使用qt4做程序。
安装时将源里的assistant,designer什么的都装上。如果使用kdevelop,那么要将kdevelopvassistant(即kdevelop助手)的qt参考文件的路径都修改一下,因为默认的路径是qt3的。这样在kdevelop中就可以直接使用qt4的帮助文档了。
学习qt4有一本电子书:
<c++ gui programming with qt4>
还不错,不过少了书附带的cd,电子书中的代码多少有点ugly。可以直接从assistant的tutorial and examples看起。
GNOME很漂亮,但KDE很舒适。
Lenovo Sunrise 120 with Kubuntu 7.10
头像
wth123456
帖子: 234
注册时间: 2006-12-07 17:32
送出感谢: 0
接收感谢: 0

#11

帖子 wth123456 » 2007-06-27 12:44

下次再7.04 下面再装一次,不成功就算了。
upl
帖子: 1
注册时间: 2007-07-11 17:20
送出感谢: 0
接收感谢: 0

#12

帖子 upl » 2007-07-11 17:22

Download source code from trolltech.com, compile, install.
头像
china_baby
帖子: 71
注册时间: 2007-06-20 13:17
来自: 上海
送出感谢: 0
接收感谢: 0

#13

帖子 china_baby » 2007-07-13 11:07

有哪位前辈说说具体的在ubuntu6.06下编译Qt3程序的步骤啊?qmake编译hello程序报错:
hello.cpp:4: Unknown test function: int main
hello.cpp:6: Unknown test function: QApplication app
hello.cpp:6: Parse Error ('QApplication app(argc,argv);')
Error processing project file: /home/hello.cpp
是否我,真的一无所有??
alabor
帖子: 113
注册时间: 2007-03-17 13:16
送出感谢: 0
接收感谢: 0

#14

帖子 alabor » 2007-10-30 23:05

gaozw 写了:我在使用qt4做程序。
安装时将源里的assistant,designer什么的都装上。如果使用kdevelop,那么要将kdevelopvassistant(即kdevelop助手)的qt参考文件的路径都修改一下,因为默认的路径是qt3的。这样在kdevelop中就可以直接使用qt4的帮助文档了。
学习qt4有一本电子书:
<c++ gui programming with qt4>
还不错,不过少了书附带的cd,电子书中的代码多少有点ugly。可以直接从assistant的tutorial and examples看起。
我就是不知道该如何修改路径。
本来一个程序,在不使用Kdevelop的情况下是可以顺利编译的,但是一旦使用了IDE就无法编译通过了。我想也应该是因为在创建Project文件时没有指定Qmake的绝对路径和Qt4Desinger的绝对路径的原因。但是我又确实不知道其绝对路径是什么。如果采用查找文件的话,在很多地方都会有Qmake。
cjsh2005
帖子: 11
注册时间: 2009-04-03 20:20
送出感谢: 0
接收感谢: 0

Re: [讨论]关于在Gnome下安装QT4

#15

帖子 cjsh2005 » 2009-10-13 16:40

qmake-qt4和designer-qt4一般被默认安装在/usr/bin/下了,你可以到这里找一下。
回复

回到 “GTK+和QT”