当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装pyqt5.4遇到麻烦,求助
帖子发表于 : 2015-04-29 0:33 

注册: 2014-10-30 9:44
帖子: 11
系统: ubuntu
送出感谢: 1
接收感谢: 1
安装pyqt,需要sip,以前电脑上的sip版本是4.16.3,然后我将sip进行升级。
现在用sip -V 查看sip的版本是4.16.7,但是我在Python3中输出print(sip.SIP_VERSION_STR)时,sip的版本是4.16.3,请问我该怎么做,让Python3调用的sip版本也是4.16.7呢


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装pyqt5.4遇到麻烦,求助
帖子发表于 : 2015-04-29 11:12 

注册: 2014-10-30 9:44
帖子: 11
系统: ubuntu
送出感谢: 1
接收感谢: 1
自己找到了解决方法

sudo -rm /usr/lib/python3/dist-packages/sip*
将之前的sip删掉,重新安装即可


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译