当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 关于4.7和5.2的问题
帖子发表于 : 2015-05-08 15:35 

注册: 2009-02-17 13:48
帖子: 78
送出感谢: 15
接收感谢: 0 次
我在ubuntu14上需要qt4.7的环境 但自动安装creator后发现是5.2的 之前在ubuntu12上安装是4.7的 这个怎么能按上呢 除了creator我都是命令行下载安装的 然后到软件中心安装creator


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 关于4.7和5.2的问题
帖子发表于 : 2015-05-08 17:01 
头像

注册: 2008-09-18 13:11
帖子: 2913
送出感谢: 1
接收感谢: 483
qtcreator用的qt库版本和你开发用的qt库版本可以不一样。
只要你在系统上安装上qt4的库,在qtcreator设置里添加一个qt version/kit就可以用了
sudo apt-get install qt4-default
另外不知道为什么要执着于4.7,就用源里的qt4.8呗,代码迁移成本几乎没有。非要用4.7的话就需要自己编译4.7的库代码了,对新手来说是件很麻烦的事



_________________
评价: 3.7% psv1988
 
页首
 用户资料  
 
3 楼 
 文章标题 : Re: 关于4.7和5.2的问题
帖子发表于 : 2015-05-08 17:43 

注册: 2009-02-17 13:48
帖子: 78
送出感谢: 15
接收感谢: 0 次
4.8可以 我在ubuntu14上装qt 出来的是5.2版本的 原先的代码编译后就不能运行了 所以我想问的是怎么在ubuntu14上装qt4版本


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译