关于4.7和5.2的问题

开发基于GTK+或QT的应用程序
回复
psv1988
帖子: 78
注册时间: 2009-02-17 13:48
送出感谢: 15 次
接收感谢: 0

关于4.7和5.2的问题

#1

帖子 psv1988 » 2015-05-08 15:35

我在ubuntu14上需要qt4.7的环境 但自动安装creator后发现是5.2的 之前在ubuntu12上安装是4.7的 这个怎么能按上呢 除了creator我都是命令行下载安装的 然后到软件中心安装creator
头像
astolia
论坛版主
帖子: 3193
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 538 次

Re: 关于4.7和5.2的问题

#2

帖子 astolia » 2015-05-08 17:01

qtcreator用的qt库版本和你开发用的qt库版本可以不一样。
只要你在系统上安装上qt4的库,在qtcreator设置里添加一个qt version/kit就可以用了
sudo apt-get install qt4-default
另外不知道为什么要执着于4.7,就用源里的qt4.8呗,代码迁移成本几乎没有。非要用4.7的话就需要自己编译4.7的库代码了,对新手来说是件很麻烦的事
这些用户感谢了作者 astolia 于这个帖子:
psv1988 (2015-05-08 17:49)
评价: 3.7%
psv1988
帖子: 78
注册时间: 2009-02-17 13:48
送出感谢: 15 次
接收感谢: 0

Re: 关于4.7和5.2的问题

#3

帖子 psv1988 » 2015-05-08 17:43

4.8可以 我在ubuntu14上装qt 出来的是5.2版本的 原先的代码编译后就不能运行了 所以我想问的是怎么在ubuntu14上装qt4版本
回复

回到 “GTK+和QT”