ubuntu14安装QT5 makeflie报错

开发基于GTK+或QT的应用程序
回复
ubu0452
帖子: 9
注册时间: 2015-08-05 15:25
系统: linux
送出感谢: 1 次
接收感谢: 0

ubuntu14安装QT5 makeflie报错

#1

帖子 ubu0452 » 2015-08-12 12:04

环境ubuntu14.04,QT4升级QT5.2.1
在终端make出错
main.cpp: In function ‘int main(int, char**)’:
main.cpp:6:3: error: ‘QAppliction’ was not declared in this scope
QAppliction app(argc,argv);
^
我的.pro文件
######################################################################
# Automatically generated by qmake (3.0) ?? 8? 11 15:26:21 2015
######################################################################
QT += core gui

greaterThan(QT_MAJOR_VERSION, 4): QT += widgets
TEMPLATE = app
TARGET = project4


# Input
HEADERS += mydialog.h
SOURCES += main.cpp mydialog.cpp
恒河沙数1
帖子: 295
注册时间: 2013-04-27 19:26
系统: ubuntu+win7
送出感谢: 21 次
接收感谢: 9 次

Re: ubuntu14安装QT5 makeflie报错

#2

帖子 恒河沙数1 » 2015-08-12 18:24

东西装全了没?

代码: 全选

$ sudo apt-get install qt5-default
回复

回到 “GTK+和QT”