Linux 无法安装 gnome-core-devel,请教高手

开发基于GTK+或QT的应用程序
回复
kerrysu
帖子: 25
注册时间: 2016-03-29 9:56
系统: ubuntu
送出感谢: 11 次
接收感谢: 0

Linux 无法安装 gnome-core-devel,请教高手

#1

帖子 kerrysu » 2016-03-29 10:09

下列的软件包有不能满足的依赖关系: gnome-devel: 依赖: gnome-core-devel

sudo apt-get install gnome-core-devel
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
gnome-core-devel: 依赖: libgconf2-dev (>= 2.22.0) 但是它将不会被安装
依赖: libatspi-dev (>= 1.22.1) 但是它将不会被安装
依赖: libgnomevfs2-dev (>= 1:2.22.0) 但是它将不会被安装
依赖: libgtk2.0-dev (>= 2.13.0) 但是它将不会被安装
依赖: libbonoboui2-dev (>= 2.22.0) 但是它将不会被安装
依赖: libglade2-dev (>= 1:2.6.2) 但是它将不会被安装
依赖: libgnome2-dev (>= 2.20.1.1) 但是它将不会被安装
依赖: libgnomecanvas2-dev (>= 2.20.1.1) 但是它将不会被安装
依赖: libgnomeui-dev (>= 2.20.1.1) 但是它将不会被安装
依赖: libpango1.0-dev (>= 1.20.3) 但是它将不会被安装
依赖: libeel2-dev (>= 2.20.0) 但是它将不会被安装
依赖: libgnome-desktop-dev (>= 2.22.2) 但是它将不会被安装
依赖: libpanel-applet2-dev (>= 2.20.3) 但是它将不会被安装
依赖: python-gnome2-desktop-dev (>= 2.22.0) 但是它将不会被安装
依赖: libgstreamer-plugins-base0.10-dev (>= 0.10.19) 但是它将不会被安装
依赖: libgstreamer0.10-dev (>= 0.10.19) 但是它将不会被安装
依赖: libgtkhtml3.14-dev (>= 3.18.2) 但是它将不会被安装
依赖: libgtksourceview2.0-dev (>= 2.2.1) 但是它将不会被安装
依赖: libgail-gnome-dev (>= 1.20.0) 但是它将不会被安装
依赖: libgnomekbd-dev (>= 2.22.0) 但是它将不会被安装
依赖: libgnomekbdui-dev (>= 2.22.0) 但是它将不会被安装
依赖: libgnomeprint2.2-dev (>= 2.18.4) 但是它将不会被安装
依赖: libgnomeprintui2.2-dev (>= 2.18.2) 但是它将不会被安装
依赖: libgweather-dev (>= 2.22.2) 但是它将不会被安装
依赖: liboobs-1-dev (>= 2.22.0) 但是它将不会被安装
依赖: librsvg2-dev (>= 2.22.2) 但是它将不会被安装
依赖: libsoup2.4-dev (>= 2.4.1) 但是它将不会被安装
依赖: libwnck-dev (>= 2.22.1) 但是它将不会被安装
依赖: libnautilus-extension-dev (>= 2.20.0) 但是它将不会被安装
依赖: libtotem-plparser-dev (>= 2.22.3) 但是它将不会被安装
依赖: libvte-dev (>= 0.16.13) 但是它将不会被安装
依赖: python-gnome2-dev (>= 2.22.0) 但是它将不会被安装
依赖: python-gtk2-dev (>= 2.12.1) 但是它将不会被安装
E: 无法安装的软件包
头像
vickycq
论坛版主
帖子: 4552
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: Linux 无法安装 gnome-core-devel,请教高手

#2

帖子 vickycq » 2016-03-29 10:24

执行以下命令将结果全部复制贴上来

代码: 全选

cat /etc/issue
cat /etc/os-release
cat /etc/apt/sources.list
cat /etc/apt/sources.list.d/*
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
回复

回到 “GTK+和QT”