[问题]用GTK编程 需要装哪些包阿? 现在连头文件都找不到的

开发基于GTK+或QT的应用程序
回复
zuii
帖子: 65
注册时间: 2007-03-17 10:11
送出感谢: 0
接收感谢: 0
联系:

[问题]用GTK编程 需要装哪些包阿? 现在连头文件都找不到的

#1

帖子 zuii » 2007-09-07 9:52

刚编译一个空白窗口程序

代码: 全选

#include"stdio.h"
#include"gtk/gtk.h"
int main(int argc,char *argv[])
{
   GtkWidget *window;
   gtk_init(&argc,&argv);
   window=gtk_window_new(GTK_WINDOW_TOPLEVEL);
   gtk_widget_show(window);
   gtk_main();
   return 0;
}



编译出错,找不到头文件,还有找不到命令: pkg-config--version:找不到命令

.
麻烦各位了!!
zuii
帖子: 65
注册时间: 2007-03-17 10:11
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 zuii » 2007-09-07 19:14

来人阿~~~~救命
头像
anod221
帖子: 76
注册时间: 2007-04-10 18:36
来自: 西安
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 anod221 » 2007-09-07 20:41

只要安装包gnome-core-devel就好了
头像
chaoyagami
帖子: 207
注册时间: 2007-05-27 21:25
来自: 江西南昌
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 chaoyagami » 2007-09-13 14:23

pkg-config--version这个命令中间有个空格,因该是“pkg-config --version”。编译那个文件只需要在最后面加上"pkg-config --cflags --libs gtk+-2.0"就好了,注意是包括引号的。还有GTK的开发包一定要装上,否则上面都白说。
NetBeans 6.0于12月3日正式发布。
www.netbeans.org
pwsxp
帖子: 76
注册时间: 2007-09-19 22:30
来自: Shanghai
送出感谢: 0
接收感谢: 0

#5

帖子 pwsxp » 2007-10-09 20:15

是上撇吧,好像引号不行
gcc base.c -o base `pkg-config --cflags --libs gtk+-2.0`
回复

回到 “GTK+和QT”