我是一名C程序员,在ubuntu7.10上搭建GTK2.0环境时发生的问题,请教

开发基于GTK+或QT的应用程序
回复
dyron
帖子: 6
注册时间: 2007-11-10 7:16
送出感谢: 0
接收感谢: 0

我是一名C程序员,在ubuntu7.10上搭建GTK2.0环境时发生的问题,请教

#1

帖子 dyron » 2007-11-12 1:12

按照网上说的,需要 gnome-core-devel包,可在安装gnome-core-devel时出现下边情况。


下列的软件包有不能满足的依赖关系:
gnome-core-devel: 依赖: libatspi-dev (>= 1.18.1) 但是它将不会被安装
依赖: libgail-dev (>= 1.18.0) 但是它将不会被安装
依赖: libgtk2.0-dev (>= 2.10.12) 但是它将不会被安装
依赖: libbonoboui2-dev (>= 2.18.0) 但是它将不会被安装
依赖: libglade2-dev (>= 1:2.6.0) 但是它将不会被安装
依赖: libgnomecanvas2-dev (>= 2.14.0) 但是它将不会被安装
依赖: libgnomeui-dev (>= 2.18.1) 但是它将不会被安装
依赖: libpango1.0-dev (>= 1.16.4) 但是它将不会被安装
依赖: libeel2-dev (>= 2.18.0.1) 但是它将不会被安装
依赖: libgnome-desktop-dev (>= 2.18.2) 但是它将不会被安装
依赖: libgnome-menu-dev (>= 2.18.2) 但是它将不会被安装
依赖: libpanel-applet2-dev (>= 2.18.2) 但是它将不会被安装
依赖: libgtkhtml3.14-dev (>= 3.14.2) 但是它将不会被安装
依赖: libgtksourceview-dev (>= 1.8.5) 但是它将不会被安装
依赖: libgail-gnome-dev (>= 1.18.0) 但是它将不会被安装
依赖: libgnomekbd-dev (>= 2.18.2) 但是它将不会被安装
依赖: libgnomekbdui-dev (>= 2.18.2) 但是它将不会被安装
依赖: libgnomeprint2.2-dev (>= 2.18.0) 但是它将不会被安装
依赖: libgnomeprintui2.2-dev (>= 2.18.0) 但是它将不会被安装
依赖: libnautilus-extension-dev (>= 2.16.3) 但是它将不会被安装
依赖: librsvg2-dev (>= 2.16.1) 但是它将不会被安装
依赖: libwnck-dev (>= 2.18.2) 但是它将不会被安装
依赖: libvte-dev (>= 0.16.4) 但是它将不会被安装
E: 无法安装的软件包


最后发现大多数包都依于libpango1.0-dev这个包,但这个包系统里装了1.18.3版本,如果我把这个包删了,就会连删几十个包,不删我的环境做不起来,请教大家有什么方法可以做起来。因为我现在make menuconfig的时候都起不来,内核都编译不了,我是一名内核开发工作者,不编译内核会工作不了的。附:ubuntu7.10比7.04慢多了

下列的软件包有不能满足的依赖关系:
libpango1.0-dev: 依赖: libpango1.0-0 (= 1.18.2-0ubuntu1) 但是 1.18.3-0ubuntu1 正要被安装
vupiggy
帖子: 89
注册时间: 2006-03-19 18:25
来自: FZ->TJ->PEK->AMS->MTL
送出感谢: 0
接收感谢: 0

#2

帖子 vupiggy » 2007-11-12 1:46

? 开发内核的会搞不定这事儿?

make menuconfig和gtk,gnome一点关系都没有啊,它依赖的是ncurses。
dyron
帖子: 6
注册时间: 2007-11-10 7:16
送出感谢: 0
接收感谢: 0

#3

帖子 dyron » 2007-11-12 2:03

朋友,你有什么方法把这个问题解决么?告知一下,多谢
vupiggy
帖子: 89
注册时间: 2006-03-19 18:25
来自: FZ->TJ->PEK->AMS->MTL
送出感谢: 0
接收感谢: 0

#4

帖子 vupiggy » 2007-11-12 7:33

第一:我们不是朋友

上面这句属于从古大师书里学来用于臭贫的,要是实在太介意就忽略掉;)

第二:我不知道你要解决什么,你是想问怎么装上gnome-core-devel这个包呢还是怎么让make menuconfig通过?如果是前者,对不起,上其它版转悠转悠抓住一个编译狂准能问出点什么来。如果是后者呢,只要装一个包:libncurses5-dev 就可以了,当然apt会装其它依赖的包。

第三:本来不该告诉你的,kernel hacking,hacking hacking,就是个痛苦的摸索过程,这个最最简单的问题搞不定,hmm...... :(

第四:告诉你要编译内核必须要装gnome-core-devel包的人,过去踹他两脚,如果是个女的就算了。
dyron
帖子: 6
注册时间: 2007-11-10 7:16
送出感谢: 0
接收感谢: 0

#5

帖子 dyron » 2007-11-12 13:04

:lol: :lol: :lol: Thank you!
头像
madoldman
帖子: 599
注册时间: 2006-02-27 20:19
来自: works system
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 madoldman » 2007-11-12 15:17

哈哈哈,说的太好了
其实编译内核干吗一定要用menuconfig阿,config也不错阿
实在不行就直接改.config文件也不费劲阿,唉,不知道楼主到底要干什么,哈哈哈
很赞最后一句“告诉你要编译内核必须要装gnome-core-devel包的人,过去踹他两脚,如果是个女的就算了”
vupiggy 写了:第一:我们不是朋友

上面这句属于从古大师书里学来用于臭贫的,要是实在太介意就忽略掉;)

第二:我不知道你要解决什么,你是想问怎么装上gnome-core-devel这个包呢还是怎么让make menuconfig通过?如果是前者,对不起,上其它版转悠转悠抓住一个编译狂准能问出点什么来。如果是后者呢,只要装一个包:libncurses5-dev 就可以了,当然apt会装其它依赖的包。

第三:本来不该告诉你的,kernel hacking,hacking hacking,就是个痛苦的摸索过程,这个最最简单的问题搞不定,hmm...... :(

第四:告诉你要编译内核必须要装gnome-core-devel包的人,过去踹他两脚,如果是个女的就算了。
东西路,南北走
十字路口人咬狗
拿起狗来打砖头
砖头咬了狗一口
图片
szandrew
帖子: 28
注册时间: 2007-10-15 11:01
送出感谢: 0
接收感谢: 0

#7

帖子 szandrew » 2007-11-22 10:23

我作为旁观者,觉得还是针对提问者的问题,给出答案比较的好,或者告诉提问者如何去解决答案
当然再给出答案的同时再给出些鼓励的话就更好了。
恕我直言,后面的回答,我个人感觉不太满意。
顺便说一句,我也有这个问题,但起因不是楼主的编译kernel。
头像
madoldman
帖子: 599
注册时间: 2006-02-27 20:19
来自: works system
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 madoldman » 2007-11-22 11:35

看看你的源,是不是把源给弄错了?
如果不是源错了,应该没有这些依赖问题吧?或者你是不是把源改成其他的版本装过什么东西把依赖弄乱了?
把源改好后dist-upgrade一下看看吧
人家楼主就是要编译kernel,gnome-core-devel本来就不需要,你满意不满意有什么关系吗?楼主好像很满意呢
东西路,南北走
十字路口人咬狗
拿起狗来打砖头
砖头咬了狗一口
图片
lingyunyuan
帖子: 47
注册时间: 2007-05-16 18:27
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 lingyunyuan » 2007-11-25 22:47

vupiggy 写了:第一:我们不是朋友

上面这句属于从古大师书里学来用于臭贫的,要是实在太介意就忽略掉;)

第二:我不知道你要解决什么,你是想问怎么装上gnome-core-devel这个包呢还是怎么让make menuconfig通过?如果是前者,对不起,上其它版转悠转悠抓住一个编译狂准能问出点什么来。如果是后者呢,只要装一个包:libncurses5-dev 就可以了,当然apt会装其它依赖的包。

第三:本来不该告诉你的,kernel hacking,hacking hacking,就是个痛苦的摸索过程,这个最最简单的问题搞不定,hmm...... :(

第四:告诉你要编译内核必须要装gnome-core-devel包的人,过去踹他两脚,如果是个女的就算了。
P~P
头像
stlxv
论坛版主
帖子: 8273
注册时间: 2006-05-03 0:39
来自: المريخ
送出感谢: 0
接收感谢: 1 次

#10

帖子 stlxv » 2007-11-25 22:50

请LZ告诉我你是怎么安装的
PHP是最好的语言!不服来战!
ktboy
帖子: 7
注册时间: 2008-03-14 8:23
送出感谢: 0
接收感谢: 0

#11

帖子 ktboy » 2008-03-14 11:39

真不理解上边那个装相的
引用回复
第一:我们不是朋友

上面这句属于从古大师书里学来用于臭贫的,要是实在太介意就忽略掉Wink

第二:我不知道你要解决什么,你是想问怎么装上gnome-core-devel这个包呢还是怎么让make menuconfig通过?如果是前者,对不起,上其它版转悠转悠抓住一个编译狂准能问出点什么来。如果是后者呢,只要装一个包:libncurses5 -dev 就可以了,当然apt会装其它依赖的包。

第三:本来不该告诉你的,kernel hacking,hacking hacking,就是个痛苦的摸索过程,这个最最简单的问题搞不定,hmm...... Sad

第四:告诉你要编译内核必须要装gnome-core-devel包的人,过去踹他两脚,如果是个女的就算了。

像回事的说了一堆废话 没有一句有用的
兄弟 你直接更新那个包就行了 不用删了
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#12

帖子 BigSnake.NET » 2008-03-15 11:49

1. 确保你的源版本与系统版本对应
2. 使用 aptitude 代替 apt-get
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
回复

回到 “GTK+和QT”