[2010.02.20更新][汇总]构建C/C++开发环境(包括gtk/qt等开发库)(适合ubuntu9.10)

开发基于GTK+或QT的应用程序
回复
ck416787107
帖子: 7
注册时间: 2010-03-22 13:22
送出感谢: 0
接收感谢: 0

Re: [2010.02.20更新][汇总]构建C/C++开发环境(包括gtk/qt等开发库)(适合ubuntu9.10

#121

帖子 ck416787107 » 2010-08-04 7:52

谢谢楼主了 :em09
头像
whichbest
帖子: 19
注册时间: 2008-11-23 16:04
送出感谢: 0
接收感谢: 0

Re: [2010.02.20更新][汇总]构建C/C++开发环境(包括gtk/qt等开发库)(适合ubuntu9.10

#122

帖子 whichbest » 2010-08-05 20:18

对于初学者非常有用,非常不错的教程
AMD 4400+
AMD R770+SB600/ONDA A770S
ATI HD2600PRO/DATALAND
头像
帅帅的小肥
帖子: 111
注册时间: 2010-05-02 23:58
送出感谢: 0
接收感谢: 0
联系:

Re: [2010.02.20更新][汇总]构建C/C++开发环境(包括gtk/qt等开发库)(适合ubuntu9.10

#123

帖子 帅帅的小肥 » 2010-10-26 8:44

mark
我的个人博客http://lovexx.org
leixinren
帖子: 96
注册时间: 2006-03-14 21:01
送出感谢: 0
接收感谢: 0

Re: [2010.02.20更新][汇总]构建C/C++开发环境(包括gtk/qt等开发库)(适合ubuntu9.10

#124

帖子 leixinren » 2011-03-16 21:27

不错,有心人。。。谢谢分享。。。
jay1221
帖子: 1
注册时间: 2011-03-26 10:34
送出感谢: 0
接收感谢: 0

Re: [2010.02.20更新][汇总]构建C/C++开发环境(包括gtk/qt等开发库)(适合ubuntu9.10

#125

帖子 jay1221 » 2011-03-27 16:28

哪里有软件下载啊?
头像
idealcat
帖子: 4
注册时间: 2011-04-17 16:03
送出感谢: 0
接收感谢: 0

Re: [2010.02.20更新][汇总]构建C/C++开发环境(包括gtk/qt等开发库)(适合ubuntu9.10

#126

帖子 idealcat » 2011-05-06 11:33

请问一下 我打算学习QT
qt4-dev-tools
qt4-doc
qt4-doc-html
等都有了
我用Eclipse做开发
照着书写了一个窗体 结果提示“binary not found”
请问是怎么回事啊
RaebLoocMai
帖子: 81
注册时间: 2011-06-09 22:17
送出感谢: 0
接收感谢: 0

Re: [2010.02.20更新][汇总]构建C/C++开发环境(包括gtk/qt等开发库)(适合ubuntu9.10

#127

帖子 RaebLoocMai » 2011-06-09 23:14

收藏了 好资料太多看不过来了都
cart
帖子: 2
注册时间: 2011-09-22 11:38
送出感谢: 0
接收感谢: 0

Re: [2010.02.20更新][汇总]构建C/C++开发环境(包括gtk/qt等开发库)(适合ubuntu9.10

#128

帖子 cart » 2011-09-23 16:42

Thx !

谢谢楼主了!收藏了 :em11
genime
帖子: 155
注册时间: 2010-05-29 0:48
送出感谢: 2 次
接收感谢: 1 次

Re: [2010.02.20更新][汇总]构建C/C++开发环境(包括gtk/qt等开发库)(适合ubuntu9.10

#129

帖子 genime » 2012-03-25 17:06

楼主咋装不上呢?

在安装libgtk2.0-dev时提示:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgtk2.0-dev: Depends: libgtk2.0-0 (= 2.20.1-0ubuntu2) but 2.20.1-0ubuntu2.1 is to be installed
E: Broken packages

安装gnome-core-devel提示:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gnome-core-devel: Depends: libgconf2-dev (>= 2.28) but it is not going to be installed
Depends: libatspi-dev (>= 1.28) but it is not going to be installed
Depends: libgnomevfs2-dev (>= 1:2.24) but it is not going to be installed
Depends: libgtk2.0-dev (>= 2.18) but it is not going to be installed
Depends: libbonoboui2-dev (>= 2.24) but it is not going to be installed
Depends: libglade2-dev (>= 1:2.6.4) but it is not going to be installed
Depends: libgnome2-dev (>= 2.28) but it is not going to be installed
Depends: libgnomecanvas2-dev (>= 2.26) but it is not going to be installed
Depends: libgnomeui-dev (>= 2.24) but it is not going to be installed
Depends: libgnome-desktop-dev (>= 2.28) but it is not going to be installed
Depends: libpanel-applet2-dev (>= 2.28) but it is not going to be installed
Depends: python-gnome2-desktop-dev (>= 2.28) but it is not going to be installed
Depends: libgtkhtml3.14-dev (>= 3.28) but it is not going to be installed
Depends: libgtksourceview2.0-dev (>= 2.8) but it is not going to be installed
Depends: libgail-gnome-dev (>= 1.20.1) but it is not going to be installed
Depends: libgnomekbd-dev (>= 2.28) but it is not going to be installed
Depends: libgweather-dev (>= 2.28) but it is not going to be installed
Depends: liboobs-1-dev (>= 2.22.2) but it is not going to be installed
Depends: librsvg2-dev (>= 2.26) but it is not going to be installed
Depends: libsoup2.4-dev (>= 2.28) but it is not going to be installed
Depends: libwnck-dev (>= 2.28) but it is not going to be installed
Depends: libnautilus-extension-dev (>= 2.28) but it is not going to be installed
Depends: libvte-dev (>= 0.22) but it is not going to be installed
Depends: python-gnome2-dev (>= 2.28) but it is not going to be installed
Depends: python-gtk2-dev (>= 2.16) but it is not going to be installed
E: Broken packages
:em20 :em20 这该怎么搞啊?谢谢
sherryququ
帖子: 8
注册时间: 2012-07-17 18:54
送出感谢: 0
接收感谢: 0

Re: [2010.02.20更新][汇总]构建C/C++开发环境(包括gtk/qt等开发库)(适合ubuntu9.10

#130

帖子 sherryququ » 2012-07-27 15:29

:em01 自学了一阵,折腾了各种,现在终于明白楼主这个帖子有多么好了
头像
haoyihuan
帖子: 271
注册时间: 2009-06-11 13:37
送出感谢: 1 次
接收感谢: 0

Re: [2010.02.20更新][汇总]构建C/C++开发环境(包括gtk/qt等开发库)(适合ubuntu9.10

#131

帖子 haoyihuan » 2013-12-14 15:08

想写个在linux和windows下都能够编译的c代码,windows下用什么编辑器、编译器?
跑debian应该是有点搞头的吧。
回复

回到 “GTK+和QT”