我并不想在根分区用 relatime 挂载

最大的社区版本,Ubuntu的发源地
回复
头像
自由建客
论坛版主
帖子: 13427
注册时间: 2008-07-30 23:21
系统: Debian stable AMD64
来自: freebuilder@yeah.net
送出感谢: 12 次
接收感谢: 112 次
联系:

我并不想在根分区用 relatime 挂载

#1

帖子 自由建客 » 2010-10-03 22:01

linuxsir 太冷清了,这边来!

代码: 全选

>0< ~# grep '\/dev\/sda2' /proc/mounts
/dev/sda2 / ext4 rw,relatime,errors=remount-ro,commit=360,barrier=1,data=ordered 0 0

>0< ~# grep '\/dev\/sda2' /etc/fstab 
/dev/sda2	/	ext4	errors=remount-ro,commit=360	0 1

>0< ~# tune2fs -l /dev/sda2 | grep 'Default mount options'
Default mount options:    (none)
我并没有指定 relatime ,为何实际挂载却有呢?
头像
cnkilior
论坛版主
帖子: 4979
注册时间: 2007-08-05 17:40
送出感谢: 0
接收感谢: 5 次

Re: 我并不想在根分区用 relatime 挂载

#2

帖子 cnkilior » 2010-10-03 22:07

noatime和relatime必须指定一个吧。
头像
cnkilior
论坛版主
帖子: 4979
注册时间: 2007-08-05 17:40
送出感谢: 0
接收感谢: 5 次

Re: 我并不想在根分区用 relatime 挂载

#3

帖子 cnkilior » 2010-10-03 22:19

刚才我看到了laptop-mode.conf中有句USE_RELATIME=1
头像
自由建客
论坛版主
帖子: 13427
注册时间: 2008-07-30 23:21
系统: Debian stable AMD64
来自: freebuilder@yeah.net
送出感谢: 12 次
接收感谢: 112 次
联系:

Re: 我并不想在根分区用 relatime 挂载

#4

帖子 自由建客 » 2010-10-04 0:00

我已经不用 laptop-mode-tools 了 viewtopic.php?f=126&t=295052

内核不知从何时起默认 relatime 了,要想禁止必须指定 strictatime 。
回复

回到 “Debian发行版”