包损坏修复问题求助

最大的社区版本,Ubuntu的发源地
回复
头像
alonely
帖子: 27
注册时间: 2009-11-07 13:59
送出感谢: 0
接收感谢: 0

包损坏修复问题求助

#1

帖子 alonely » 2010-11-03 14:50

我用的是DEBIAN5.06 AMD64稳定版.昨天安装了一个DEB包,强行安装一个新版本的包上去后导致该文件的损坏.使用sudo apt-get install -f修复需要删除200多个包,我没敢删除.使用新立得修复也是一样的情况.所以不知道该如何修复那个损坏的包.因为一修复就得删除绝大多数的包.和重装没区别了.
请问该怎么解决这样的问题呢?
PS:我有备份,但是就是想弄明白这个问题该如何解决.不然以后遇到还是无法解决只能还原.
头像
nmsfan
帖子: 18958
注册时间: 2009-10-16 22:46
来自: finland
送出感谢: 16 次
接收感谢: 36 次

Re: 包损坏修复问题求助

#2

帖子 nmsfan » 2010-11-03 16:44

删除两百多个包岂不是把图形环境都删了,要不得,要不得
>>>>推Ubuntu 桌面培训~~<<<<
>>>>想加入/了解gimp汉化吗,点我吧~<<<<
——————————————————————
不推荐wubi,也不推荐你给别人推荐wubi…………
随心而为的感觉真好……
强推mayhem!!
强推ensiferum
头像
alonely
帖子: 27
注册时间: 2009-11-07 13:59
送出感谢: 0
接收感谢: 0

Re: 包损坏修复问题求助

#3

帖子 alonely » 2010-11-03 17:27

看了删除文件,系统里面文件多数都会被删除.其中就包括图形界面.真是郁闷了. :em20
头像
daf3707
论坛版主
帖子: 12673
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 49 次
接收感谢: 85 次

Re: 包损坏修复问题求助

#4

帖子 daf3707 » 2010-11-03 17:37

把强行安装的包强行删除啊
回复

回到 “Debian发行版”