设定打开使用的程序,不起作用!

最大的社区版本,Ubuntu的发源地
回复
头像
xw712
帖子: 487
注册时间: 2009-04-25 9:26
送出感谢: 0
接收感谢: 3 次

设定打开使用的程序,不起作用!

#1

帖子 xw712 » 2011-01-24 22:13

debian 6

电影选定smplayer
PDF选定foxit

每次都记住了打开的程序,但是没有用,还是会使用系统默认,我设定的不起作用。
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

Re: 设定打开使用的程序,不起作用!

#2

帖子 luojie-dune » 2011-01-24 22:47

不信.
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
头像
nmsfan
帖子: 18958
注册时间: 2009-10-16 22:46
来自: finland
送出感谢: 16 次
接收感谢: 36 次

Re: 设定打开使用的程序,不起作用!

#3

帖子 nmsfan » 2011-01-25 10:24

既然不用就可以把默认的那玩意卸掉啊,再试试smplayer看看行不行~~~~~~~~~~~
>>>>推Ubuntu 桌面培训~~<<<<
>>>>想加入/了解gimp汉化吗,点我吧~<<<<
——————————————————————
不推荐wubi,也不推荐你给别人推荐wubi…………
随心而为的感觉真好……
强推mayhem!!
强推ensiferum
头像
xw712
帖子: 487
注册时间: 2009-04-25 9:26
送出感谢: 0
接收感谢: 3 次

Re: 设定打开使用的程序,不起作用!

#4

帖子 xw712 » 2011-01-25 18:18

不敢随便删除,上次删了evolution,净出妖蛾子!
只是不懂,为什么totem,evolution,evince不能随便删除,它们只是普通的应用软件而已,但和gnome结合很紧密,不理解为什么这么干
头像
supercatexpert
帖子: 403
注册时间: 2010-01-17 15:39
系统: Debian Wheezy AMD64
送出感谢: 0
接收感谢: 6 次
联系:

Re: 设定打开使用的程序,不起作用!

#5

帖子 supercatexpert » 2011-01-25 18:27

如果不想要Totem, Evolution之类的,不是不可以,只是你需要自己安装GNOME的组件。因为GNOME本身某些功能需要这些软件,所以这些软件不能随便删掉。
这些软件没必要删掉,如果你的硬盘不是小得不行。

设置默认打开的程序应该在文件的属性内设置,设置关联该文件类型的打开方式。
OS: Debian Wheezy (Testing) for AMD64~~~
Mobile Phone: Nokia N900, OS: Maemo 5.0 (Base on Debian)~~~
本人的项目: RhythmCat(Linux下的音乐播放器.....支持歌词等功能...)
http://code.google.com/p/rhythmcat

RhythmCat 2进行中 (https://github.com/supercatexpert/RhythmCat2/)
头像
xw712
帖子: 487
注册时间: 2009-04-25 9:26
送出感谢: 0
接收感谢: 3 次

Re: 设定打开使用的程序,不起作用!

#6

帖子 xw712 » 2011-01-25 20:36

感谢!
在文件属性里设定,现在好了!
头像
xw712
帖子: 487
注册时间: 2009-04-25 9:26
送出感谢: 0
接收感谢: 3 次

Re: 设定打开使用的程序,不起作用!

#7

帖子 xw712 » 2011-01-25 20:40

如果不想要Totem, Evolution之类的,不是不可以,只是你需要自己安装GNOME的组件。因为GNOME本身某些功能需要这些软件,所以这些软件不能随便删掉。

你的意思是:一个完整的gnome是可以不要这些的,但是,系统默认的并不完整,需要补组件,才能删了它。
头像
supercatexpert
帖子: 403
注册时间: 2010-01-17 15:39
系统: Debian Wheezy AMD64
送出感谢: 0
接收感谢: 6 次
联系:

Re: 设定打开使用的程序,不起作用!

#8

帖子 supercatexpert » 2011-01-25 23:23

gnome-core和gnome-desktop-environment都是虚包,功能是帮助你自动选定GNOME环境需要的包,但是也会携带上那些软件。如果卸载者2个虚包,那么便自动卸载这些虚包所安装的所有包,整个GNOME环境都会被卸载(除非你手动安装了这些包,手动安装的包是不会被卸载的)

你可以看看gnome-core依赖的包,然后手动安装自己想要的包。
OS: Debian Wheezy (Testing) for AMD64~~~
Mobile Phone: Nokia N900, OS: Maemo 5.0 (Base on Debian)~~~
本人的项目: RhythmCat(Linux下的音乐播放器.....支持歌词等功能...)
http://code.google.com/p/rhythmcat

RhythmCat 2进行中 (https://github.com/supercatexpert/RhythmCat2/)
头像
xw712
帖子: 487
注册时间: 2009-04-25 9:26
送出感谢: 0
接收感谢: 3 次

Re: 设定打开使用的程序,不起作用!

#9

帖子 xw712 » 2011-01-28 19:19

supercatexpert 写了:gnome-core和gnome-desktop-environment都是虚包,功能是帮助你自动选定GNOME环境需要的包,但是也会携带上那些软件。如果卸载者2个虚包,那么便自动卸载这些虚包所安装的所有包,整个GNOME环境都会被卸载(除非你手动安装了这些包,手动安装的包是不会被卸载的)

你可以看看gnome-core依赖的包,然后手动安装自己想要的包。
有点理解了,谢谢!
回复

回到 “Debian发行版”