当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : debian新手请教入手问题
帖子发表于 : 2011-06-08 9:57 
头像

注册: 2011-01-05 14:21
帖子: 628
送出感谢: 0 次
接收感谢: 0 次
之前用的ubuntu, 现在决定开始学debian了。 安装了系统之后遇到各种问题


1.无线网不能上. iwconfig能看到无线网卡,ifconfig wlan0 up不能启动。 错误提示是:SIOCSIFFLAGS: No such file or directory

2.fcitx不能鼠标跟随。安装力scim没有任何反应。

3.deb包不会安装。dpkg -i google-chrome-stable_current_amd64.deb总有有依赖问题。 试用apt-get install ***也会有依赖问题,但是我想把依赖的包逐个安装,还是有依赖问题,是一个死循环。 用aptitude install synaptic, 提示如下:

代码:
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libgnomevfs2-extra [Not Installed]                 
2)     libkrb53 [Not Installed]                           
3)     synaptic [Not Installed]                           

     Leave the following dependencies unresolved:         
4)     libgnome2-vfs-perl recommends libgnomevfs2-extra   


Accept this solution? [Y/n/q/?]

然后选择y,还是什么都不安装


_________________
O(∩_∩)O


页首
 用户资料  
 
2 楼 
 文章标题 : Re: debian新手请教入手问题
帖子发表于 : 2011-06-08 10:25 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
1.不用,不清楚
2.是的,很久了,不过我习惯了
3.试试sudo apt-get install -f?更新你的源,还有你的源全不全?


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
3 楼 
 文章标题 : Re: debian新手请教入手问题
帖子发表于 : 2011-06-08 11:01 
头像

注册: 2011-01-05 14:21
帖子: 628
送出感谢: 0 次
接收感谢: 0 次
leeaman 写道:
1.不用,不清楚
2.是的,很久了,不过我习惯了
3.试试sudo apt-get install -f?更新你的源,还有你的源全不全?


-f之后是不是强制安装不管依赖关系,那样子安全吗? 我就用了163和官方的两个源


_________________
O(∩_∩)O


页首
 用户资料  
 
4 楼 
 文章标题 : Re: debian新手请教入手问题
帖子发表于 : 2011-06-08 11:04 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
先试试那个命令,然后贴你的源出来看看


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
5 楼 
 文章标题 : Re: debian新手请教入手问题
帖子发表于 : 2011-06-08 11:15 
头像

注册: 2011-01-05 14:21
帖子: 628
送出感谢: 0 次
接收感谢: 0 次
leeaman 写道:
先试试那个命令,然后贴你的源出来看看

-f之后还是不可以。
代码:
root@debian:/home/frank# apt-get install -f synaptic
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 synaptic : Depends: libapt-inst-libc6.7-6-1.1
            Depends: libapt-pkg-libc6.7-6-4.6
E: Broken packages


我的源:

代码:
#

# deb cdrom:[Debian GNU/Linux 6.0.1a _Squeeze_ - Official amd64 CD Binary-1 20110322-16:05]/ squeeze main

#deb cdrom:[Debian GNU/Linux 6.0.1a _Squeeze_ - Official amd64 CD Binary-1 20110322-16:05]/ squeeze main

# Line commented out by installer because it failed to verify:
#deb http://security.debian.org/ squeeze/updates main
# Line commented out by installer because it failed to verify:
#deb-src http://security.debian.org/ squeeze/updates main

# squeeze-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
# deb ftp:://debian.linux.org.tw/pub/apt unstable main
# deb ftp:://ftp.hk.debian.org/unoffical/dlot-apt unstable main

deb http://mirrors.163.com/debian/ lenny main contrib non-free
deb-src http://mirrors.163.com/debian lenny main contrib non-free

deb http://ftp.debian.org/debian/ squeeze-updates main
deb-src http://ftp.debian.org/debian/ squeeze-updates main


_________________
O(∩_∩)O


页首
 用户资料  
 
6 楼 
 文章标题 : Re: debian新手请教入手问题
帖子发表于 : 2011-06-08 11:19 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
代码:
deb http://http.us.debian.org/debian/ sid contrib non-free main

我的就一行搞定....


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
7 楼 
 文章标题 : Re: debian新手请教入手问题
帖子发表于 : 2011-06-08 11:21 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
你的源不对...leny改成 squeeze应该就好了


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
8 楼 
 文章标题 : Re: debian新手请教入手问题
帖子发表于 : 2011-06-08 12:45 
头像

注册: 2011-01-05 14:21
帖子: 628
送出感谢: 0 次
接收感谢: 0 次
leeaman 写道:
你的源不对...leny改成 squeeze应该就好了

果然可以了。就是速度太慢了


_________________
O(∩_∩)O


页首
 用户资料  
 
9 楼 
 文章标题 : Re: debian新手请教入手问题
帖子发表于 : 2011-06-09 2:02 

注册: 2009-10-03 23:31
帖子: 3030
送出感谢: 1
接收感谢: 14
换用USTC的源试试。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: debian新手请教入手问题
帖子发表于 : 2011-06-09 2:53 
头像

注册: 2009-10-16 22:46
帖子: 18958
地址: finland
送出感谢: 28
接收感谢: 48
-f不是指强制,是指修复~


_________________
>>>>推Ubuntu 桌面培训~~<<<<
>>>>想加入/了解gimp汉化吗,点我吧~<<<<
——————————————————————
不推荐wubi,也不推荐你给别人推荐wubi…………
随心而为的感觉真好……
强推mayhem!!
强推ensiferum


页首
 用户资料  
 
11 楼 
 文章标题 : Re: debian新手请教入手问题
帖子发表于 : 2011-06-25 0:52 

注册: 2006-04-24 0:36
帖子: 69
送出感谢: 7
接收感谢: 1
推荐 ftp.tw.debian.org 源,
北京网通很快,2M可以跑到300多

debian下没用过无线网卡,
不过你看看 /etc/network/interfaces 里面有没有定义wlan0的部分


_________________
ONEDUST - 浮塵草堂


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译