还是firefox声音问题

最大的社区版本,Ubuntu的发源地
回复
头像
kkkmaokkk
帖子: 480
注册时间: 2010-01-01 7:05
送出感谢: 1 次
接收感谢: 0

还是firefox声音问题

#1

帖子 kkkmaokkk » 2013-02-02 11:30

这次换了kde结果出现

代码: 全选

ALSA lib dlmisc.c:254:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_pcm_alsa.so
这东西到哪边去搞啊?
本来是装了pulseaudio的,但是这东西一直爆音。。。无奈之下只能删之,现在就alsa,amarok和系统有声音就是这个firefix,,,
麻烦各位多指点
0.0
头像
mraandtux
论坛版主
帖子: 5087
注册时间: 2009-12-12 19:29
系统: Ubuntu + Windows 10
来自: 随便一个地方
送出感谢: 0
接收感谢: 158 次
联系:

Re: 还是firefox声音问题

#2

帖子 mraandtux » 2013-02-02 13:44

头像
kkkmaokkk
帖子: 480
注册时间: 2010-01-01 7:05
送出感谢: 1 次
接收感谢: 0

Re: 还是firefox声音问题

#3

帖子 kkkmaokkk » 2013-02-02 23:03

mraandtux 写了:看下面的链接:
http://forums.opensuse.org/english/get- ... brary.html
我也重新安装alsa的有关的东西,但是依旧没有这个东西
麻烦各位多指点
0.0
头像
kkkmaokkk
帖子: 480
注册时间: 2010-01-01 7:05
送出感谢: 1 次
接收感谢: 0

Re: 还是firefox声音问题

#4

帖子 kkkmaokkk » 2013-02-03 14:49

testing的东西果然没stable的保守,换回stable就没问题 :em06
statble下也根本没这个so :em20
麻烦各位多指点
0.0
头像
自由建客
论坛版主
帖子: 13436
注册时间: 2008-07-30 23:21
系统: Debian stable AMD64
来自: freebuilder@yeah.net
送出感谢: 12 次
接收感谢: 112 次
联系:

Re: 还是firefox声音问题

#5

帖子 自由建客 » 2013-02-03 17:26

不理解,firefox 声音?谁发声?
头像
kkkmaokkk
帖子: 480
注册时间: 2010-01-01 7:05
送出感谢: 1 次
接收感谢: 0

Re: 还是firefox声音问题

#6

帖子 kkkmaokkk » 2013-02-05 20:45

自由建客 写了:不理解,firefox 声音?谁发声?
flash~
麻烦各位多指点
0.0
头像
自由建客
论坛版主
帖子: 13436
注册时间: 2008-07-30 23:21
系统: Debian stable AMD64
来自: freebuilder@yeah.net
送出感谢: 12 次
接收感谢: 112 次
联系:

Re: 还是firefox声音问题

#7

帖子 自由建客 » 2013-02-06 0:29

kkkmaokkk, 我直接用 alsa,正常。你装了 alsa-base 没?
头像
kkkmaokkk
帖子: 480
注册时间: 2010-01-01 7:05
送出感谢: 1 次
接收感谢: 0

Re: 还是firefox声音问题

#8

帖子 kkkmaokkk » 2013-02-07 13:04

自由建客 写了:kkkmaokkk, 我直接用 alsa,正常。你装了 alsa-base 没?
我也没说清楚,我安转的是wheezy,而且是联网安装的所有它把所有需要的组件都安装上了,包括pulseaudio,但是所有的声音都有爆音现象。于是我卸载了pulseaudio,准备单单用alsa,爆音的确明显减缓,但是flash从此就哑了。而后我安装回pulseaudio也没用,提示1l那个。

我也把alsa-base(默认就安装了,我也重新安装) alsa-oss都装了,但是就只有flash没声音。还是1l那个问题。

代码: 全选

root@Squeeze:/home/cat# dpkg --get-selections | grep pulse
gstreamer0.10-pulseaudio                        install
libpulse-browse0                                install
libpulse-mainloop-glib0                         install
libpulse0                                       install
pulseaudio                                      install
pulseaudio-esound-compat                        install
pulseaudio-module-x11                           install
pulseaudio-utils                                install
root@Squeeze:/home/cat# dpkg --get-selections | grep alsa
alsa-base                                       install
alsa-utils                                      install
libsdl1.2debian-alsa                            install
这个是squeeze的包安装情况,这个2个默认都是安装的,因为没出问题所有我也没去动,话说现在的音质很不错,丝毫无杂音和爆音。
麻烦各位多指点
0.0
头像
自由建客
论坛版主
帖子: 13436
注册时间: 2008-07-30 23:21
系统: Debian stable AMD64
来自: freebuilder@yeah.net
送出感谢: 12 次
接收感谢: 112 次
联系:

Re: 还是firefox声音问题

#9

帖子 自由建客 » 2013-02-07 22:17

把 ~/.mzilla 删掉重来。
头像
kkkmaokkk
帖子: 480
注册时间: 2010-01-01 7:05
送出感谢: 1 次
接收感谢: 0

Re: 还是firefox声音问题

#10

帖子 kkkmaokkk » 2013-02-07 23:33

没基会了,wheezy已换squeeze,,

Sent from my WT19i using Tapatalk 2
麻烦各位多指点
0.0
回复

回到 “Debian发行版”