当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [找到1个解决方案]Debian安装包时提示"下列XX包将安装"时如何只选择部分包进行安装?
帖子发表于 : 2017-04-27 18:26 

注册: 2013-05-26 6:58
帖子: 2128
系统: Debian 9
送出感谢: 874
接收感谢: 29
Debian安装包时提示"下列XX包将安装"时如何只选择部分包进行安装?
我指的是Recommends不是Depends
我并不想手动选择所有Recommends,只是有个别几个包我看出来不需要,希望别装
例如:我只想安装intel的显卡驱动
代码:
Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
  adwaita-icon-theme at-spi2-core dbus dconf-gsettings-backend dconf-service
  desktop-base fontconfig fontconfig-config fonts-dejavu-core glib-networking
  glib-networking-common glib-networking-services gnome-accessibility-themes
  gnome-themes-standard gnome-themes-standard-data gsettings-desktop-schemas
  gtk-update-icon-cache gtk2-engines-pixbuf hicolor-icon-theme
  keyboard-configuration krb5-locales libatk-bridge2.0-0 libatk1.0-0
  libatk1.0-data libatspi2.0-0 libavahi-client3 libavahi-common-data
  libavahi-common3 libcairo-gobject2 libcairo2 libcolord2 libcroco3 libcups2
  libdatrie1 libdbus-1-3 libdconf1 libdrm-amdgpu1 libdrm-intel1
  libdrm-nouveau2 libdrm-radeon1 libdrm2 libedit2 libegl1-mesa libepoxy0
  libevdev2 libexpat1 libfontconfig1 libfontenc1 libfreetype6 libgail-common
  libgail18 libgbm1 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgl1-mesa-dri
  libgl1-mesa-glx libglapi-mesa libglib2.0-0 libglib2.0-data libgraphite2-3
  libgssapi-krb5-2 libgtk-3-0 libgtk-3-bin libgtk-3-common libgtk2.0-0
  libgtk2.0-bin libgtk2.0-common libgudev-1.0-0 libharfbuzz0b libice6 libicu57
  libinput-bin libinput10 libjbig0 libjpeg62-turbo libjson-glib-1.0-0
  libjson-glib-1.0-common libk5crypto3 libkeyutils1 libkrb5-3 libkrb5support0
  liblcms2-2 liblightdm-gobject-1-0 libllvm3.9 libmtdev1 libpam-systemd
  libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpciaccess0
  libpixman-1-0 libpng16-16 libpolkit-agent-1-0 libpolkit-backend-1-0
  libpolkit-gobject-1-0 libproxy1v5 librest-0.7-0 librsvg2-2 librsvg2-common
  libsensors4 libsm6 libsoup-gnome2.4-1 libsoup2.4-1 libthai-data libthai0
  libtiff5 libtxc-dxtn-s2tc libwacom-bin libwacom-common libwacom2
  libwayland-client0 libwayland-cursor0 libwayland-egl1-mesa
  libwayland-server0 libx11-6 libx11-data libx11-xcb1 libxatracker2 libxau6
  libxaw7 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0 libxcb-present0
  libxcb-render0 libxcb-shm0 libxcb-sync1 libxcb-util0 libxcb-xfixes0 libxcb1
  libxcomposite1 libxcursor1 libxdamage1 libxdmcp6 libxext6 libxfixes3
  libxfont1 libxfont2 libxi6 libxinerama1 libxkbcommon0 libxkbfile1
  libxklavier16 libxml2 libxmu6 libxmuu1 libxpm4 libxrandr2 libxrender1
  libxshmfence1 libxss1 libxt6 libxtst6 libxv1 libxvmc1 libxxf86vm1
  lightdm-gtk-greeter policykit-1 sgml-base shared-mime-info ucf x11-common
  x11-xkb-utils xauth xdg-user-dirs xfonts-base xfonts-encodings xfonts-utils
  xkb-data xml-core xserver-common xserver-xorg xserver-xorg-core
  xserver-xorg-input-all xserver-xorg-input-libinput xserver-xorg-input-wacom
  xserver-xorg-video-all xserver-xorg-video-amdgpu xserver-xorg-video-ati
  xserver-xorg-video-fbdev xserver-xorg-video-intel xserver-xorg-video-nouveau
  xserver-xorg-video-qxl xserver-xorg-video-radeon xserver-xorg-video-vesa
  xserver-xorg-video-vmware


Sat Apr 29 14:15:19 CST 2017补充:
aptitude输入问号可以看到除了y/n以外的用法,其中包括修改当前行为的功能


_________________
Linux桌面优化综合贴[2017.09.18](欢迎各位补充或指正误区)
[2016.03.10]会C语言但看不懂英文文档的点这里,一个用C语言编写的简陋学习工具
单硬盘通过iso文件实机安装Debian的方法
重启或操作fcitx时失去响应的一个解决方法,不妨试试看


最后由 科学之子 编辑于 2017-04-29 14:16,总共编辑了 3 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: Debian安装包时提示"下列XX包将安装"时如何只选择部分包进行安装?
帖子发表于 : 2017-04-27 20:07 

注册: 2009-08-04 16:33
帖子: 16721
送出感谢: 21
接收感谢: 1816
https://manpages.debian.org/jessie/apt/ ... .8.en.html
--no-install-recommends
Do not consider recommended packages as a dependency for installing. Configuration Item: APT::Install-Recommends.

加 --no-install-recommends 參數
需要的 recommends 另外手動再安裝


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Debian安装包时提示"下列XX包将安装"时如何只选择部分包进行安装?
帖子发表于 : 2017-04-27 20:46 

注册: 2013-05-26 6:58
帖子: 2128
系统: Debian 9
送出感谢: 874
接收感谢: 29
poloshiao 写道:
https://manpages.debian.org/jessie/apt/apt-get.8.en.html
--no-install-recommends
Do not consider recommended packages as a dependency for installing. Configuration Item: APT::Install-Recommends.

加 --no-install-recommends 參數
需要的 recommends 另外手動再安裝

我并不想手动安装recommends,因为我对包的理解很有限
但同时我确定一些recommends我并不需要

记得arch的pacman可以让我在安装时选择是否安装某些包
Thu Apr 27 23:40:49 CST 2017补充:
而且这么做的话,可能depends的recommends也会被忽略?


_________________
Linux桌面优化综合贴[2017.09.18](欢迎各位补充或指正误区)
[2016.03.10]会C语言但看不懂英文文档的点这里,一个用C语言编写的简陋学习工具
单硬盘通过iso文件实机安装Debian的方法
重启或操作fcitx时失去响应的一个解决方法,不妨试试看


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译