Ubuntu中文论坛
http://forum.ubuntu.org.cn/

求助:Debian 8 i386 升级到 9.3后,象棋游戏gmchess 无法启动
http://forum.ubuntu.org.cn/viewtopic.php?f=165&t=486408
分页: 1 / 1

作者:  careone [ 2018-01-12 17:04 ]
文章标题 :  求助:Debian 8 i386 升级到 9.3后,象棋游戏gmchess 无法启动

求助:Debian 8.9 i386 升级到 9.3后,象棋游戏gmchess 无法启动

报错:
引用:
gmchess: symbol lookup error: gmchess: undefined symbol: _ZN3Gtk7Builder16create_from_fileERKSsPKc

是因为 python 版本升级造成的问题,还是 Linux 内核的问题?

试过下面两个内核版本,都是无法启动 Gmchess:
* linux-image-3.16.0-4-686-pae 3.16.43-2+deb8u2 (Debian 8.9 自带的内核版本)
* linux-image-4.9.0-4-686-pae 4.9.65-3+deb9u1 (Debian 9.3 自带的内核版本)

有没有朋友遇到同样的问题?或者有什么解决办法?

作者:  科学之子 [ 2018-01-13 13:45 ]
文章标题 :  Re: 求助:Debian 8 i386 升级到 9.3后,象棋游戏gmchess 无法启动

个人根据直觉猜测是python的问题.
为了达到最好的兼容性,python2和3应该同时装上.
或者检查一下对应py脚本里的第一行指定的解释器,看版本是否正确.
解决办法就是想办法指定正确的版本.
比如直接用python2/3(正确版本)来运行main.py 之类

作者:  科学之子 [ 2018-01-14 17:05 ]
文章标题 :  Re: 求助:Debian 8 i386 升级到 9.3后,象棋游戏gmchess 无法启动

刚开始看楼主描述以为是Python程序.
"aptitude show gmchess"看了一下,貌似是C++写的.
重新做了一些搜索,希望对您有所帮助.
https://www.google.com/search?newwindow ... hETkwMy_YQ
http://gdwarner.blogspot.com/2009/03/c- ... error.html

分页: 1 / 1 当前时区为 UTC + 8 小时
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/