32位系统安装Android Studio时遇到"Unable to run mksdcard SDK tool."?

最大的社区版本,Ubuntu的发源地
回复
科学之子
帖子: 2270
注册时间: 2013-05-26 6:58
系统: Debian 9
送出感谢: 846 次
接收感谢: 30 次

32位系统安装Android Studio时遇到"Unable to run mksdcard SDK tool."?

#1

帖子 科学之子 » 2018-02-08 23:19

32位系统安装Android Studio时遇到"Unable to run mksdcard SDK tool."?
网上搜索这个提示都说是缺32位的库,但我系统本身就是32位的
而且我试了试,全部都是已安装:

代码: 全选

$ sudo aptitude install libz1 libncurses5 libbz2-1.0 libstdc++6
libncurses5 is already installed at the requested version (6.0+20161126-1+deb9u1)
libbz2-1.0 is already installed at the requested version (1.0.6-8.1)
libstdc++6 is already installed at the requested version (6.3.0-18)
libncurses5 is already installed at the requested version (6.0+20161126-1+deb9u1)
libbz2-1.0 is already installed at the requested version (1.0.6-8.1)
libstdc++6 is already installed at the requested version (6.3.0-18)
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
Fri Feb 9 12:41:33 CST 2018补充:
{本帖的系统环境是Debian 9
此外我还试了试:

代码: 全选

~/Android/Sdk/tools$ ldd ./mksdcard 
	linux-gate.so.1 (0xb7eeb000)
	libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xb7eb6000)
	libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xb7cfe000)
	/lib/ld-linux.so.2 (0xb7eed000)
~/Android/Sdk/tools$ 
给出来的文件路径经过apt-file搜索都是已经安装了的
我甚至通过文件名还找到了libx32gcc1和libc6-x32,也装上了,重试还是失败.
然后
file ~/Android/Sdk/emulator/* 貌似发现一堆64bit可执行文件:

代码: 全选

~/Android/Sdk/emulator$ file *
bin64:                    directory
emulator:                 ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.24, stripped
emulator64-arm:           ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.24, stripped
emulator64-crash-service: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.24, stripped
emulator64-mips:          ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.24, stripped
emulator64-x86:           ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.24, stripped
emulator-check:           ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.24, stripped
lib:                      directory
lib64:                    directory
mksdcard:                 POSIX shell script, ASCII text executable
mksdcard.origin:          ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.24, BuildID[sha1]=b02071aed64d5776bed3896685cb5081740eda4a, not stripped
NOTICE.txt:               ASCII text
package.xml:              XML 1.0 document, ASCII text, with very long lines
qemu:                     directory
resources:                directory
source.properties:        ASCII text
我把mksdcard替换成了一个beep脚本,结果重试时主板蜂鸣器真的响了.
猜测是相关文件只支持64bit系统或打包失误.
到谷歌上搜索时自动补全的关键词:
https://www.google.com/search?newwindow ... oOBPp8KoI0
貌似已经不推荐使用了.
32bit 系统还有办法吗?还是只能改用第三方模拟器?
}
上次由 科学之子 在 2018-02-09 14:46,总共编辑 2 次。
poloshiao
论坛版主
帖子: 18277
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1950 次

Re: 32位系统安装Android Studio时遇到"Unable to run mksdcard SDK tool

#2

帖子 poloshiao » 2018-02-09 11:24

我系统本身就是32位的
記得你是使用 Debian 9 ?
請提供完整的作業系統及版本 以免讓你白忙
这些用户感谢了作者 poloshiao 于这个帖子:
科学之子 (2018-02-09 14:47)
评价: 3.7%
科学之子
帖子: 2270
注册时间: 2013-05-26 6:58
系统: Debian 9
送出感谢: 846 次
接收感谢: 30 次

Re: 32位系统安装Android Studio时遇到"Unable to run mksdcard SDK tool

#3

帖子 科学之子 » 2018-02-09 14:49

poloshiao 写了:
我系统本身就是32位的
記得你是使用 Debian 9 ?
請提供完整的作業系統及版本 以免讓你白忙
感谢提醒.
我用的是Debian 9.
更多信息已经在1楼补充.
poloshiao
论坛版主
帖子: 18277
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1950 次

Re: 32位系统安装Android Studio时遇到"Unable to run mksdcard SDK tool

#4

帖子 poloshiao » 2018-02-09 15:08

我用的是Debian 9
試試
先安裝 lib32stdc++6

資料來源
https://linuxconfig.org/how-to-install- ... etch-linux
How to Install Android Studio on Debian 9 Stretch Linux
最下方
Appendix
Error message:
Unable to run mksdcard SDK tool.
The resolve the above issue install lib32stdc++6:
# apt-get install lib32stdc++6
科学之子
帖子: 2270
注册时间: 2013-05-26 6:58
系统: Debian 9
送出感谢: 846 次
接收感谢: 30 次

Re: 32位系统安装Android Studio时遇到"Unable to run mksdcard SDK tool

#5

帖子 科学之子 » 2018-02-10 12:45

poloshiao 写了:
我用的是Debian 9
試試
先安裝 lib32stdc++6

資料來源
https://linuxconfig.org/how-to-install- ... etch-linux
How to Install Android Studio on Debian 9 Stretch Linux
最下方
Appendix
Error message:
Unable to run mksdcard SDK tool.
The resolve the above issue install lib32stdc++6:
# apt-get install lib32stdc++6
在我的环境下我的系统没有这个包,可能因为我安装的Debian本身就是32位的关系
我这里有'libstdc++6'并且已经安装了.
回复

回到 “Debian发行版”