搬瓦工买的vps搭建好ss,但不能上网

Linux VPS 支持
回复
mylw
帖子: 25
注册时间: 2013-09-21 12:21
系统: 13.04
送出感谢: 0
接收感谢: 0

搬瓦工买的vps搭建好ss,但不能上网

#1

帖子 mylw » 2017-09-17 7:47

搬瓦工买的vps搭建好ss,但不能上网。
IMG_0506.JPG
11
ip 104.255.152.166的vps,用自带的Shadowsocks server已搭配好ss服务,端口1025,
然后在本机安装Shadowsocks,配置文件:
IMG_0507.JPG
12
自己电脑ss连接服务器
IMG_0509.JPG
12
浏览器也设置代理
IMG_0510.JPG
12
访问google终端的信息,但不能访问
IMG_0511.JPG
12
江苏电信和移动ping 104.255.152.166 一般time=282左右浮动
不能上网怎么解决?哪位能帮忙指点下!
上次由 mylw 在 2017-09-17 21:33,总共编辑 1 次。
头像
九天星
帖子: 1317
注册时间: 2007-07-14 20:45
送出感谢: 67 次
接收感谢: 37 次

Re: 搬瓦工买的vps搭建好ss,但不能上网

#2

帖子 九天星 » 2017-09-17 8:44

浏览器也设置socks主机代理127.0.0.1: 1026
你浏览器这么设置的意思是什么?
开源、共享、自由

微信号非公众号:xfiles_sky

用手机点击这里有奇迹发生,其他无效
mylw
帖子: 25
注册时间: 2013-09-21 12:21
系统: 13.04
送出感谢: 0
接收感谢: 0

Re: 搬瓦工买的vps搭建好ss,但不能上网

#3

帖子 mylw » 2017-09-17 13:36

九天星 写了:
浏览器也设置socks主机代理127.0.0.1: 1026
你浏览器这么设置的意思是什么?
浏览器设置代理
头像
qy117121
论坛版主
帖子: 49936
注册时间: 2007-12-14 13:40
系统: Winbuntu
来自: 志虚国乌由市
送出感谢: 17 次
接收感谢: 332 次
联系:

Re: 搬瓦工买的vps搭建好ss,但不能上网

#4

帖子 qy117121 » 2017-09-17 17:13

你本地运行了55客户端了没,怎么感觉你是在服务器上运行的客户端
渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu
mylw
帖子: 25
注册时间: 2013-09-21 12:21
系统: 13.04
送出感谢: 0
接收感谢: 0

Re: 搬瓦工买的vps搭建好ss,但不能上网

#5

帖子 mylw » 2017-09-17 20:22

qy117121 写了:你本地运行了55客户端了没,怎么感觉你是在服务器上运行的客户端
什么是55客户端?
vps上配置好shadowsocks服务,自己电脑也安装了shadowsocks作为客户端,参考网上教程的,但上不了google等网站。
头像
qy117121
论坛版主
帖子: 49936
注册时间: 2007-12-14 13:40
系统: Winbuntu
来自: 志虚国乌由市
送出感谢: 17 次
接收感谢: 332 次
联系:

Re: 搬瓦工买的vps搭建好ss,但不能上网

#6

帖子 qy117121 » 2017-09-17 21:22

代码: 全选

sslocal -c /etc/shadowsocks.json
INFO: loading config from /etc/shadowsocks.json
2017-09-17 07:34:49 INFO loading libcrypto from libcrypto.so.1.0.0
2017-09-17 07:34:49 INFO starting local at 127.0.0.1:1026
这个是你在vps上运行的? 运行这个干嘛,这是客户端,
渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu
mylw
帖子: 25
注册时间: 2013-09-21 12:21
系统: 13.04
送出感谢: 0
接收感谢: 0

Re: 搬瓦工买的vps搭建好ss,但不能上网

#7

帖子 mylw » 2017-09-17 21:34

qy117121 写了:

代码: 全选

sslocal -c /etc/shadowsocks.json
INFO: loading config from /etc/shadowsocks.json
2017-09-17 07:34:49 INFO loading libcrypto from libcrypto.so.1.0.0
2017-09-17 07:34:49 INFO starting local at 127.0.0.1:1026
这个是你在vps上运行的? 运行这个干嘛,这是客户端,
现在上传了图片,在我自己电脑上运行的
头像
九天星
帖子: 1317
注册时间: 2007-07-14 20:45
送出感谢: 67 次
接收感谢: 37 次

Re: 搬瓦工买的vps搭建好ss,但不能上网

#8

帖子 九天星 » 2017-09-18 10:39

Nmap scan report for 104.255.152.166
Host is up (0.21s latency).
Not shown: 998 filtered ports
PORT STATE SERVICE VERSION
443/tcp open ssl/https ZTE web server 1.0 ZTE corp 2015.
| fingerprint-strings:
| GetRequest:
| HTTP/1.0 200 OK
| Server: ZTE web server 1.0 ZTE corp 2015.
| Accept-Ranges: bytes
| Connection: close
| X-Frame-Options: SAMEORIGIN
| Cache-Control: no-cache,no-store
| Content-Length: 118152
| Set-Cookie: _TESTCOOKIESUPPORT=1; PATH=/; HttpOnly
| Content-Type: text/html; charset=utf-8
| X-Content-Type-Options: nosniff
| X-Frame-Options: SAMEORIGIN
| Content-Security-Policy: default-src 'self' 'unsafe-inline' 'unsafe-eval'; img-src 'self' data:;
| X-XSS-Protection: 1; mode=block
| Set-Cookie: SID=;expires=Thu, 01-Jan-1970 00:00:00 GMT;path=/;
| <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/transitional.dtd">
| <html xmlns="http://www.w3.org/1999/xhtml">
| <head>
| <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
| <meta http-equiv="X-UA-Compatible" content="IE=edge">
| <link rel="shortcut icon" href="/img/favicon.ico" />
| <title>&#72;&#50;&#54;&
| HTTPOptions:
| HTTP/1.1 501 Not Implemented
| Server: ZTE web server 1.0 ZTE corp 2015.
| Accept-Ranges: bytes
| Connection: close
| X-Frame-Options: SAMEORIGIN
| Content-Type: text/html; charset=iso-8859-1
| X-Content-Type-Options: nosniff
| Cache-Control: no-cache,no-store
| <html>
| <head><title>501 Not Implemented</title></head>
| <body bgcolor="#FFFFFF" text="#000000" link="#2020ff" vlink="#4040cc">
| <h2>501 Not Implemented</h2>
| requested method is not implemented by this server.
| <div style="display:none">
| <ajax_response_xml_root>
| <IF_ERRORSTR>SessionTimeout</IF_ERRORSTR>
| <IF_ERRORPARAM>SUCC</IF_ERRORPARAM>
| <IF_ERRORTYPE>SUCC</IF_ERRORTYPE>
| </ajax_response_xml_root>
|_ <span>Padding so that MSIE deigns to show this error inste
|_http-server-header: ZTE web server 1.0 ZTE corp 2015.
| ssl-cert: Subject: commonName=192.168.1.1/organizationName=ZTE/stateOrProvinceName=JiangSu/countryName=CN
| Issuer: commonName=ZTE-ROOT-CA/organizationName=ZTE/stateOrProvinceName=GuangDong/countryName=CN
| Public Key type: rsa
| Public Key bits: 1024
| Signature Algorithm: sha1WithRSAEncryption
| Not valid before: 2013-05-03T09:10:17
| Not valid after: 2023-05-01T09:10:17
| MD5: e238 90e1 9bc0 9d19 b804 84c8 b67a 73b3
|_SHA-1: bd3a bff2 348e 8c46 63b3 34a0 40ae 97fd bd07 e01c
55555/tcp open unknown
| fingerprint-strings:
| GenericLines:
| HTTP/1.1 400 Bad Request
| Server: ZTE web server 1.0 ZTE corp 2015.
| Accept-Ranges: bytes
| Connection: close
| X-Frame-Options: SAMEORIGIN
| Content-Type: text/html; charset=iso-8859-1
| X-Content-Type-Options: nosniff
| Cache-Control: no-cache,no-store
| <html>
| <head><title>400 Bad Request</title></head>
| <body bgcolor="#FFFFFF" text="#000000" link="#2020ff" vlink="#4040cc">
| <h2>400 Bad Request</h2>
| Your request has bad syntax or is inherently impossible to satisfy.
| <div style="display:none">
| <ajax_response_xml_root>
| <IF_ERRORSTR>SessionTimeout</IF_ERRORSTR>
| <IF_ERRORPARAM>SUCC</IF_ERRORPARAM>
| <IF_ERRORTYPE>SUCC</IF_ERRORTYPE>
| </ajax_response_xml_root>
| <span>Padding so that MSIE deigns to show this error inste
| GetRequest:
| HTTP/1.0 200 OK
| Server: ZTE web server 1.0 ZTE corp 2015.
| Accept-Ranges: bytes
| Connection: close
| X-Frame-Options: SAMEORIGIN
| Cache-Control: no-cache,no-store
| Content-Length: 118152
| Set-Cookie: _TESTCOOKIESUPPORT=1; PATH=/; HttpOnly
| Content-Type: text/html; charset=utf-8
| X-Content-Type-Options: nosniff
| X-Frame-Options: SAMEORIGIN
| Content-Security-Policy: default-src 'self' 'unsafe-inline' 'unsafe-eval'; img-src 'self' data:;
| X-XSS-Protection: 1; mode=block
| Set-Cookie: SID=;expires=Thu, 01-Jan-1970 00:00:00 GMT;path=/;
| <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/transitional.dtd">
| <html xmlns="http://www.w3.org/1999/xhtml">
| <head>
| <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
| <meta http-equiv="X-UA-Compatible" content="IE=edge">
| <link rel="shortcut icon" href="/img/favicon.ico" />
|_ <title>&#72;&#50;&#54;&
2 services unrecognized despite returning data. If you know the service/version, please submit the following fingerprints at https://nmap.org/cgi-bin/submit.cgi?new-service :
开源、共享、自由

微信号非公众号:xfiles_sky

用手机点击这里有奇迹发生,其他无效
zywork
帖子: 27
注册时间: 2011-09-21 13:46
送出感谢: 0
接收感谢: 1 次

Re: 搬瓦工买的vps搭建好ss,但不能上网

#9

帖子 zywork » 2017-09-20 17:13

本地电脑ssh连接服务器,然后vi /etc/shadowsocks.json, server那一行改成:"server":"0.0.0.0",就可以上了。
头像
astolia
论坛版主
帖子: 3033
注册时间: 2008-09-18 13:11
送出感谢: 1 次
接收感谢: 500 次

Re: 搬瓦工买的vps搭建好ss,但不能上网

#10

帖子 astolia » 2017-09-20 20:59

如果IMG_0511.JPG那图是你访问google的结果,那显然是你被DNS投毒了。那些IP没一个是google的。
最简单的处理方法是在firefox的代理设置页面最下面选择dns解析也走代理

另外,你把本地的密码填错了,服务器上是8,你本地写成B了
上次由 astolia 在 2017-10-26 21:10,总共编辑 1 次。
onlylove
论坛版主
帖子: 4380
注册时间: 2007-01-14 16:23
送出感谢: 0
接收感谢: 96 次

Re: 搬瓦工买的vps搭建好ss,但不能上网

#11

帖子 onlylove » 2017-09-20 21:02

把配置贴的这么详细是想做啥 :Hehe
头像
qy117121
论坛版主
帖子: 49936
注册时间: 2007-12-14 13:40
系统: Winbuntu
来自: 志虚国乌由市
送出感谢: 17 次
接收感谢: 332 次
联系:

Re: 搬瓦工买的vps搭建好ss,但不能上网

#12

帖子 qy117121 » 2017-09-20 21:20

BWG是有好几个机房的吧,楼主换个西海岸的吧,这个延迟也太大了
渠月 · QY

本人只会灌水,不负责回答问题

无聊可以点一下→ http://u.nu/ubuntu
头像
tynh_19901005
帖子: 23
注册时间: 2011-05-09 21:23
送出感谢: 5 次
接收感谢: 0

Re: 搬瓦工买的vps搭建好ss,但不能上网

#13

帖子 tynh_19901005 » 2017-10-26 8:31

其实我遇到过,可以上谷歌但是其他的油管啥的不能用。 是dns被污染的原因。 在火狐浏览器中输入about:config 进入配置页面network.proxy.socks_remote_dns 修改为true就可以了。
do
{
do what make you happy;
}
while(!unreach my dreams);
回复

回到 “Ubuntu VPS”