怎么装fvwm2.6呢

讨论openbox,awesome,FVWM等WM
回复
reallynotme
帖子: 157
注册时间: 2010-11-11 18:13
系统: Ubuntu
送出感谢: 0
接收感谢: 4 次

怎么装fvwm2.6呢

#1

帖子 reallynotme » 2013-02-11 12:27

源里面是2.5版本的,既然2.6出来了,就想用新的.
自己尝试编译安装,但是总是有个

代码: 全选

With GTK+ required for FvwmGtk?     no: Failed to detect GTK, see config.log
在新立得里装了不少libgtk的包,都解决不了
头像
AutoXBC
帖子: 1750
注册时间: 2007-10-23 12:54
送出感谢: 2 次
接收感谢: 24 次

Re: 怎么装fvwm2.6呢

#2

帖子 AutoXBC » 2013-02-11 12:59

编译安装需要预先配置编译环境,执行这个命令

代码: 全选

sudo apt-get build-dep fvwm
自己编译也没什么好处,不如直接从开发版的仓库安装现成的
http://mirrors.sohu.com/ubuntu/pool/universe/f/fvwm/
reallynotme
帖子: 157
注册时间: 2010-11-11 18:13
系统: Ubuntu
送出感谢: 0
接收感谢: 4 次

Re: 怎么装fvwm2.6呢

#3

帖子 reallynotme » 2013-02-11 13:13

代码: 全选

sudo apt-get build-dep fvwm
之前已经试过了,还是不行

我在你给的网址里下了"fvwm_2.6.5.ds-1_amd64.deb"
但是提示"依赖关系不满足 libfontconfig1 (>=2.9.0)"
这个怎么解决呢?
我用的是12.04
reallynotme
帖子: 157
注册时间: 2010-11-11 18:13
系统: Ubuntu
送出感谢: 0
接收感谢: 4 次

Re: 怎么装fvwm2.6呢

#4

帖子 reallynotme » 2013-02-11 14:18

reallynotme 写了:

代码: 全选

sudo apt-get build-dep fvwm
之前已经试过了,还是不行

我在你给的网址里下了"fvwm_2.6.5.ds-1_amd64.deb"
但是提示"依赖关系不满足 libfontconfig1 (>=2.9.0)"
这个怎么解决呢?
我用的是12.04
已经装了的libfontconfig1是2.8.0的,算了,先用2.5吧
头像
AutoXBC
帖子: 1750
注册时间: 2007-10-23 12:54
送出感谢: 2 次
接收感谢: 24 次

Re: 怎么装fvwm2.6呢

#5

帖子 AutoXBC » 2013-02-11 14:50

不打算折腾了?
fvwm (1:2.5.26-2) unstable; urgency=low

* [debiandir:e2d7ea6]: Remove the gtk build dependencies, and do not
look for gtk The menus used in Fvwm can either be native, or, using
FvwmGTK, be GTK-based alternatives. FvwmGtk only has options to define
the content of the menus and dialogs. The builtin menus offer many
features which the GTK menus currently don’t have. None of the
features of the builtin window-list have been implemented. FvwmGtk
module requires GTK+ and optionally GDK-Imlib and GNOME libraries.
GDK-Imlib library that is a part of Imlib version 1 is used to have
images. Most of thee libraries are not obsolete, and development of
FvwmGtk module does not seem to be keeping up. Note, fvwm itself has
an ability to support GNOME Window Manager hints (which is enabled by
default), this has nothing to do with GNOME library support compiled
into FvwmGtk (which is autoprobed and used if passed). In this commit,
we disable autoprobing of GTK+, Imlib and GNOME libraries. This is a
imperceptible change in functionality.

-- Manoj Srivastava <srivasta@debian.org> Sun, 21 Dec 2008 11:38:00 -0600
大意是说 debian 打了个补丁使得编译不需要 gtk 依赖?然后说了一堆不知道什么意思的理由。

那么在 ubuntu 下编译除了要配置编译环境外,最好还要用打过补丁的源码。步骤大概是这样:

1) 下载源码包,补丁包,描述文件
就是上面那个网址里这几个 fvwm_2.6.5.ds-1.debian.tar.gz , fvwm_2.6.5.ds-1.dsc , fvwm_2.6.5.ds.orig.tar.gz
2) 解压源码包并打补丁,注意不是普通的命令
dpkg-source -x fvwm_2.6.5.ds-1.dsc
3) 编辑依赖描述文件,把 libfontconfig 版本号改小
debian/control
3) 专用的编译命令
fakeroot debian/rules binary
4) 安装生成的 deb 文件
sudo gdebi foo.deb

前提是 fvwm 的源码和补丁真的不依赖那么高版本的 libfontconfig,不然仅仅改配置文件是不行的。
回复

回到 “窗口管理器”