编译e17中的emotion时出现以下错误...

讨论openbox,awesome,FVWM等WM
回复
头像
IsoaSFlus
帖子: 366
注册时间: 2012-11-13 11:30
系统: ubuntu17.10,Arch
送出感谢: 5 次
接收感谢: 4 次
联系:

编译e17中的emotion时出现以下错误...

#1

帖子 IsoaSFlus » 2013-04-04 12:33

代码: 全选

edje_cc: Critical. Unable to load image "tiles.png" used by file "../data/theme.edj": File (or file path) does not exist. Check if path to file "tiles.png" is correct (both directory and file name).
以上,有没有人也出现过这种错误呢?求解决方法,谢谢。
头像
IsoaSFlus
帖子: 366
注册时间: 2012-11-13 11:30
系统: ubuntu17.10,Arch
送出感谢: 5 次
接收感谢: 4 次
联系:

Re: 编译e17中的emotion时出现以下错误...

#3

帖子 IsoaSFlus » 2013-04-04 23:38

photor 写了::em06
嗯...几乎每次发和e17有关的贴都见得到你,感谢你多次以来的帮助.
头像
photor
论坛版主
帖子: 11003
注册时间: 2008-04-26 12:41
送出感谢: 8 次
接收感谢: 36 次

Re: 编译e17中的emotion时出现以下错误...

#4

帖子 photor » 2013-04-04 23:50

IsoaSFlus 写了:
photor 写了::em06
嗯...几乎每次发和e17有关的贴都见得到你,感谢你多次以来的帮助.
我也是菜鸟,解决不了你的问题,只能帮顶了 :em09
头像
IsoaSFlus
帖子: 366
注册时间: 2012-11-13 11:30
系统: ubuntu17.10,Arch
送出感谢: 5 次
接收感谢: 4 次
联系:

Re: 编译e17中的emotion时出现以下错误...

#5

帖子 IsoaSFlus » 2013-04-05 8:14

photor 写了:
IsoaSFlus 写了:
photor 写了::em06
嗯...几乎每次发和e17有关的贴都见得到你,感谢你多次以来的帮助.
我也是菜鸟,解决不了你的问题,只能帮顶了 :em09
好吧,我记得论坛里面不是有人编译成功过的么?
头像
lizefeng1996
帖子: 49
注册时间: 2011-12-31 20:27
系统: ubuntu Kubuntu
送出感谢: 10 次
接收感谢: 1 次

Re: 编译e17中的emotion时出现以下错误...

#6

帖子 lizefeng1996 » 2013-07-16 19:28

我编译成功了,按这个顺序来
1:eet
2:evas
3:ecore
4:embryo
5:elem什么玩意。。
然后是e17

但是编译完成后需要在/usr/share/xse[TAB](补全一下啦,忘了那个目录叫什么了 )目录中自己写一个e17.desktop的文件,内容修改其他的两个文件就行了,运行命令这样写enlightenment_start,不知道的直接#注释掉,名称是必填的
注销登录应该就能看到多了一个选项

我进去后发现没特效,而且不支持混合,说我少了编译选项。从官方可以下载到deb包,发个链接吧
https://launchpad.net/~efl/+archive/trunk
rgba(0, 0, 0, 0.73)
panel coner
头像
lizefeng1996
帖子: 49
注册时间: 2011-12-31 20:27
系统: ubuntu Kubuntu
送出感谢: 10 次
接收感谢: 1 次

Re: 编译e17中的emotion时出现以下错误...

#7

帖子 lizefeng1996 » 2013-07-16 19:32

:em06 忘说了,官方的链接没问题,但不要安装entrance登录管理器
rgba(0, 0, 0, 0.73)
panel coner
头像
IsoaSFlus
帖子: 366
注册时间: 2012-11-13 11:30
系统: ubuntu17.10,Arch
送出感谢: 5 次
接收感谢: 4 次
联系:

Re: 编译e17中的emotion时出现以下错误...

#8

帖子 IsoaSFlus » 2013-07-16 19:44

lizefeng1996 写了::em06 忘说了,官方的链接没问题,但不要安装entrance登录管理器
额……感谢你的好意……但现在我有了台新电脑……暂时用不到e17了……老电脑换成arch了……不准备装x……

Sent from my Galaxy S2 using Tapatalk 2
头像
photor
论坛版主
帖子: 11003
注册时间: 2008-04-26 12:41
送出感谢: 8 次
接收感谢: 36 次

Re: 编译e17中的emotion时出现以下错误...

#9

帖子 photor » 2013-07-16 21:16

lizefeng1996 写了:我编译成功了,按这个顺序来
1:eet
2:evas
3:ecore
4:embryo
5:elem什么玩意。。
然后是e17

但是编译完成后需要在/usr/share/xse[TAB](补全一下啦,忘了那个目录叫什么了 )目录中自己写一个e17.desktop的文件,内容修改其他的两个文件就行了,运行命令这样写enlightenment_start,不知道的直接#注释掉,名称是必填的
注销登录应该就能看到多了一个选项

我进去后发现没特效,而且不支持混合,说我少了编译选项。从官方可以下载到deb包,发个链接吧
https://launchpad.net/~efl/+archive/trunk
5那个叫elementary,是EFL的高级图形控件库,类似于GTK和QT的控件库,看官方的这个结构图就很清楚了:
图片 :em09
头像
lizefeng1996
帖子: 49
注册时间: 2011-12-31 20:27
系统: ubuntu Kubuntu
送出感谢: 10 次
接收感谢: 1 次

Re: 编译e17中的emotion时出现以下错误...

#10

帖子 lizefeng1996 » 2013-07-17 11:37

photor 写了:
lizefeng1996 写了:我编译成功了,按这个顺序来
1:eet
2:evas
3:ecore
4:embryo
5:elem什么玩意。。
然后是e17

但是编译完成后需要在/usr/share/xse[TAB](补全一下啦,忘了那个目录叫什么了 )目录中自己写一个e17.desktop的文件,内容修改其他的两个文件就行了,运行命令这样写enlightenment_start,不知道的直接#注释掉,名称是必填的
注销登录应该就能看到多了一个选项

我进去后发现没特效,而且不支持混合,说我少了编译选项。从官方可以下载到deb包,发个链接吧
<!-- m --><a class="postlink" href="https://launchpad.net/~efl/+archive/tru ... e/trunk</a><!-- m -->
5那个叫elementary,是EFL的高级图形控件库,类似于GTK和QT的控件库,看官方的这个结构图就很清楚了:
图片 :em09
:em02 我也是看着那个编译的,但是现在有个出人意料的问题————
:em06 在使用terminology的时候,它嵌入在一个正常窗口内,那个正常的大窗口不能关闭、调整大小 标题栏上写的是:ecore_evas_EWS 什么什么,那台电脑没联网,所以不能发截图了, :em06 在谷歌上找到了开发者的帖子,看懂了一部分,大概意思就是那个ews是一个很好的解决方案,但是我实在不想要, :em20
photor 快救命啊,那个终端我太喜欢了,实在不想用G3的取代,除了不能输入中文以外(其实写代码都在fbterm里面啦)简直太惊艳了。。。
photor 求解释啊 :em03 我是下了无数个deb包用dpkg安装的
rgba(0, 0, 0, 0.73)
panel coner
头像
photor
论坛版主
帖子: 11003
注册时间: 2008-04-26 12:41
送出感谢: 8 次
接收感谢: 36 次

Re: 编译e17中的emotion时出现以下错误...

#11

帖子 photor » 2013-07-18 11:38

lizefeng1996 写了:
photor 写了:
lizefeng1996 写了:我编译成功了,按这个顺序来
1:eet
2:evas
3:ecore
4:embryo
5:elem什么玩意。。
然后是e17

但是编译完成后需要在/usr/share/xse[TAB](补全一下啦,忘了那个目录叫什么了 )目录中自己写一个e17.desktop的文件,内容修改其他的两个文件就行了,运行命令这样写enlightenment_start,不知道的直接#注释掉,名称是必填的
注销登录应该就能看到多了一个选项

我进去后发现没特效,而且不支持混合,说我少了编译选项。从官方可以下载到deb包,发个链接吧
<!-- m --><a class="postlink" href="https://launchpad.net/~efl/+archive/tru ... e/trunk</a><!-- m -->
5那个叫elementary,是EFL的高级图形控件库,类似于GTK和QT的控件库,看官方的这个结构图就很清楚了:
图片 :em09
:em02 我也是看着那个编译的,但是现在有个出人意料的问题————
:em06 在使用terminology的时候,它嵌入在一个正常窗口内,那个正常的大窗口不能关闭、调整大小 标题栏上写的是:ecore_evas_EWS 什么什么,那台电脑没联网,所以不能发截图了, :em06 在谷歌上找到了开发者的帖子,看懂了一部分,大概意思就是那个ews是一个很好的解决方案,但是我实在不想要, :em20
photor 快救命啊,那个终端我太喜欢了,实在不想用G3的取代,除了不能输入中文以外(其实写代码都在fbterm里面啦)简直太惊艳了。。。
photor 求解释啊 :em03 我是下了无数个deb包用dpkg安装的
这个我可帮不了你,你可以直接跟那个开发者交流噻 :em06
terminology现在bug太多,毕竟才0.3版,我还是先等等 :em09
回复

回到 “窗口管理器”