当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 升级10.04b1后一直有一些软件无法更新,为什么?
帖子发表于 : 2010-04-04 8:22 
头像

注册: 2008-03-12 8:41
帖子: 578
地址: nenu.Ani
送出感谢: 4
接收感谢: 3
sudo aptitude safe-upgrade

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成
下列软件包已经被阻止升级:
blender ffmpeg gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad kino
libavdevice52{a} libavfilter0{a} libavformat52{a} libpostproc51{a}
libquicktime1{a} libswscale0{a} libsynfig0{a}
0 个软件包被升级,新安装 0 个, 0 个将被删除, 同时 12 个将不升级。
需要获取 0B 的存档。 解包后将要使用 0B。
正在编辑扩展状态信息... 完成
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
正在读取扩展状态文件
正在初始化软件包状态... 完成
——————————————
在新力得选择升级blender,提示

blender:
依赖: libavcodec52 但是此软件包将不会被安装 或者
libavcodec-extra-52 (>=4:0.5+svn20090706-3) 但是 4:0.5+svn20090706-2ubuntu3 将会被安装
依赖: libavdevice52 (>=4:0.5+svn20090706-3) 但是 4:0.5+svn20090706-2ubuntu2 将会被安装 或者
libavdevice-extra-52 (>=4:0.5+svn20090706-3) 但是此软件包不能安装
依赖: libavformat52 (>=4:0.5+svn20090706-3) 但是 4:0.5+svn20090706-2ubuntu2 将会被安装 或者
libavformat-extra-52 (>=4:0.5+svn20090706-3) 但是此软件包不能安装
依赖: libavutil49 但是此软件包将不会被安装 或者
libavutil-extra-49 (>=4:0.5+svn20090706-3) 但是 4:0.5+svn20090706-2ubuntu3 将会被安装
依赖: libswscale0 (>=4:0.5+svn20090706-3) 但是 4:0.5+svn20090706-2ubuntu2 将会被安装 或者
libswscale-extra-0 (>=4:0.5+svn20090706-3) 但是此软件包不能安装


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 升级10.04b1后一直有一些软件无法更新,为什么?
帖子发表于 : 2010-04-04 8:51 
头像

注册: 2008-03-25 15:49
帖子: 25877
地址: 谁知道?
送出感谢: 8
接收感谢: 10
手动装 :?


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 升级10.04b1后一直有一些软件无法更新,为什么?
帖子发表于 : 2010-04-04 9:01 
头像

注册: 2008-03-12 8:41
帖子: 578
地址: nenu.Ani
送出感谢: 4
接收感谢: 3
手动装libavcodec52 ,提示
依赖: libavutil49 但是此软件包将不会被安装

手动装libavutil49,提示
附件:
Screenshot-无标题窗口.png
Screenshot-无标题窗口.png [ 31.99 KiB | 被浏览 895 次 ]


我滴天,都是兄弟,怎么就不能共存呢,9.10里明明好好的阿,住新房怎么还打起来了?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 升级10.04b1后一直有一些软件无法更新,为什么?
帖子发表于 : 2010-04-04 9:08 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
依赖变了,看情况吧,等等吧


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 升级10.04b1后一直有一些软件无法更新,为什么?
帖子发表于 : 2010-04-04 9:27 
头像

注册: 2008-11-01 20:43
帖子: 17328
系统: 自动检测比较好
送出感谢: 44
接收感谢: 11
等8號


_________________
谁是我?KL.Uiq8 YinMeng


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 升级10.04b1后一直有一些软件无法更新,为什么?
帖子发表于 : 2010-04-04 9:27 
头像

注册: 2008-03-12 8:41
帖子: 578
地址: nenu.Ani
送出感谢: 4
接收感谢: 3
这个问题以前也有人碰到过:

http://forum.ubuntu.org.cn/viewtopic.php?f=74&p=1621273

和10.04无关?


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 升级10.04b1后一直有一些软件无法更新,为什么?
帖子发表于 : 2010-04-10 10:17 
头像

注册: 2008-03-12 8:41
帖子: 578
地址: nenu.Ani
送出感谢: 4
接收感谢: 3
速腾1994 写道:
等8號

都10号了,问题依旧。 :em21


只好手动解决,将所有不能自动升级的包卸载掉,多一个不多
用哪个软件再装,缺依赖包就手动安装

目前障碍清除,blender已经正常安装


安装smplayer,发现
引用:
smplayer:
软件包 smplayer 没有可用的版本,但是存在于数据库中。
这典型地意味着该软件包曾经在一个依赖关系中被提及并且从未上载过,现在已经陈旧或者从 sources.list 目录中无法获得


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 升级10.04b1后一直有一些软件无法更新,为什么?
帖子发表于 : 2011-04-06 20:38 

注册: 2010-01-24 8:31
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
我也遇到了跟你一样的问题~~~不过我是“libavformat52、libpostproc52、libswscale0"这三个软件包无法安装,我的Tweak居然提示有软件包损坏~~~搞不明白了。。。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 升级10.04b1后一直有一些软件无法更新,为什么?
帖子发表于 : 2011-04-07 16:41 
头像

注册: 2008-03-12 8:41
帖子: 578
地址: nenu.Ani
送出感谢: 4
接收感谢: 3
呵呵,一年前的帖子。
用新立得卸载了有问题的包再重装需要的软件,应该行。


_________________
不能假定每个人都爱用命令行。
只要支持Linux的,我们都应该支持。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译