升级了10.04的不能挂移动硬盘的解决方案

Lucid Lynx (长期支持)
回复
wiseberg
帖子: 20
注册时间: 2007-08-01 18:13
送出感谢: 0
接收感谢: 0

升级了10.04的不能挂移动硬盘的解决方案

#1

帖子 wiseberg » 2010-04-04 15:47

开始我以为是kernel的问题,自己下了一个编译好装上也不行,看了maillist,根据alan的说法跟udev有关,由此有人提出干脆关了udev的功能,并实验成功。

这个解决方案是临时的,在我的lucid lynx 64bit版上测试通过:
开个终端,然后执行以下命令:

代码: 全选

cd /lib/udev/rules.d
sudo mv 85-hdparm.rules{,.disabled}

再插拔一下你的移动硬盘,看看如何?
头像
pocoyo
论坛版主
帖子: 25878
注册时间: 2008-03-25 15:49
来自: 谁知道?
送出感谢: 5 次
接收感谢: 9 次
联系:

Re: 升级了10.04的不能挂移动硬盘的解决方案

#2

帖子 pocoyo » 2010-04-04 16:15

没有 不知道
头像
qiang_liu8183
论坛版主
帖子: 10672
注册时间: 2006-09-10 22:36
来自: 北京
送出感谢: 1 次
接收感谢: 6 次

Re: 升级了10.04的不能挂移动硬盘的解决方案

#3

帖子 qiang_liu8183 » 2010-04-04 16:50

楼上太水了
看破、放下、自在、随缘、念佛
真诚、清净、平等、正觉、慈悲
头像
nlr
帖子: 472
注册时间: 2009-04-27 21:07
来自: 柚香何处闻?
送出感谢: 0
接收感谢: 0

Re: 升级了10.04的不能挂移动硬盘的解决方案

#4

帖子 nlr » 2010-04-04 18:34

我是根据坛里一高手的方法安装GSmartCotrol解决的,先打开再插上移动硬盘,可能也是临时的解决办法。各位可以试试!
OS :Ubuntu13.04
头像
intree
帖子: 105
注册时间: 2008-01-22 19:02
送出感谢: 0
接收感谢: 0

Re: 升级了10.04的不能挂移动硬盘的解决方案

#5

帖子 intree » 2010-04-04 23:00

这么说来,是不是新的Linux版本,包含了udev功能的都会出现这个问题?
calvin.ngei
帖子: 178
注册时间: 2007-10-14 13:22
送出感谢: 0
接收感谢: 0

Re: 升级了10.04的不能挂移动硬盘的解决方案

#6

帖子 calvin.ngei » 2010-04-05 19:15

看来确实是udev的问题了。
在百度上搜索“udev 移动硬盘”关键字,找到一些其他发行版有关udev和不能挂载移动硬盘的网页。

就是这个bug了,我10.04插上移动硬盘出来的信息简直一模一样:
http://ohioloco.ubuntuforums.org/showth ... ?t=1441653
https://bugs.launchpad.net/ubuntu/+sour ... bug/515023
头像
速腾1994
论坛版主
帖子: 17363
注册时间: 2008-11-01 20:43
系统: Arch+gnome
送出感谢: 23 次
接收感谢: 8 次

Re: 升级了10.04的不能挂移动硬盘的解决方案

#7

帖子 速腾1994 » 2010-04-05 19:55

:shock:
头像
wangdu2002
帖子: 13284
注册时间: 2008-12-13 19:39
来自: 物华天宝人杰地灵
送出感谢: 1 次
接收感谢: 6 次

Re: 升级了10.04的不能挂移动硬盘的解决方案

#8

帖子 wangdu2002 » 2010-04-05 19:59

真是怪招迭出啊。。。 :em06
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!
tawie
帖子: 132
注册时间: 2005-10-23 21:46
来自: 深圳
送出感谢: 0
接收感谢: 0

Re: 升级了10.04的不能挂移动硬盘的解决方案

#9

帖子 tawie » 2010-04-05 20:10

楼主的方法有效,就是不知道有没有副作用。
xiaohan863
帖子: 28
注册时间: 2010-03-27 3:45
送出感谢: 0
接收感谢: 0

Re: 升级了10.04的不能挂移动硬盘的解决方案

#10

帖子 xiaohan863 » 2010-04-05 23:35

是可以了,谢谢楼主,但确实不知道这会不会造成其他问题
calvin.ngei
帖子: 178
注册时间: 2007-10-14 13:22
送出感谢: 0
接收感谢: 0

Re: 升级了10.04的不能挂移动硬盘的解决方案

#11

帖子 calvin.ngei » 2010-04-06 7:26

在 livecd 里面 disable 掉 /lib/udev/rules.d/85-hdparm.rules 以后,重启 udev 服务,确实可以挂载移动硬盘了。接着我尝试用 livecd 把系统安装到我的移动硬盘上,装完系统后把移动硬盘上新安装的系统里面的 /lib/udev/rules.d/85-hdparm.rules 也 disable 掉,然后再启动移动硬盘上的 10.04 系统,在登录界面挂住,X一直显示出紫黑色背景和可移动的鼠标指针,但不能出现gdm登录器。按 ctrl+alt+f1 切换到控制台,发现系统停留在待登录状态,显示"login:"等待控制台登录状态。于是敲入用户名想登录进去看看是怎么回事。但是敲完用户名按回车之后一直无反应,不出现要求输入密码的"password:"这一行,控制台登录也挂住了。鼠标键盘都还有反应,但是按caps键无法切换大小写状态,按ctrl+alt+delete也不能重启系统,切换回X,一直在那里挂着显示紫黑色背景不出现gdm,按ctrl+alt+backspace也不能结束X。等了约两分钟,控制台挂住的登录突然出现两行字,大概是说 kernel 什么进程 hang 住了,然后是 /dev/sdb (我的移动硬盘)出现 I/O error,错误跟在 /lib/udev/rules.d/85-hdparm.rules 被 disable 之前不能挂移动硬盘出现的 I/O error 提示一样。还是有问题,没有彻底解决。

PS:不要怀疑我的移动硬盘有问题。我的移动硬盘是完全没有问题的,反复在多个系统里面检查过。不信你们试一试把系统安装到移动硬盘上看看(把grub也安装到移动硬盘上,以启动移动硬盘上的系统)。
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 升级了10.04的不能挂移动硬盘的解决方案

#12

帖子 eexpress » 2010-04-06 8:54

hdparm查询下usb盘,这会导致问题?
没觉得。
● 鸣学
pbus
帖子: 26
注册时间: 2008-09-12 14:00
送出感谢: 0
接收感谢: 0

Re: 升级了10.04的不能挂移动硬盘的解决方案

#13

帖子 pbus » 2011-05-20 23:57

确实好了
能挂载移动硬盘额 :em11
感谢啊。。。。
找了半天
没有草木为剑的本领,却可以有草木为剑的胸襟!
回复

回到 “Ubuntu 10.04 LTS”